Budge Tone 201

Discussion in '3CX Phone System - General' started by SS Limited, Sep 16, 2009.

Thread Status:
Not open for further replies.
  1. SS Limited

    Joined:
    Sep 16, 2009
    Messages:
    4
    Likes Received:
    0
    Has anyone managed to get these phones working with 3CX? Were experiencing trouble with simply getting 3CX setup.

    We are using the following:
    Dedicated machine running 3CX
    1 x Grandstream GXW4104
    6 x Grandstream Budge Tone 201

    After following numerous guides available I believe the machine is setup correctly, extensions are recognised, telephone to telephone calls work however outgoing and incoming calls are not working.

    Below is a sample of the log which makes me think that it could be the phone, any ideas welcome.

    16:24:17.547 [CM503008]: Call(7): Call is terminated

    16:24:17.547 [CM503008]: Call(7): Call is terminated

    16:24:08.343 [CM503007]: Call(7): Device joined: sip:10000@192.168.1.160:5060

    16:24:08.327 [CM503007]: Call(7): Device joined: sip:1006@192.168.1.73:5060;transport=udp

    16:24:08.311 [CM505002]: Gateway:[Grandstream] Device info: Device Not Identified: User Agent not matched; Capabilities:[reinvite, replaces, able-no-sdp, recvonly] UserAgent: [Grandstream GXW4104 (HW 1.1, Ch:8) 1.0.1.10] Transport: [sip:192.168.1.1:5060]

    16:24:08.311 [CM503002]: Call(7): Alerting sip:10000@192.168.1.160:5060

    16:24:05.254 [CM503024]: Call(7): Calling PSTNline:xxxxxxxxxxxx@(Ln.10000@Grandstream)@[Dev:sip:10000@192.168.1.160:5060]

    16:24:05.254 [CM503004]: Call(7): Route 1: PSTNline:xxxxxxxxxxxx@(Ln.10000@Grandstream)@[Dev:sip:10000@192.168.1.160:5060, Dev:sip:10001@192.168.1.160:5062, Dev:sip:10002@192.168.1.160:5064, Dev:sip:10003@192.168.1.160:5066]

    16:24:05.223 [CM503010]: Making route(s) to <sip:xxxxxxxxxxxx@192.168.1.1>

    16:24:05.223 [CM505001]: Ext.1006: Device info: Device Not Identified: User Agent not matched; Capabilities:[reinvite, replaces, able-no-sdp, recvonly] UserAgent: [Grandstream BT200 1.1.6.46] Transport: [sip:192.168.1.1:5060]

    16:24:05.191 [CM503001]: Call(7): Incoming call from Ext.1006 to <sip:xxxxxxxxxxxx@192.168.1.1>

    16:09:53.884 [CM506001]: STUN request to resolve SIP external IP:port mapping is sent to STUN server 75.101.138.128:3478 over Transport 192.168.1.1:5060

    16:04:35.394 [CM503015]: Call(6): Attempt to reach <sip:xxxxxxxxxxxx@192.168.1.1> failed. Reason: Server Failure

    16:04:35.301 [CM503024]: Call(6): Calling PSTNline:xxxxxxxxxxxx@(Ln.10000@Grandstream)@[Dev:sip:10003@192.168.1.160:5066]

    16:04:35.191 [CM503024]: Call(6): Calling PSTNline:xxxxxxxxxxxx@(Ln.10000@Grandstream)@[Dev:sip:10002@192.168.1.160:5064]

    16:04:35.082 [CM503024]: Call(6): Calling PSTNline:xxxxxxxxxxxx@(Ln.10000@Grandstream)@[Dev:sip:10001@192.168.1.160:5062]

    16:04:35.020 [CM503024]: Call(6): Calling PSTNline:xxxxxxxxxxxx@(Ln.10000@Grandstream)@[Dev:sip:10000@192.168.1.160:5060]

    16:04:34.973 [CM503010]: Making route(s) to <sip:xxxxxxxxxxxx@192.168.1.1>

    16:04:34.957 [CM503001]: Call(6): Incoming call from Ext.1006 to <sip:xxxxxxxxxxxx@192.168.1.1>

    15:59:34.876 [CM503008]: Call(5): Call is terminated

    15:59:16.764 [CM503007]: Call(5): Device joined: sip:10000@192.168.1.160:5060

    15:59:16.733 [CM505002]: Gateway:[Grandstream] Device info: Device Not Identified: User Agent not matched; Capabilities:[reinvite, replaces, able-no-sdp, recvonly] UserAgent: [Grandstream GXW4104 (HW 1.1, Ch:8) 1.0.1.10] Transport: [sip:192.168.1.1:5060]


    Thanks in advance

    James
     
  2. leejor

    leejor Well-Known Member

    Joined:
    Jan 22, 2008
    Messages:
    10,573
    Likes Received:
    247
    I would double check your settings in the GXW4104. If you can make Ext to Ext calls, then I would assume, although I could be wrong, that the phones are working OK. Can you make an outgoing call using the 3Cx softphone or any other type of SIP phone? If that fails then it almost certainly points to a configuration problem in the gateway.
     
  3. SS Limited

    Joined:
    Sep 16, 2009
    Messages:
    4
    Likes Received:
    0
    Is there anyway that we can test the system with without the phone? We do not have any other phones available to use unfortunately.

    I am, however fairly confident in that the gateway was setup correctly, I have followed both guides available here (3CX) and from Grandstream, is there anything obvious I may have missed or anything I can post here for you guys to spot the probable and most likely obvious newbee mistake!?
     
  4. SY

    SY Well-Known Member
    3CX Support

    Joined:
    Jan 26, 2007
    Messages:
    1,825
    Likes Received:
    2
    You didn't specify what is the problem with outgoing/incoming calls to/from gateway.
    Is it "no audio"?

    Thanks
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  5. leejor

    leejor Well-Known Member

    Joined:
    Jan 22, 2008
    Messages:
    10,573
    Likes Received:
    247
    You can load the 3CX softphone http://www.3cx.com/VOIP/softphone.html or x-lite http://www.counterpath.com/x-lite.html&active=4 (or any other SIP phone software) onto a PC and register it as an extension for testing.
     
  6. SS Limited

    Joined:
    Sep 16, 2009
    Messages:
    4
    Likes Received:
    0
    That is correct, it sounds almost static, no error beeps it simply dials the number and then appears to 'connect' i.e. the timer starts counting the call and all that you get is static sound.

    Will now try out the soft phones and will let you know how I get on.

    Thanks for you help so far folks.
     
  7. SS Limited

    Joined:
    Sep 16, 2009
    Messages:
    4
    Likes Received:
    0
    OK, still no go, maybe its not the phone but as leejor suggested the gateway itself, I’ve posted up screen shots of the settings page to see if anyone can spot anything obvious?
     

    Attached Files:

Thread Status:
Not open for further replies.