Dismiss Notice
We would like to remind you that we’re updating our login process for all 3CX forums whereby you will be able to login with the same credentials you use for the Partner or Customer Portal. Click here to read more.

Bug or "feature" ??

Discussion in '3CX Phone System - General' started by miraportuga, Nov 9, 2009.

Thread Status:
Not open for further replies.
  1. miraportuga

    miraportuga Member

    Joined:
    Aug 7, 2007
    Messages:
    297
    Likes Received:
    0
    The scenario is:

    3CX v8.0.9536.468 Free license version
    Using cassini as web server
    OS: Windows XP Pro SP3
    Running on Virtual Server 2005 R2 SP1
    Ports open(to the internet): 5060(TCP&UDP)/5090(TCP)/RTP Ports(UDP)
    Internal extensions: 6 (IP Phones)
    External extensions: 1 (Ip Phone)
    Voip Lines: 3(2 from my ISP, both with voip numbers, and 1 from voipbuster)
    PSTN Line: SPA3102
    SIP Domain: My external FQDN(using dyndns domain)
    For a better understanding we'll have Line 1 and Line 2, both refer to my ISP Voip lines wich have diferentes numbers to call to.
    Problem:



    The problem comes when i try to redirect Line 2 to my external extension. What happens is i call Line 2, but instead of going for my external extension it will go to whatever i have defined on Line 1.

    Both lines have equal configuration(except user/pass).

    What have i tried so far?
    If i setup line 1 to go to my external extension, and then call Line 2, the call will go to my external extension.
    If i delete line 1 and setup line 2 like i want(to go to external extension) it will work properly.
    Delete both lines and setup everything again.
    Delete both lines and setup everything again with diferent names.

    Logs show exactly this behaviour, 3cx wont even try to call my external extension, it goes straight to whatever its defined on line 1.

    Apart from this all is working well even tough 3cx is a bit unstable with this configuration.
    Waiting for comments on this, and possible solution.
    Need any more info ? ask for it :D
    Cheers
     
  2. Henk

    Henk Member

    Joined:
    Nov 13, 2007
    Messages:
    250
    Likes Received:
    0
    Not sure if I understand the issue, as you said it works properly, the issue you have is that line 1 is configured line 2 does not work properly? eg. routes to an external number?

    Henk
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. miraportuga

    miraportuga Member

    Joined:
    Aug 7, 2007
    Messages:
    297
    Likes Received:
    0
    Ok, i believe i found what was the issue here.
    Anyway, Henk, what i was saying was that. I was calling Line 2, and 3cx was taking me to whatever destination i had defined on Line 1, instead of using the definitions on line 2, wich was the line i was calling, it was not.

    The problem here was, that i was restricting all ports except those needed for 3cx to comunicate with sip provider, stun and so on. (Direction 3cx -> internet). I change this on my access-list and its all working now so far.

    Cheers
     
Thread Status:
Not open for further replies.