Call between extensions freezes

Discussion in '3CX Phone System - General' started by aputia, Feb 23, 2012.

Thread Status:
Not open for further replies.
  1. aputia

    Joined:
    Feb 23, 2012
    Messages:
    6
    Likes Received:
    0
    I installed 3cx with 10 external extensions (fixed and mobile). Sometimes, during a call (expecially with mobile phones on 3g network), the connection between 2 extensions, freezes, because of problems with the 3g network. So, even if the call ended because of the network, on 3cx console the connection is yet active. In this way, if I try to establish again the connection between the extensions, I receive the message of busy. I have to enter the console and restart the services.

    Is this normal?
    Is not possible to setup a timeout, in order to force the disconnection of the call?

    I use sipdroid, fritz box and other voip system as extensions on 3cx

    Thanks
     
  2. leejor

    leejor Well-Known Member

    Joined:
    Jan 22, 2008
    Messages:
    10,567
    Likes Received:
    246
    You might try enabling the PBX delivers audio option in the extension settings, that may introduce audio issues, so there may be a trade-off. If 3CX is just used for call set-up, and the the two devices "talk" between themselves, until the next registration interval comes and goes, 3CX may have no idea that the two devices are no longer communicating because it never receives a message of the call disconnect. The other thing you might consider (perhaps a last resort) is shortening the 3CX registration requirement time, to something less than the 30 minutes, that is the default. Of course that will affect all devices. You could try lowering the registration time on the phone, but I'm not positive that 3CX will not still wait the 30 minutes before assuming that the extension has "dropped off"
     
  3. aputia

    Joined:
    Feb 23, 2012
    Messages:
    6
    Likes Received:
    0
    Thank you.
    Regarding 3CX registration requirement, where can I set this parameter?

    Regards
     
  4. leejor

    leejor Well-Known Member

    Joined:
    Jan 22, 2008
    Messages:
    10,567
    Likes Received:
    246
    It used to be under Settings/Advanced/Custom Parameters/Maxexpiration, and was set to 1800 seconds by default. However, I hadn't looked for it for a while and don't see it in there any more.

    To change it may now require an edit of one of the 3CX system files. I don't see them completely removing the ability to change that parameter, it's probably just been made a bit harder.

    Perhaps someone from 3CX can enlighten us on where that is now changed.
     
Thread Status:
Not open for further replies.