Call does not connect on HTC EVO (Sprint)

Discussion in 'Android' started by evotivo, Jul 21, 2010.

Thread Status:
Not open for further replies.
  1. evotivo

    Joined:
    Jul 21, 2010
    Messages:
    3
    Likes Received:
    0
    I was able to successfully install the client and register. I see the registration info on the top right of the screen. I also see On Hook and Available below that. It looks like everything is ready for me to make a call but when I dial a number, the message changes to 'Calling' for a brief moment and then immediately the screen changes to the 3CX splash screen with the registration and other information displayed. Am I missing some configuration settings here?

    Thanks
     
  2. loganss

    Joined:
    Jul 21, 2010
    Messages:
    15
    Likes Received:
    0
    If you're calling directly from the 3CXPhone SIP client, do you have money on your SIP provider account? The call won't work unless you have money in your account or in the case of some SIP providers inbound calls are free so if someone calls you it will work.
     
  3. evotivo

    Joined:
    Jul 21, 2010
    Messages:
    3
    Likes Received:
    0
    I have it set up with pbxes.org and I did not charge up my account. I just checked and there is no option to charge up. So I am assuming the service is free. They have a free no money plan valid for 2000 minutes / month which is what I am signed up for.

    Also, so far all my incoming calls are coming through Sprint even though I have 3CX configures and up and running. What do I need to do to make this work?

    I may not be doing anything right here. Can someone please share a step by step guide for installing / configuring this service ?
    Thanks
     
  4. Charel

    Joined:
    Feb 27, 2010
    Messages:
    4
    Likes Received:
    0
    I have a similar problem. When I try to dial out, the phone (HTC Desire) makes the call instead. As I am trying to call a no. that is not accepted by the ordinary mobile (using prefix with the SIP-no.) it is not accepted as a valid phone call with my cell phone and hangs up. On the 3CX screen, it looks like you describe it.

    Incoming calls works fine.
     
  5. LeonidasG

    LeonidasG Support Team
    Staff Member 3CX Support

    Joined:
    Nov 19, 2008
    Messages:
    1,505
    Likes Received:
    100
    Check the logs on the 3CX PBX and see what's happening or the logs on your PBXes.org account.
    This sounds more like incorrect config with your PBXes account than a bug in the 3CX Phone as the behavior you described only happens when a call cannot reach it's destination / destination does not exist.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  6. loganss

    Joined:
    Jul 21, 2010
    Messages:
    15
    Likes Received:
    0
    I agree that it sounds like you have a configuration problem.

    Are you saying PBXes.org allows you to use 2000 minutes/month or your SIP provider allows this?

    PBXes.org is not your SIP provider but a service that allows you to connect many sip providers to one account, amongst other things. I like to think of PBXes and SipSorcery as SIP account managers. Unless you are looking to take advantage of the management of multiple sip accounts, for simplicity sake you're better off just hooking your primary SIP provider account directly into 3CXPhone. Especially if you are new to the whole SIP thing.

    What SIP provider are you using to make outbound calls (i.e. Callcentric, sip2sip, antisip,sipgate)?

    On another note, the more systems that are involved in you VoIP SIP calls the more chances one of them could induce lag into your call.
     
  7. notmike

    Joined:
    Jul 25, 2010
    Messages:
    2
    Likes Received:
    0
    For the record, this does work on the Evo, go into Audio Codecs and drag Speex to the top, uncheck the other options, this is the only way I was able to get good call quality, but it's hit or miss whether it works each time. Over a VPN I can hardly get it to work at all.

    The alternative client still works best on the evo in my opinion, at least over VPN
     
Thread Status:
Not open for further replies.