Call external number begin with "9"

Discussion in '3CX Phone System - General' started by tobiastromm, Mar 14, 2013.

Thread Status:
Not open for further replies.
  1. tobiastromm

    tobiastromm New Member

    Joined:
    Jun 26, 2010
    Messages:
    138
    Likes Received:
    0
    Hi, i'm having some problem with external calls that begin with 9.

    I can dial any external number, except if it begin with 9, in this case i got Busy Tone.

    3CX outbound rule for GXW4104 is 0, so, i need to dial 099XXXXXX.

    PSTN gateway is GXW4104.

    Any help is welcome.

    Thank You.
     
  2. AndreasP_3CX

    AndreasP_3CX New Member
    3CX Support

    Joined:
    Feb 15, 2013
    Messages:
    196
    Likes Received:
    2
    Hi, please follow this guide to configure the gateway with 3CX Phone System http: //www.3cx.com/voip-gateways/grandstream-gxw-41044108/ - NO LONGER AVAILABLE.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. tobiastromm

    tobiastromm New Member

    Joined:
    Jun 26, 2010
    Messages:
    138
    Likes Received:
    0
    Had followed this step guide, note that I can dial any number, except if the number start with 9.

    I can successfully receive calls too.

    Calling 010325 for give you na example, working fine.

    19:13:12.888 [CM503008]: Call(126): Call is terminated
    19:13:12.623 [CM503007]: Call(126): Device joined: sip:10003@10.0.0.84:5062;transport=udp
    19:13:12.623 [CM503007]: Call(126): Device joined: sip:904@10.0.0.12:56736
    19:13:11.935 [CM505002]: Gateway:[GXW-4104] Device info: Device Not Identified: User Agent not matched; Capabilities:[reinvite, replaces, able-no-sdp, recvonly] UserAgent: [Grandstream GXW4104 (HW 2.0, Ch:8) 1.3.4.13] PBX contact: [sip:10003@10.0.0.1:5060]
    19:13:11.935 [CM503002]: Call(126): Alerting sip:10003@10.0.0.84:5062;transport=udp
    19:13:09.982 [CM503025]: Call(126): Calling PSTNline:10325@(Ln.10003@GXW-4104)@[Dev:sip:10003@10.0.0.84:5062;transport=udp]
    19:13:09.935 [CM503004]: Call(126): Route 1: PSTNline:10325@(Ln.10003@GXW-4104)@[Dev:sip:10003@10.0.0.84:5062;transport=udp]
    19:13:09.935 [CM503010]: Making route(s) to <sip:010325@10.0.0.1>


    Calling mobile number (error)

    19:13:48.530 [CM503020]: Normal call termination. Reason: Server Failure
    19:13:48.530 [CM503016]: Call(129): Attempt to reach <sip:099228764@10.0.0.1> failed. Reason: Server Failure
    19:13:48.530 [CM503003]: Call(129): Call to sip:99228764@10.0.0.84:5062 has failed; Cause: 503 Service Unavailable; from IP:10.0.0.84:5062
    19:13:48.483 [CM503025]: Call(129): Calling PSTNline:99228764@(Ln.10003@GXW-4104)@[Dev:sip:10003@10.0.0.84:5062;transport=udp]
    19:13:48.436 [CM503004]: Call(129): Route 1: PSTNline:99228764@(Ln.10003@GXW-4104)@[Dev:sip:10003@10.0.0.84:5062;transport=udp]
    19:13:48.436 [CM503010]: Making route(s) to <sip:099228764@10.0.0.1>
    19:13:48.420 [CM505001]: Ext.904: Device info: Device Identified: [Man: Counterpath;Mod: Bria;Rev: General] Capabilities:[reinvite, no-replaces, unable-no-sdp, recvonly] UserAgent: [Bria Professional release 2.4 stamp 49381] PBX contact: [sip:904@10.0.0.1:5060;transport=TCP]
    19:13:48.420 [CM503001]: Call(129): Incoming call from Ext.904 to <sip:099228764@10.0.0.1>
     
  4. lneblett

    lneblett Well-Known Member

    Joined:
    Sep 7, 2010
    Messages:
    2,064
    Likes Received:
    58
    I am guessing that the issue is related to the GXW still being set to a default for picking the line out. IN your example, you have apparently prepended a "o" to the dial string to indicate the route to the GWX. Once this is done, it looks like the 0 is stripped leaving you with number that you actually want the GS device to dial.

    Unfortunately, your number is actually 992^^^^^^^ and the GXW is using the "99" as a command to send the call out line/port 2 given your "992" entry. it is a nice feature for troubleshooting as you can then manually select any port to force a call into.

    The device allows you to change this setting. Look under channel page settings.
    (following from manual)
    Prefix to specify Port
    (1 stage dialing method)
    Default is 99.
    Syntax to USE this feature: prefix# (that is 99) + ch# (could be anything from 1 to 8)
    + dialing# will result in this call forwarded to FXO port (ch#) immediately.
     
  5. tobiastromm

    tobiastromm New Member

    Joined:
    Jun 26, 2010
    Messages:
    138
    Likes Received:
    0
    lneblett.

    It seems to be the problem.

    I will make some tests and give you a freedback later.

    Thank You.
     
  6. stash

    stash New Member

    Joined:
    Feb 23, 2012
    Messages:
    213
    Likes Received:
    0
    Hi tobias.


    like lneblet said there is a prefix to specify port on the channels tab of your grandstream portal try to change that to any number and try to call out again


    Thanks,

    STASH
     
  7. tobiastromm

    tobiastromm New Member

    Joined:
    Jun 26, 2010
    Messages:
    138
    Likes Received:
    0
    Test done.

    Dialing a number with 9 is now working.

    Thank You for the excellent explanation!

    Best regards.
     
Thread Status:
Not open for further replies.