Dismiss Notice
We would like to remind you that we’re updating our login process for all 3CX forums whereby you will be able to login with the same credentials you use for the Partner or Customer Portal. Click here to read more.

Call forwarding not working (Polycom phone configuration)

Discussion in '3CX Phone System - General' started by pjr, Apr 20, 2012.

Thread Status:
Not open for further replies.
  1. pjr

    pjr New Member

    Joined:
    Oct 5, 2009
    Messages:
    154
    Likes Received:
    0
    Hi,

    I have a v8 3CX system in a hosting centre with 2 different offices connected via VPN.

    They are all using polycom phones.

    Users are setting the polycom phones to foward calls to their mobiles when they are out of the office. This appears to work for one office and not for the other?

    I have compared the server activity logs between a working office and non working office and can see that for the working forward, the line in the log shows "Diverted to: <SIP:mobilenumber@IP of PBX:5060>"

    For the site that isnt working, the same line in the log shows "Diverted to: <SIP:mobilenumber@IP of Polycom Phone:5060>" and then shows "No known route to target: <sip:mobilenumber@ip of Polycom Phone>. I cannot figure out why the non working site phones are forwarding to the mobilenumber@ip of phone and not mobilenumber@ip of pbx?

    The same issue occurs if the user configures their polycom phone to forward to an internal extension and not an external number - this rules out outbound rules as a possible cause.

    The phones are all using the same template and the extensions in each office are configured identically but we are seeing differing behaviour. Can anyone offer any insight?

    Thanks

    Paul
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  2. albertc

    Joined:
    Nov 21, 2011
    Messages:
    89
    Likes Received:
    0
    Re: Call forwarding not working (Polycom phone configuration

    Seem like the issue maybe related to your vpn setting where the phone may not have the correct ip address for the 3cx local interface. Are all three locations using different private subnet? (i.e. hosting server using private network of 10.1.1.0, office A using 172.17.0.0 and office B using 192.168.1.0). More information is needed to troubleshoot this issue.
     
  3. pjr

    pjr New Member

    Joined:
    Oct 5, 2009
    Messages:
    154
    Likes Received:
    0
    Re: Call forwarding not working (Polycom phone configuration

    All 3 locations are using different subnets.

    Hosted is 172.20.68.0/24
    Working site is 172.21.37.0/24
    Non working site is 172.21.69.0/24

    Paul
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Thread Status:
Not open for further replies.