Call from softphone to T19P fails

Discussion in '3CX Phone System - General' started by GoPiTM, Jan 11, 2016.

Thread Status:
Not open for further replies.
  1. GoPiTM

    Joined:
    May 15, 2015
    Messages:
    9
    Likes Received:
    0
    So I have a T19p and it works fine except when someone calls from a softphone it does not connect.

    This is from the log file:
    Code:
    11-jan-2016 10:57:27.107   Leg L:893.2[Extn] is terminated: Cause: 408 Request Timeout/INVITE from local
    11-jan-2016 10:56:24.267   [CM504001]: Endpoint Extn:212: new contact is registered. Contact(s): [sip:212@192.168.40.236:5062 / 212]
    11-jan-2016 10:56:23.920   [CM504002]: Endpoint Extn:212: a contact is unregistered. Contact(s): []
    11-jan-2016 10:56:19.937   [CM503025]: Call(C:893): Calling T:Extn:212@[Dev:sip:212@192.168.40.236:5062] for L:893.1[Extn]
    11-jan-2016 10:56:19.888   [CM503027]: Call(C:893): From: Extn:307 ("Pieter Goris" <sip:307@192.168.81.52:13060>)  to  T:Extn:212@[Dev:sip:212@192.168.40.236:5062]
    11-jan-2016 10:56:19.887   [CM503004]: Call(C:893): Route 1: from L:893.1[Extn] to T:Extn:212@[Dev:sip:212@192.168.40.236:5062]
    
    The Firmware Version of the phone is 31.72.193.20
    I'm running 3CX14 SP2 and 3CXPhone 14.0.47020.0

    Thanks in advance.
     
  2. lneblett

    lneblett Well-Known Member

    Joined:
    Sep 7, 2010
    Messages:
    2,061
    Likes Received:
    56
    Not really sure why,, but a few questions:

    1. Was the firmware version on the T19 installed by the 3CX upgrade process?
    2. Was the T19 provisioned using 3CX or manual?
    (the t19 went unregistered for a second, but the trace is so short that there may be other related info associated to the t19 that was taking place prior to the call. It almost looks like that when the call was placed, the t19 was in the process of registering or doing something else that caused it to unregister and as a result, may have missed the invite. As a result the system timed out.
     
  3. GoPiTM

    Joined:
    May 15, 2015
    Messages:
    9
    Likes Received:
    0
    1. The firmware was pushed with 3CX
    2. The T19 is provisioned by filling in the auto-provisioning link on the phone.
     
  4. lneblett

    lneblett Well-Known Member

    Joined:
    Sep 7, 2010
    Messages:
    2,061
    Likes Received:
    56
    OK, so then if all works well with the T19 except with the softphone, what type of softphone? I am still curious about the T19 becoming unregistered at about the same time. Does this occur on every call made to it from the softphone?
     
  5. NickD_3CX

    NickD_3CX Support Team
    Staff Member 3CX Support

    Joined:
    Jun 2, 2014
    Messages:
    1,252
    Likes Received:
    63
    Additionally, I highly doubt that the firmware was pushed onto the phone by the 3CX Phone System because if you are using V14, the firmware that is downloaded and pushed is v31.72.0.105 for the T19P and v53.80.0.70 for the T19P E2. If you can't find v31.72.0.105 you might also be OK with v31.71.0.228 which was the previous one supported.

    Make sure you are using this firmware version, if it is not pushed onto the phone through 3CX, do it manually.
     
  6. GoPiTM

    Joined:
    May 15, 2015
    Messages:
    9
    Likes Received:
    0
    Ok,

    So I loaded firmware version: 31.72.0.105 and everything works :D.
    Thank you all for the support.
     
Thread Status:
Not open for further replies.