Call hung up after 30 seconds

Discussion in '3CX Phone System - General' started by andierebara, Aug 27, 2007.

  1. andierebara

    Joined:
    Aug 27, 2007
    Messages:
    4
    Likes Received:
    0
    Hello Everybody,

    I am using 3CX with the 3CX Phone software and Linksys SPA3102 for it's PSTN line.
    I can make outside calls from 3cx phone to outside regularly.
    The problem is that when I receive a call form outside throuht the PSTN line the call hungs up after 30 seconds.
    The Detect PSTN long silence is "off", also I have tried Detec disconnect tone to "no" but is still the same situation.

    On the 3cx server log I see:

    [CM104001] Call(14): Ln:10413@Linja413 hung up call; cause: unknown

    Looks like the call is disconnectd by the SPA but I can not ind it why, it disconnect exactly after 30 seconds of conevrsation.

    I apprechiate any help on this!
    Thank You!
     
  2. 5qg4

    5qg4 Active Member

    Joined:
    Jan 31, 2007
    Messages:
    643
    Likes Received:
    0
    Please to use X-Lite instead of 3CX soft phone.

    The free version is available here:
    http://www.counterpath.com/xlitedownload.html

    If get the same result. Please provide the details log, not just a line
    The completed SIP call log maybe help to solve the problem easier.
     
  3. andierebara

    Joined:
    Aug 27, 2007
    Messages:
    4
    Likes Received:
    0
    Hi Ricky,

    I did install the X-lite you suggested and tried with it, it is the same situation. Here below I am copyin the log from the 3cx server:

    ------------------------------------------------------------------------------
    16:46:54.234 StratLink::eek:nHangUp [CM104001] Call(20): Ln:10413@Linja413 hung up call; cause: unknown
    16:46:22.125 CallLegImpl::eek:nConnected [CM103001] Call(20): Created audio channel for Ext.415 (192.168.0.200:8182) with third party (192.168.0.198:16474)
    16:46:22.125 StratInOut::eek:nConnected [CM104005] Call(20): Setup completed for call from Ln:10413@Linja413 to Ext.415
    16:46:22.125 CallLegImpl::eek:nConnected [CM103001] Call(20): Created audio channel for Ln:10413@Linja413 (192.168.0.198:16474) with third party (192.168.0.200:8182)
    16:46:12.562 CallConf::eek:nProvisional [CM103003] Call(20): Ext.415 is ringing
    16:46:12.406 CallConf::eek:nIncoming [CM103002] Call(20): Incoming call from 10413 (Ln:10413@Linja413) to sip:10413@192.168.0.200
    16:43:25.156 ServRegs::eek:nAdd [CM113002] Registered: Ext.415
    -----------------------------------------------------------------------------------

    tx
     
  4. 5qg4

    5qg4 Active Member

    Joined:
    Jan 31, 2007
    Messages:
    643
    Likes Received:
    0
    Are you using the latest firmware for SPA3102? It should be 5.1.7

    Please try to set Detect PSTN Long Silence to "yes" and changed the value for PSTN Long Silence Duration from 30 to 300. To see it will be drop the calls after 30 seconds or not.
     
  5. andierebara

    Joined:
    Aug 27, 2007
    Messages:
    4
    Likes Received:
    0
    Linksys SPA3102 details are:

    Software Version: 5.1.7(GW) Hardware Version: 1.1.5

    I did change the Detect Long silence to "yes" and put the time to 300 seconds but it is the same result; it disconnects after 30 sec. Here are the logs from 3cx in case it helps:

    09:21:27.000 StratLink::eek:nHangUp [CM104001] Call(21): Ln:10413@Linja413 hung up call; cause: unknown
    09:20:54.640 CallLegImpl::eek:nConnected [CM103001] Call(21): Created audio channel for Ext.415 (192.168.0.200:61912) with third party (192.168.0.198:16476)
    09:20:54.609 StratInOut::eek:nConnected [CM104005] Call(21): Setup completed for call from Ln:10413@Linja413 to Ext.415
    09:20:54.609 CallLegImpl::eek:nConnected [CM103001] Call(21): Created audio channel for Ln:10413@Linja413 (192.168.0.198:16476) with third party (192.168.0.200:61912)
    09:20:51.187 CallConf::eek:nProvisional [CM103003] Call(21): Ext.415 is ringing
    09:20:51.046 CallConf::eek:nIncoming [CM103002] Call(21): Incoming call from 10413 (Ln:10413@Linja413) to sip:10413@192.168.0.200
     
  6. 5qg4

    5qg4 Active Member

    Joined:
    Jan 31, 2007
    Messages:
    643
    Likes Received:
    0
    Please check those extensions, they ticked "Extension is external" or not.
     
  7. andierebara

    Joined:
    Aug 27, 2007
    Messages:
    4
    Likes Received:
    0
    No all the extensions are at the same LAN so no one is checked Eternal.
    192.168.0.200 is the extension 415 and 192.168.0.198 is the SPA3102 named "Linja413"
     
  8. 5qg4

    5qg4 Active Member

    Joined:
    Jan 31, 2007
    Messages:
    643
    Likes Received:
    0
    Referred to your log. We know that all of them are at same LAN. My meaning is goto console at extensions > Manage > Edit Extension: XXX > Other option. Then check the "Extension is external" option at this tab for those extensions are ticked or not.

    Also you may check the SPA3102 setting for any difference between this guide http: //www.3cx.com/voip-gateways/linksys-3102/ - NO LONGER AVAILABLE
     
  9. archie

    archie Well-Known Member
    3CX Support

    Joined:
    Aug 18, 2006
    Messages:
    1,309
    Likes Received:
    0
    I believe Henk Harms (itfarmer) had the same issue and solved it by proper configuration of SPA. PM him for details.
     

Share This Page