Dismiss Notice
We would like to remind you that we’re updating our login process for all 3CX forums whereby you will be able to login with the same credentials you use for the Partner or Customer Portal. Click here to read more.

Solved Call Queue no audio?

Discussion in '3CX Phone System - General' started by support@multiplies.be, Jan 22, 2018.

Thread Status:
Not open for further replies.
  1. support@multiplies.be

    Joined:
    Aug 28, 2013
    Messages:
    4
    Likes Received:
    0
    i'm having an issue that recently (6hrs ago) started showing up.

    When calling a call queue there is no audio in that call.
    - external calls to call queue => no audio
    - internal calls to call queue => no audio
    - calls between extensions => audio

    - PBX delivers audio
    - phones and PBX are on a seperate VLAN
    - Server is using IP on that VLAN to communicate directly to the phones (not using the FQDN)
    - this issue is only when using the Queue functionality.
    - 3CX V15.5 fully up to date
    - server has been restarted
    - i've disabled the anti-virus on the 3CX briefly without succes

    any help is welcome
     
  2. kenttec

    Joined:
    Jul 29, 2016
    Messages:
    64
    Likes Received:
    18
    Hi

    I have had the odd system extension become corrupt on me before, one thing that you can try is creating a new queue, add some extensions (logged in) and test

    Is the 3CX license OK e.g. connecting to 3CX licensing servers etc.
     
  3. JCLloyd

    JCLloyd New Member

    Joined:
    Oct 5, 2017
    Messages:
    113
    Likes Received:
    20
    Windows 10? Fall Creators update? If so, try restarting the SIP Server Service. It will need to restart the Media Server & IVR Server services. If that resolves your issue, you might be experiencing what I was a couple of months ago. I upgraded from v15.5SP0 to SP1, SP2 and Windows v1709 within a week span. I experienced the null audio content, once, about a week after. Rebooting the computer fixed that. After that, I couldn't go 2 weeks without losing the ability to pickup inbound calls. Rebooting, restoring from previous backup, restarting services... got me back online. Pulling my 3rd party AV and setting GPO for the new Defender didn't help, and I am thinking "App & Browser Control" (possibly Control Flow Guard) might be my issue.

    If you are on Windows 10 and your issue goes away bouncing the Media Server or IVR Server service, you might consider going to the Debian Distro. I'm on day 12 with no issues and hardly half the resources Windows needed. If I make it to February 4th, I am considering this my permanent solution.

    Drop me a note after the 4th of February and see how I am doing! It took me about 45 minutes from backup to restore, including a drive swap and Linux install.

    I'm not sure how closely my issue relates to yours, but it is something to consider.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  4. support@multiplies.be

    Joined:
    Aug 28, 2013
    Messages:
    4
    Likes Received:
    0
    The machine is running on windows server 2012 R2 standard and has been running for more then 1.5 years without any real issues.
    Server is up to date.
    I've added a new extension and tested this out aswel without succes.

    We have noted that when the user presses the "hold" button and then takes the call back, audio is starting to come through.

    Swapping to Linux is not possible in this case.

    License version is a Professional Perpetual and we have valid maintenance until the 16th of July 2018 (server has been up and running since 16th of july 2017)

    Restarting any service did not solve our issue.
     
  5. JCLloyd

    JCLloyd New Member

    Joined:
    Oct 5, 2017
    Messages:
    113
    Likes Received:
    20
    Understood... What has 3CX support been able to find? The call "hold" maneuver should be a good indicator for them.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  6. jimbo59

    jimbo59 Member

    Joined:
    Nov 17, 2017
    Messages:
    358
    Likes Received:
    77
    Windows event logs are clear?
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  7. support@multiplies.be

    Joined:
    Aug 28, 2013
    Messages:
    4
    Likes Received:
    0
    Logs are clear from any 3CX related error's.

    3CX support was not informed (yet)
    they are charging 75 Euro/Dollar per case.
    The last 3 case the only help we've recieved was "your phone does not have the right firmware","you are running a custom template and we do not support this, etc.

    I've been checking some traces and have not been able to view any errors. I have noticed that the PCMU / PCMA codecs are not being respected, but i've forced PCMA and tested this without succes.

    This looks like an SDP error but no NAT is being used... so i'm a bit stumped
     
  8. YiannisH_3CX

    YiannisH_3CX Support Team
    Staff Member 3CX Support

    Joined:
    May 10, 2016
    Messages:
    7,400
    Likes Received:
    535
    Make sure that under extension settings / Options / Troubleshooting the options Support Re-Invite and Support 'Replaces' are enabled along with PBX delivers Audio option.
    Also what phones are you using? Have you tried replicating the issue with a 3CX client?
     
  9. support@multiplies.be

    Joined:
    Aug 28, 2013
    Messages:
    4
    Likes Received:
    0
    i've had to remove the PBX delivers audio, re-invite, and support 'replaces' and readd it to all extensions for this to work.
    Very wierd.

    Call queue seems to be working as expected again.

    This was also tested with a 3CX mobile client
     
  10. YiannisH_3CX

    YiannisH_3CX Support Team
    Staff Member 3CX Support

    Joined:
    May 10, 2016
    Messages:
    7,400
    Likes Received:
    535
    Glad to hear the issue has been resolved. Monitor the situation and report back if you face the issue again so we can further troublehsoot
     
Thread Status:
Not open for further replies.