Call Queue

Discussion in '3CX Phone System - General' started by dionh, Jul 26, 2007.

  1. dionh

    Joined:
    Mar 3, 2007
    Messages:
    23
    Likes Received:
    0
    Hi

    We have 8 lines using a Grandstream GXW4108 and have 8 lines setup. All the line are setup to Q on ext 8000 however when you ring in the maximum calls I can Q is 2 after this the line just rings and rings and the call is not passed to the Q.

    Is this a bug?

    Many thanks
    Dion
     
  2. Ralph

    Ralph Member

    Joined:
    Jun 28, 2007
    Messages:
    417
    Likes Received:
    0
    Miss posted.

    Sorry :)
     
  3. Anonymous

    Anonymous Guest

    Have you configured your gateway etc to handle more than two lines?

    By default 3CX only configures for 2 lines.
     
  4. Ralph

    Ralph Member

    Joined:
    Jun 28, 2007
    Messages:
    417
    Likes Received:
    0
    Excellent point itfarmer

    Excellent point ITFarmer :)

    Also check your configuration on the server:

    General Settings -> Ports to use for external calls.

    As I recall you need 2 ports per call. So if you wanted 8 simultaneous calls you would neet to configure it for ports 9000 - 9017.

    I think by default it is set for 9000 - 9005 (2 simultaneous calls).

    Best of luck :wink:
     
  5. dionh

    Joined:
    Mar 3, 2007
    Messages:
    23
    Likes Received:
    0
    Hi

    Thanks, now that you say that I remember reading that.

    However I have changed the ports to : 9000 - 9015

    Line 0 9000 - 9001
    Line 1 9002 - 9003
    Line 2 9004 - 9005
    Line 3 9006 - 9007
    Line 4 9008 - 9009
    Line 5 9010 - 9011
    Line 6 9012 - 9013
    Line 7 9014 - 9015

    and I can get 6 lines now so the math does not work. Anyway I will try and increase this to get the other 2 lines.

    Another point I would like to make that is if you hang up the calls the status on both the web and 3cx call assistant still says the lines are connected I have waited a couple of min's to see if the position in Q changes but it does not.

    The only way to clear down the call is to answer it. Clearly nobody is there as the call has been hung up.

    Is there a way to fix this?

    Many thanks
    Dion
     
  6. dionh

    Joined:
    Mar 3, 2007
    Messages:
    23
    Likes Received:
    0
    Right, as far as I can tell this is working as it should.

    I had a faulty cable on one of the gateway ports (status was always set to busy)

    The problem with the calls not clearing down when you hang up looks like a gateway issue also as the call are not dropped at the gateway.

    The status page on the grandstream shows the lines still connected!!

    Will log a fault with grandstream to see what they have to say.

    Enable Current Disconnect is set to yes. yet to try tone.

    Dion
     
  7. Ralph

    Ralph Member

    Joined:
    Jun 28, 2007
    Messages:
    417
    Likes Received:
    0
    Are you using the speaker on the phones?

    I seem to remember that the Grandstream GXP 2000 we have wouldn't actually hang up from an incoming call if you answered with the speaker phone. You had to enable "Turn off speaker on remote disconnect:" on each of the account pages. If you are using or plan to use the speaker phone feature you may want to check this out.
     

Share This Page