Call "silent" sometimes

Discussion in '3CX Phone System - General' started by hasler, Feb 17, 2009.

Thread Status:
Not open for further replies.
  1. hasler

    Joined:
    Jan 7, 2009
    Messages:
    20
    Likes Received:
    0
    Hello,
    I work good with the 3cx software 7.0.4744.0.
    I use a Patton 4552 Gateway.

    My problem is that not every outgoing or ingoing call goes trough correctly, in this case the phone is silent.
    On the phone itself if shows that I'm connected.

    The log provides the following info:


    09:39:00.344 [CM503007]: Call(2): Device joined: sip:10000@192.168.1.4:5060

    09:39:00.234 [CM503007]: Call(2): Device joined: sip:12@192.168.1.12:5060;line=zkjodeb1

    09:39:00.219 [CM503002]: Call(2): Alerting sip:10000@192.168.1.4:5060

    09:38:59.078 [CM503004]: Call(2): Calling: Unknown:0473xxxxxx@(Ln.10000@ISDN)@[Dev:sip:10000@192.168.1.4:5060]

    09:38:59.047 [CM503010]: Making route(s) to <sip:0473xxxxxx@192.168.1.3;user=phone>

    09:38:59.047 [CM505001]: Ext.12: Device info: Device Identified: [Man: Snom;Mod: 8xx series;Rev: General] Capabilities:[reinvite, replaces, able-no-sdp, recvonly] UserAgent: [snom820/8.1.2] Transport: [sip:192.168.1.3:5060]

    09:38:58.922 [MS003005] C:2.1: Failed to create Endpoint: (destination=192.168.1.12)
    EndPoint: ID=00000002@(LOCAL)
    LOGID=C:2.1 Status: MSEP_FAILED
    RTP:192.168.1.3:7002
    RTCP:192.168.1.3:7003
    STUN RTP:0.0.0.0:0
    STUN RTCP:0.0.0.0:0
    Coder:
    NOT SET
    101:telephony-event
    Party ptime:20
    Party RTP:0.0.0.0:0
    Party RTCP:0.0.0.0:0
    Decoders:
    <empty>


    09:38:58.922 [CM503001]: Call(2): Incoming call from Ext.12 to <sip:0473xxxxxx@192.168.1.3;user=phone>

    09:38:58.922 [MS003003] C:2.1: RTCP socket 192.168.1.3:7003 binding failed with error code 10048

    09:38:58.922 [MS003002] C:2.1: RTP socket 192.168.1.3:7002 binding failed with error code 10048

    Can anyone help me to resolve the problem?

    Thanks,

    Andreas

    09:33:10.152 [CM504001]: Ext.12: new contact is registered. Contact(s): [sip:12@192.168.1.12:5060;line=zkjodeb1/12]

    09:32:29.682 [CM504001]: Ext.13: new contact is registered. Contact(s): [sip:13@192.168.1.13:2048;line=rf0h9fy2/13]
     
  2. SY

    SY Well-Known Member
    3CX Support

    Joined:
    Jan 26, 2007
    Messages:
    1,825
    Likes Received:
    2
    This problem is already discussed on this forum. Search for "binding failed with error code"
    It means that ports which are specified as available for media server (RTP) occupied by other application.
    use "netstat -ano" to verify the range of ports and check what application grabs it.

    Thanks
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. hasler

    Joined:
    Jan 7, 2009
    Messages:
    20
    Likes Received:
    0
    I chanded the ports in the registry as described in the FAQ "binding media server".
    After that the 3cx service was not able to start. I got the massage that the port 5060 is in use by an other application.
    I canceld the added port from the registry entry an restartet the server, but no luck, the service is not able to start.
    I also uninstalled the 3cx software an reinstalled the software.
    The service give me an unknown error with code 80004005.

    Can anyone help me to resolve the problem?

    Thanks,

    Andreas
     
  4. coertvc

    Joined:
    Jan 23, 2014
    Messages:
    26
    Likes Received:
    0
    Hi SY

    the reference in this forum to the binding article and reference MS article ONLY refer to Server 2000 and 2003, I use 2008 R2, have set all the reservations and no luck.

    regards,

    COert
     
  5. coertvc

    Joined:
    Jan 23, 2014
    Messages:
    26
    Likes Received:
    0
    and here is the proof, does not work in 2008 server (2003 server is not longer supported by MS

    http://support.microsoft.com/kb/2665809
     
Thread Status:
Not open for further replies.