Call termination on all my "phones"

Discussion in '3CX Phone System - General' started by Alessandro Ranieri, Mar 29, 2017.

Thread Status:
Not open for further replies.
  1. Alessandro Ranieri

    Joined:
    Mar 29, 2017
    Messages:
    13
    Likes Received:
    0
    Hi everybody,
    I'm quite new to 3cx and after installing V15 (debian iso) everything seems working well, but I'm facing a strange problem: If I reject an incoming call with my desk phone, my iOS 3cx client keeps ring and the call remain active.
    The deskphone is a grand stream GXP 2160 provisoned by a 3cx template provided by grandstream.
    Thanks in advance.

    Alessandro
     
  2. YiannisH_3CX

    YiannisH_3CX Support Team
    Staff Member 3CX Support

    Joined:
    May 10, 2016
    Messages:
    6,444
    Likes Received:
    463
    Hello @Alessandro Ranieri

    Please note that what you are experiencing is the default behaviour. When forking the call into two or more devices the call is not dropped until it is rejected from all devices or the call is answered or it reaches the call time out.
     
  3. Alessandro Ranieri

    Joined:
    Mar 29, 2017
    Messages:
    13
    Likes Received:
    0
    Hi Yiannish,
    thanks for your reply, I didn't know that is the default behaviour, but if I reject the call from my iOS or pc client the call is dropped from all devices, instead if I drop the call from my deskphone the call is dropped from the deskphone, from the pc client but not from the iOS client.
    Thanks

    A.
     
  4. JasonNadeau

    JasonNadeau Member

    Joined:
    Oct 14, 2015
    Messages:
    262
    Likes Received:
    46
    Yup, it's normal. Rejecting via the 3cx app sends a different busy code to 3cx pbx. There's a workaround for yealink phones, not sure about grandstream.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  5. Alessandro Ranieri

    Joined:
    Mar 29, 2017
    Messages:
    13
    Likes Received:
    0
    Hi Jason thank you very much,
    can you please tell wich is the workaround for the yealink phones?
    Thanks in advance

    A.
     
  6. JasonNadeau

    JasonNadeau Member

    Joined:
    Oct 14, 2015
    Messages:
    262
    Likes Received:
    46
    In the yealink, in the call forwarding settings under call forward on busy put in a dummy extension that goes right to the users voice-mail. Don't turn on the forward on busy, just put a value in the busy forward box. Hitting reject on the yealink sends the caller to the forward on busy destination. I can't remember if we can put *4 + extension number - don't think so (hence the dummy extension)
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  7. Alessandro Ranieri

    Joined:
    Mar 29, 2017
    Messages:
    13
    Likes Received:
    0
    Many thanks man. :D

    A.
     
Thread Status:
Not open for further replies.