Call Waiting not working with Ring Groups

Discussion in '3CX Phone System - General' started by cejota3, Oct 18, 2009.

Thread Status:
Not open for further replies.
  1. cejota3

    Joined:
    Oct 18, 2009
    Messages:
    16
    Likes Received:
    0
    I've searched to find the answer to this question, but with no luck. So I'm sorry if this is something that has been answered before.

    In short, what I'm trying to do is have "call waiting" work for inbound calls that are handled via a ring group.

    In detail, I have:
    - The most current version of 3CX, 8.0.9532
    - A mixture of SNOM 360 and Polycom IP430 phones (although the phone doesn't seem to make a difference, I'm fairly positive this is a 3CX concern.)

    - For example, let's say I have three extensions, 101, 102, and 103. All of these extensions have "Use Phone Status" set in the "Forwarding Rules" so that the phone can take a second inbound call while busy with a call, i.e. call waiting.

    - When you call the extension directly with two calls, call waiting works like a charm.

    - All three extensions are in a ring group, let's call it, "Everyone", and the "Ring Strategy" is "Ring All".

    - The ring group works as you'd expect. For example, you place a call that is directed to it, and extensions 101, 102, and 103 all ring. But here is the problem, let's say extension 101 answers a call, and then (while that call is still in progress), a second call comes in. Rather than extension's 101 "call waiting" kicking in while 102 and 103 also ring; only 102 and 103 ring.

    I've got to imagine that call waiting should work with inbound calls that are directed via ring groups, but I haven't gotten it to work. I realize that a work-around is to configure each of my phones with two extensions (or "lines" or "identities") and then place each of these second extensions in the ring group. I've tried that, and it works, but having to create and maintain two extensions per phone is something I'm really trying to avoid.

    Any help would be greatly appreciated.

    Thank you,
    C.J.
     
  2. comresource

    comresource Member

    Joined:
    May 22, 2009
    Messages:
    303
    Likes Received:
    0
    There is a custom parameter for this. I cant remember the exact name but just sort by name and its near the top something about use phone status for ring groups.

    Its under Settings-Advanced-Custom

    EDIT : Just looked it up. Its ALLOWUSEBUSYOPTFORGROUP. Set this to 1
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. cejota3

    Joined:
    Oct 18, 2009
    Messages:
    16
    Likes Received:
    0
    Danny,

    A million THANK-YOU's! That did it. I knew it had to be a simple setting like that. I just wish it was documented.

    Where can I send you the six-pack of beer to say thank you? :mrgreen:

    C.J.
     
Thread Status:
Not open for further replies.