Callback is not working!

Discussion in '3CX Phone System - General' started by ltifoski, Aug 18, 2017.

Thread Status:
Not open for further replies.
  1. ltifoski

    Joined:
    Jul 29, 2017
    Messages:
    38
    Likes Received:
    0
    Dear,

    I configured the callback im my queue, but this working only with internal calls (extension to extension). How to made to working with external calls?

    Thanks.

    Lucas Tifoski
     
  2. IoannisM_3CX

    IoannisM_3CX Support Team
    Staff Member 3CX Support

    Joined:
    Aug 10, 2017
    Messages:
    228
    Likes Received:
    17
    Hello itifoski,

    I just tried your scenario and works on my PBX. If your extension to extension scenario works that means you configured the queue correctly so please do check the following:

    1. In your inbound rules check that you set the "Route calls to" to point on your Queue
    2. In your outbound rules check that in "Calls from extension group(s)" you don't have any group(s) added.

    What is the response you get when you call externally?

    Thank you
     
  3. ltifoski

    Joined:
    Jul 29, 2017
    Messages:
    38
    Likes Received:
    0
    Hello @IoannisM_3CX

    My problem ys:

    When i press 2, for callback function, i receive the message: you solicit callback for the number (inform number), press star to confirm, 0 for alter the number or pound to cancel. When i press star and the call is internal, the call finish and the callback working fine. But, when the call is external and i press star, the callback not working.

    Can help me with this issue?

    Thanks,

    Lucas Tifoski
     
  4. IoannisM_3CX

    IoannisM_3CX Support Team
    Staff Member 3CX Support

    Joined:
    Aug 10, 2017
    Messages:
    228
    Likes Received:
    17
    Hello ltifoski,

    Please do supply me with more information. What i understood from your sayings is that externaly you enter the queue>>press 2(that means that callback works)>>press * and then you don't hear the message "an agent will contact you shortly".
    Please also check if you have any prefix,strip or any other configurations in your outbound rules.
    Also for debugging purposes, go to Queue>>Notifications and add an agent in the "Select queue manager extension number" (make sure you have given an email account to this is extension in your extension's general configuration) and then again in Queue>>Notifications>>Queue Email Notifications check "Notify Queue Manager when a Callback is made" ,"Notify Queue manager when a Callback fails" and "Notify Queue Manager when a Queue call is lost". Give it a try with this configuration and reply please.

    Thank you
     
    #4 IoannisM_3CX, Aug 18, 2017
    Last edited: Aug 19, 2017
  5. ltifoski

    Joined:
    Jul 29, 2017
    Messages:
    38
    Likes Received:
    0
    Hello @IoannisM_3CX

    I tried this way and received the following emails:

    This callbaclk is internal and it worked (i hear the message "an agent will contact you shortly"):

    Callback to number 4002 was requested from Queue 8010 by caller 4002
    Caller: 4002
    Queue: 8010 [Suporte]

    This message is of the external call lost in queue:

    Lost Call in Queue Suporte (8010) from Caller ID 111993229733

    when is external call, i press 2 to calback, i hear the message of calback but i not hear the message "an agent will contact you shortly" and not receive the e-mail.

    Can help me?

    Thank you.

    Lucas Tifoski
     
  6. NickD_3CX

    NickD_3CX Support Team
    Staff Member 3CX Support

    Joined:
    Jun 2, 2014
    Messages:
    1,283
    Likes Received:
    68
    Lucas, can you check your Outbound Rules and check if any of them have the "Calls from Extensions" or Call from Extension Groups" filled in?

    If yes, remove everything from those 2 fields.

    This is the most common reason why Callbacks fail.
     
  7. ltifoski

    Joined:
    Jul 29, 2017
    Messages:
    38
    Likes Received:
    0
    Hello @NickD_3CX

    i not have any route with this. I made some changes, but the problem remains. Can you help me?

    Thanks.

    Lucas Tifoski
     
  8. NickD_3CX

    NickD_3CX Support Team
    Staff Member 3CX Support

    Joined:
    Jun 2, 2014
    Messages:
    1,283
    Likes Received:
    68
    Then the next I would suggest is that you changing the logging level to Verbose from the options in the Activity Log, leave a Callback, and when it fails go back to the Activity Log and check the logs to see if there is any pointer as to why the call failed.
     
  9. leejor

    leejor Well-Known Member

    Joined:
    Jan 22, 2008
    Messages:
    10,587
    Likes Received:
    253
    The problem may be that the format of the caller ID number, which is being used for call back, does not match an outbound rule. The logs should show if this is the case. If so, add a prefix to the caller ID, so that it matches a rule, or create an additional rule that matches the call back number.
     
  10. ltifoski

    Joined:
    Jul 29, 2017
    Messages:
    38
    Likes Received:
    0
    how i mande this?
     
  11. ltifoski

    Joined:
    Jul 29, 2017
    Messages:
    38
    Likes Received:
    0
    I made this before, but not have results. The callback is not triggered because it does not appear in the call log.

    I cant made the callback working :(

    Can help me?

    Thanks.

    Lucas Tifoski
     
  12. NickD_3CX

    NickD_3CX Support Team
    Staff Member 3CX Support

    Joined:
    Jun 2, 2014
    Messages:
    1,283
    Likes Received:
    68
    OK, could you:
    • Post a screenshot from your Callback settings
    • Post a screenshot from your Outbound Rules
    • Try leaving a callback using Option 0 where you manually enter the number you want to be called back to and tell us the number you left if it failed.
     
  13. ltifoski

    Joined:
    Jul 29, 2017
    Messages:
    38
    Likes Received:
    0
    This is the calback configuration, i use #4 for outbound:

    upload_2017-8-18_16-32-43.png

    And this is my outbound roule for callback:

    upload_2017-8-18_16-34-44.png

    is this?

    Thank you.

    Lucas Tifoski
     
  14. NickD_3CX

    NickD_3CX Support Team
    Staff Member 3CX Support

    Joined:
    Jun 2, 2014
    Messages:
    1,283
    Likes Received:
    68
    In the outbound rules, do you strip the 2 digits?
     
  15. leejor

    leejor Well-Known Member

    Joined:
    Jan 22, 2008
    Messages:
    10,587
    Likes Received:
    253
    I didn't realise you could use # as a digit in the outbound rules. I was under the impression that it was strictly numeric.
     
    #15 leejor, Aug 18, 2017
    Last edited: Aug 18, 2017
  16. ltifoski

    Joined:
    Jul 29, 2017
    Messages:
    38
    Likes Received:
    0
    Yes! i stripped the two digits more three digits that do not serve to make call, totaling 5 digits.
    But my question is: why do not I hear the message that an agent will contact you? In internal calls I hear the message and the callback works.

    upload_2017-8-18_16-56-18.png
     
  17. ltifoski

    Joined:
    Jul 29, 2017
    Messages:
    38
    Likes Received:
    0
    I use and work normaly in other roules.
     
  18. ags

    ags

    Joined:
    Jan 8, 2013
    Messages:
    9
    Likes Received:
    0
    the callback function does not work for me ....

    3cx pro version 15.5.3849.1
     
  19. YiannisH_3CX

    YiannisH_3CX Support Team
    Staff Member 3CX Support

    Joined:
    May 10, 2016
    Messages:
    5,514
    Likes Received:
    361
    Hello @ags

    Are you getting an error? Can you enable the callback feature? Do you get the prompt when the callback is triggered?
    In which point is it failing?
     
  20. ltifoski

    Joined:
    Jul 29, 2017
    Messages:
    38
    Likes Received:
    0
    Hello! I not received error! The callback not working when i enable the feature and not appear in the call log.

    Can you help me?

    Thank you!

    Lucas Tifoski.
     
Thread Status:
Not open for further replies.