Called party hears an echo

Discussion in 'Windows' started by thassani, Apr 18, 2008.

Thread Status:
Not open for further replies.
  1. thassani

    Mar 3, 2008
    Likes Received:
    We have just upgraded our 3.1 3cx to 5.1.4393 and we have also upgraded the VoIP client. We are trialing the client for use by remote users and users that travel.

    When someone uses the 3cx VoIP client to call another number whether it be internal (on the same 3CX server) or external. The called party hears an echo of there own voice when talking. The sound for the calling party is fine with no echo.

    We use the client with a laptop and we have tried it with the builtin laptop speakers as well I've tried it with headsets both bluetooth and wired.

    Are there any setting we can change to elimnate the echo. The caller hears no echo and it sounds perfect.

    Side point. How do we turn off the non north american ring sound. We can here the european ring and also the north american ring when placing a call.

    Any help would be greatly appreciated.
Thread Status:
Not open for further replies.