CallerID with a SPA3000

Discussion in '3CX Phone System - General' started by paultilley100, Sep 14, 2010.

Thread Status:
Not open for further replies.
  1. paultilley100

    Joined:
    Sep 14, 2010
    Messages:
    4
    Likes Received:
    0
    Hi all

    I hope somebody can shed some light on my problem.....

    I have a SPA3000 with my BT line plugged into it and it is connected to 3CX on port 10001.
    The SPA3000 detects the incoming CallerID (looking in the web config shows 'Last Caller ID') correctly.

    However, when the call comes through to my Grandstream GXP2000 handsets, the handset display shows Sipura 10001, not the CallerID.

    Any ideas of what I have done wrong?

    Thanks in advance.
    Paul
     
  2. leejor

    leejor Well-Known Member

    Joined:
    Jan 22, 2008
    Messages:
    10,587
    Likes Received:
    253
    Post, or just have a look at, the 3CX log showing the incoming call. That will show whether or not the caller ID is being passed onto 3CX.
     
  3. paultilley100

    Joined:
    Sep 14, 2010
    Messages:
    4
    Likes Received:
    0
    OK - this might sound daft, but I know Asterisk pretty much inside out. 3CX is new to me - how do i get the log?
     
  4. paultilley100

    Joined:
    Sep 14, 2010
    Messages:
    4
    Likes Received:
    0
    ok - stupid me - ive found them - looking now.......
     
  5. paultilley100

    Joined:
    Sep 14, 2010
    Messages:
    4
    Likes Received:
    0
    23:58:28.358 [CM503025]: Call(5): Calling Ext:Ext.99@[Dev:sip:99@127.0.0.1:40600;rinstance=4423ec9c2c5c8f52]
    23:58:28.296 [CM503004]: Call(5): Route 1: Ext:Ext.99@[Dev:sip:99@127.0.0.1:40600;rinstance=4423ec9c2c5c8f52]
    23:58:28.296 [CM503010]: Making route(s) to <sip:21@10.0.0.100:5060;user=vmail>
    23:58:28.296 [CM505002]: Gateway:[Sipura] Device info: Device Identified: [Man: Linksys;Mod: SPA Series;Rev: General] Capabilities:[reinvite, no-replaces, able-no-sdp, recvonly] UserAgent: [Linksys/SPA3000-3.1.10(GWd)] PBX contact: [sip:10001@10.0.0.100:5060]
    23:58:28.296 [CM503001]: Call(5): Incoming call from 10001@(Ln.10001@Sipura) to <sip:21@10.0.0.100:5060;user=vmail>
    23:58:28.280 [CM503012]: Inbound out-of-office hours rule (unnamed) for 10001 forwards to VM:21
    23:50:49.245 [CM503007]: Call(4): Device joined: sip:99@127.0.0.1:40600;rinstance=4423ec9c2c5c8f52
    23:50:49.245 [CM505001]: Ext.99: Device info: Device Identified: [Man: 3CX Ltd.;Mod: Voice Mail Menu;Rev: General] Capabilities:[reinvite, replaces, able-no-sdp, recvonly] UserAgent: [3CX Voice Mail Menu] PBX contact: [sip:99@127.0.0.1:5060]
    23:50:49.104 [CM503025]: Call(4): Calling Ext:Ext.99@[Dev:sip:99@127.0.0.1:40600;rinstance=4423ec9c2c5c8f52]
    23:50:49.042 [CM503010]: Making route(s) to <sip:21@10.0.0.100:5060;user=vmail>
    23:50:49.026 [CM503001]: Call(4): Incoming call from 10001@(Ln.10001@Sipura) to <sip:21@10.0.0.100:5060;user=vmail>
    23:43:25.088 [CM506001]: STUN request to resolve SIP external IP:port mapping is sent to STUN server 96.9.132.83:3478 over Transport 10.0.0.100:5060
     
  6. leejor

    leejor Well-Known Member

    Joined:
    Jan 22, 2008
    Messages:
    10,587
    Likes Received:
    253
    Well, unfortunately, the 3000 isn't passing the caller ID onto 3CX. Because you are in the UK, there may be different reasons when compared to Caller Id in North America, but, off hand I suspect that the call info is being sent onto 3CX before the caller ID has been acquired, Something that happens here as well, with the wrong setting. I'm assuming that you have the caller ID set for BT specs, as you said that it was showing in the 3000 menu. Go to the PSTN tab/FXO Timer Values/PSTN Answer Delay. the default here is 16 seconds, which is far too long. However if you set it to short, like 1 or two seconds, then the call is passed onto 3Cx before it has a chance to get the caller Id info. Try about 7 seconds and then reduce the time until it fails. In North America anything less than 3 seconds means no caller ID.
     
Thread Status:
Not open for further replies.