Calling Remote location from office

Discussion in '3CX Phone System - General' started by incey2000, May 6, 2011.

Thread Status:
Not open for further replies.
  1. incey2000

    Joined:
    May 5, 2011
    Messages:
    13
    Likes Received:
    0
    Hi All
    Be gentle with me as i'm new to all this VOIP stuff.....lol

    I've setup the free version of 3cx at the office(works fine)

    On our office router(draytek 2830) i've opened ports 5060-5070 and 9000-9049 to the 3cx server, setup a yealink T20P phone at home, the phone registers fine and i can make outbound calls without any problems, i can call an office ext and it works fine. Now comes the problem, if someone from the office calls my home ext i get no audio either way?

    I'm stumped on this one and have tried everything i know and can't get it to work.
    Any help with this would be great.

    Thanks In advance.

    Martin
     
  2. davidbenwell

    davidbenwell Active Member

    Joined:
    Apr 27, 2010
    Messages:
    704
    Likes Received:
    0
    Please follow the below steps and let us know the results

    Log into the 3CX web console and run “Settings->Firewall Checker” page.

    run the firewall checker tool and post back here with the results.

    Your issue appears to be a firewall problem hints the need to run the 3CX Firewall tool
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. incey2000

    Joined:
    May 5, 2011
    Messages:
    13
    Likes Received:
    0
    Hi
    Below are the results of the firewall checker.

    3CX Firewall Checker, v1.0. Copyright (C) 3CX Ltd. All rights reserved.

    <13:39:17>: Phase 1, checking servers connection, please wait...
    <13:39:17>: Stun Checker service is reachable. Phase 1 check passed.
    <13:39:17>: Phase 2a, Check Port Forwarding to UDP SIP port, please wait...
    <13:39:18>: UDP SIP Port is set to 5060. Response received correctly with no translation. Phase 2a check passed.

    <13:39:18>: Phase 2b. Check Port Forwarding to TCP SIP port, please wait...
    <13:39:18>: TCP SIP Port is set to 5060. Response received correctly with no translation. Phase 2b check passed.

    <13:39:18>: Phase 3. Check Port Forwarding to TCP Tunnel port, please wait...
    <13:39:18>: TCP TUNNEL Port is set to 5090. Response received correctly with no translation. Phase 3 check passed.

    <13:39:18>: Phase 4. Check Port Forwarding to RTP external port range, please wait...
    <13:39:24>: UDP RTP Port 9000. Response received correctly with no translation. Phase 4-01 check passed.
    <13:39:24>: UDP RTP Port 9001. Response received correctly with no translation. Phase 4-02 check passed.
    <13:39:24>: UDP RTP Port 9002. Response received correctly with no translation. Phase 4-03 check passed.
    <13:39:24>: UDP RTP Port 9003. Response received correctly with no translation. Phase 4-04 check passed.
    <13:39:24>: UDP RTP Port 9004. Response received correctly with no translation. Phase 4-05 check passed.
    <13:39:24>: UDP RTP Port 9005. Response received correctly with no translation. Phase 4-06 check passed.
    <13:39:24>: UDP RTP Port 9006. Response received correctly with no translation. Phase 4-07 check passed.
    <13:39:24>: UDP RTP Port 9007. Response received correctly with no translation. Phase 4-08 check passed.
    <13:39:24>: UDP RTP Port 9008. Response received correctly with no translation. Phase 4-09 check passed.
    <13:39:24>: UDP RTP Port 9009. Response received correctly with no translation. Phase 4-10 check passed.
    <13:39:24>: UDP RTP Port 9010. Response received correctly with no translation. Phase 4-11 check passed.
    <13:39:24>: UDP RTP Port 9011. Response received correctly with no translation. Phase 4-12 check passed.
    <13:39:24>: UDP RTP Port 9012. Response received correctly with no translation. Phase 4-13 check passed.
    <13:39:24>: UDP RTP Port 9013. Response received correctly with no translation. Phase 4-14 check passed.
    <13:39:24>: UDP RTP Port 9014. Response received correctly with no translation. Phase 4-15 check passed.
    <13:39:24>: UDP RTP Port 9015. Response received correctly with no translation. Phase 4-16 check passed.
    <13:39:24>: UDP RTP Port 9016. Response received correctly with no translation. Phase 4-17 check passed.
    <13:39:24>: UDP RTP Port 9017. Response received correctly with no translation. Phase 4-18 check passed.
    <13:39:24>: UDP RTP Port 9018. Response received correctly with no translation. Phase 4-19 check passed.
    <13:39:24>: UDP RTP Port 9019. Response received correctly with no translation. Phase 4-20 check passed.
    <13:39:24>: UDP RTP Port 9020. Response received correctly with no translation. Phase 4-21 check passed.
    <13:39:24>: UDP RTP Port 9021. Response received correctly with no translation. Phase 4-22 check passed.
    <13:39:24>: UDP RTP Port 9022. Response received correctly with no translation. Phase 4-23 check passed.
    <13:39:24>: UDP RTP Port 9023. Response received correctly with no translation. Phase 4-24 check passed.
    <13:39:24>: UDP RTP Port 9024. Response received correctly with no translation. Phase 4-25 check passed.
    <13:39:24>: UDP RTP Port 9025. Response received correctly with no translation. Phase 4-26 check passed.
    <13:39:24>: UDP RTP Port 9026. Response received correctly with no translation. Phase 4-27 check passed.
    <13:39:24>: UDP RTP Port 9027. Response received correctly with no translation. Phase 4-28 check passed.
    <13:39:24>: UDP RTP Port 9028. Response received correctly with no translation. Phase 4-29 check passed.
    <13:39:24>: UDP RTP Port 9029. Response received correctly with no translation. Phase 4-30 check passed.
    <13:39:24>: UDP RTP Port 9030. Response received correctly with no translation. Phase 4-31 check passed.
    <13:39:24>: UDP RTP Port 9031. Response received correctly with no translation. Phase 4-32 check passed.
    <13:39:24>: UDP RTP Port 9032. NO RESPONSE received. Phase 4-33 check failed with ERRORS. Some functionality will be LIMITED. For more information, please visit http://www.3cx.com/blog/docs/firewall-checker/
    <13:39:24>: UDP RTP Port 9033. Response received correctly with no translation. Phase 4-34 check passed.
    <13:39:24>: UDP RTP Port 9034. Response received correctly with no translation. Phase 4-35 check passed.
    <13:39:24>: UDP RTP Port 9035. Response received correctly with no translation. Phase 4-36 check passed.
    <13:39:24>: UDP RTP Port 9036. Response received correctly with no translation. Phase 4-37 check passed.
    <13:39:24>: UDP RTP Port 9037. Response received correctly with no translation. Phase 4-38 check passed.
    <13:39:24>: UDP RTP Port 9038. Response received correctly with no translation. Phase 4-39 check passed.
    <13:39:24>: UDP RTP Port 9039. Response received correctly with no translation. Phase 4-40 check passed.
    <13:39:24>: UDP RTP Port 9040. Response received correctly with no translation. Phase 4-41 check passed.
    <13:39:24>: UDP RTP Port 9041. Response received correctly with no translation. Phase 4-42 check passed.
    <13:39:24>: UDP RTP Port 9042. Response received correctly with no translation. Phase 4-43 check passed.
    <13:39:24>: UDP RTP Port 9043. Response received correctly with no translation. Phase 4-44 check passed.
    <13:39:24>: UDP RTP Port 9044. Response received correctly with no translation. Phase 4-45 check passed.
    <13:39:24>: UDP RTP Port 9045. Response received correctly with no translation. Phase 4-46 check passed.
    <13:39:24>: UDP RTP Port 9046. Response received correctly with no translation. Phase 4-47 check passed.
    <13:39:24>: UDP RTP Port 9047. Response received correctly with no translation. Phase 4-48 check passed.
    <13:39:24>: UDP RTP Port 9048. Response received correctly with no translation. Phase 4-49 check passed.
    <13:39:24>: UDP RTP Port 9049. Response received correctly with no translation. Phase 4-50 check passed.


    Application exit code is 1
     
  4. leejor

    leejor Well-Known Member

    Joined:
    Jan 22, 2008
    Messages:
    10,356
    Likes Received:
    223
    Did you remember to enable STUN on the Yealink T20P? You should also confirm that the port, that you put on the Yealink (5060?), is not being used by another device at your home location.
     
  5. incey2000

    Joined:
    May 5, 2011
    Messages:
    13
    Likes Received:
    0
    Stun is enabled on the 3cx server and the home phone i'm using stun.3cx.com on port 3478

    I'm using port 5060 for the sip server and this is indeed set on the yealink home phone. I don't think anything would be using port 5060 at my home network.
    Like i said i only have a problem with calling the home ext from an office ext(i get no audio) home to office works fine, i've also just tested this from another remote location with the same results?

    I'm stumped..............
     
  6. davidbenwell

    davidbenwell Active Member

    Joined:
    Apr 27, 2010
    Messages:
    704
    Likes Received:
    0
    Ideally you should get the below error fixed

    <13:39:24>: UDP RTP Port 9032. NO RESPONSE received. Phase 4-33 check failed with ERRORS. Some functionality will be LIMITED. For more information, please visit http://www.3cx.com/blog/docs/firewall-checker/

    you could also try disabling the remote firewall on your router at home, also check to see if UPnP is enabled on the home router.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  7. smb1

    smb1 New Member

    Joined:
    Mar 18, 2009
    Messages:
    104
    Likes Received:
    0
    Have you followed the steps in this blog post

    http://www.3cx.com/blog/voip-howto/remote-extensions/
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  8. leejor

    leejor Well-Known Member

    Joined:
    Jan 22, 2008
    Messages:
    10,356
    Likes Received:
    223
    My first suspect would have been the router at home too, but given this..

    Then, I wonder if it's not a setting in the phone.

    If you can call the remote phone (get it to ring), then STUN is probably working, as that would indicate that the set is registering using the public IP (of the remote router) and the port of the phone. You can confirm this in the 3CX server logs. Something is blocking/misdirecting packets when the call doesn't originate from the remote phone. That is usually something at the remote end. Since you' tried it at a different location, then , unless the router there is the same make, and they both have a SIP issue (possible), then the phone settings would be the prime suspect. Do you get audio in one direction?
     
  9. incey2000

    Joined:
    May 5, 2011
    Messages:
    13
    Likes Received:
    0
    Hi all

    I've fixed the firewall issue but i'm still having the same issue?
    3CX Firewall Checker, v1.0. Copyright (C) 3CX Ltd. All rights reserved.

    <19:53:49>: Phase 1, checking servers connection, please wait...
    <19:53:49>: Stun Checker service is reachable. Phase 1 check passed.
    <19:53:49>: Phase 2a, Check Port Forwarding to UDP SIP port, please wait...
    <19:53:50>: UDP SIP Port is set to 5060. Response received correctly with no translation. Phase 2a check passed.

    <19:53:50>: Phase 2b. Check Port Forwarding to TCP SIP port, please wait...
    <19:53:50>: TCP SIP Port is set to 5060. Response received correctly with no translation. Phase 2b check passed.

    <19:53:50>: Phase 3. Check Port Forwarding to TCP Tunnel port, please wait...
    <19:53:50>: TCP TUNNEL Port is set to 5090. Response received correctly with no translation. Phase 3 check passed.

    <19:53:50>: Phase 4. Check Port Forwarding to RTP external port range, please wait...
    <19:53:55>: UDP RTP Port 9000. Response received correctly with no translation. Phase 4-01 check passed.
    <19:53:55>: UDP RTP Port 9001. Response received correctly with no translation. Phase 4-02 check passed.
    <19:53:55>: UDP RTP Port 9002. Response received correctly with no translation. Phase 4-03 check passed.
    <19:53:55>: UDP RTP Port 9003. Response received correctly with no translation. Phase 4-04 check passed.
    <19:53:55>: UDP RTP Port 9004. Response received correctly with no translation. Phase 4-05 check passed.
    <19:53:55>: UDP RTP Port 9005. Response received correctly with no translation. Phase 4-06 check passed.
    <19:53:55>: UDP RTP Port 9006. Response received correctly with no translation. Phase 4-07 check passed.
    <19:53:55>: UDP RTP Port 9007. Response received correctly with no translation. Phase 4-08 check passed.
    <19:53:55>: UDP RTP Port 9008. Response received correctly with no translation. Phase 4-09 check passed.
    <19:53:55>: UDP RTP Port 9009. Response received correctly with no translation. Phase 4-10 check passed.
    <19:53:55>: UDP RTP Port 9010. Response received correctly with no translation. Phase 4-11 check passed.
    <19:53:55>: UDP RTP Port 9011. Response received correctly with no translation. Phase 4-12 check passed.
    <19:53:55>: UDP RTP Port 9012. Response received correctly with no translation. Phase 4-13 check passed.
    <19:53:55>: UDP RTP Port 9013. Response received correctly with no translation. Phase 4-14 check passed.
    <19:53:55>: UDP RTP Port 9014. Response received correctly with no translation. Phase 4-15 check passed.
    <19:53:55>: UDP RTP Port 9015. Response received correctly with no translation. Phase 4-16 check passed.
    <19:53:55>: UDP RTP Port 9016. Response received correctly with no translation. Phase 4-17 check passed.
    <19:53:55>: UDP RTP Port 9017. Response received correctly with no translation. Phase 4-18 check passed.
    <19:53:55>: UDP RTP Port 9018. Response received correctly with no translation. Phase 4-19 check passed.
    <19:53:55>: UDP RTP Port 9019. Response received correctly with no translation. Phase 4-20 check passed.
    <19:53:55>: UDP RTP Port 9020. Response received correctly with no translation. Phase 4-21 check passed.
    <19:53:55>: UDP RTP Port 9021. Response received correctly with no translation. Phase 4-22 check passed.
    <19:53:55>: UDP RTP Port 9022. Response received correctly with no translation. Phase 4-23 check passed.
    <19:53:55>: UDP RTP Port 9023. Response received correctly with no translation. Phase 4-24 check passed.
    <19:53:55>: UDP RTP Port 9024. Response received correctly with no translation. Phase 4-25 check passed.
    <19:53:55>: UDP RTP Port 9025. Response received correctly with no translation. Phase 4-26 check passed.
    <19:53:55>: UDP RTP Port 9026. Response received correctly with no translation. Phase 4-27 check passed.
    <19:53:55>: UDP RTP Port 9027. Response received correctly with no translation. Phase 4-28 check passed.
    <19:53:55>: UDP RTP Port 9028. Response received correctly with no translation. Phase 4-29 check passed.
    <19:53:55>: UDP RTP Port 9029. Response received correctly with no translation. Phase 4-30 check passed.
    <19:53:55>: UDP RTP Port 9030. Response received correctly with no translation. Phase 4-31 check passed.
    <19:53:55>: UDP RTP Port 9031. Response received correctly with no translation. Phase 4-32 check passed.
    <19:53:55>: UDP RTP Port 9032. Response received correctly with no translation. Phase 4-33 check passed.
    <19:53:55>: UDP RTP Port 9033. Response received correctly with no translation. Phase 4-34 check passed.
    <19:53:55>: UDP RTP Port 9034. Response received correctly with no translation. Phase 4-35 check passed.
    <19:53:55>: UDP RTP Port 9035. Response received correctly with no translation. Phase 4-36 check passed.
    <19:53:55>: UDP RTP Port 9036. Response received correctly with no translation. Phase 4-37 check passed.
    <19:53:55>: UDP RTP Port 9037. Response received correctly with no translation. Phase 4-38 check passed.
    <19:53:55>: UDP RTP Port 9038. Response received correctly with no translation. Phase 4-39 check passed.
    <19:53:55>: UDP RTP Port 9039. Response received correctly with no translation. Phase 4-40 check passed.
    <19:53:55>: UDP RTP Port 9040. Response received correctly with no translation. Phase 4-41 check passed.
    <19:53:55>: UDP RTP Port 9041. Response received correctly with no translation. Phase 4-42 check passed.
    <19:53:55>: UDP RTP Port 9042. Response received correctly with no translation. Phase 4-43 check passed.
    <19:53:55>: UDP RTP Port 9043. Response received correctly with no translation. Phase 4-44 check passed.
    <19:53:55>: UDP RTP Port 9044. Response received correctly with no translation. Phase 4-45 check passed.
    <19:53:55>: UDP RTP Port 9045. Response received correctly with no translation. Phase 4-46 check passed.
    <19:53:55>: UDP RTP Port 9046. Response received correctly with no translation. Phase 4-47 check passed.
    <19:53:55>: UDP RTP Port 9047. Response received correctly with no translation. Phase 4-48 check passed.
    <19:53:55>: UDP RTP Port 9048. Response received correctly with no translation. Phase 4-49 check passed.
    <19:53:55>: UDP RTP Port 9049. Response received correctly with no translation. Phase 4-50 check passed.


    Application exit code is 0

    Tried turning off firewall at remote location, still won't work?
    UPnP is enabled at remote location (not sure if it should be?)

    Stun seems to be working fine with no errors in the 3cx log files. I'm sure it's a remote location phone setting issue, just not sure what?

    Phone is a Yealink T20p
    SIP port - 5060
    NAT Traversal - stun.3cx.com - port 3478
    RPort is enabled

    I get no audio either way if the office calls my home ext, works fine if i call from my home ext?

    STUMPED
     
  10. davidbenwell

    davidbenwell Active Member

    Joined:
    Apr 27, 2010
    Messages:
    704
    Likes Received:
    0
    ok, on your home router as a test setup port forwarding to the ip address of your phone

    UDP 3478 STUN SERVER COMMUNICATIONS
    5060/65 SIP COMMUNICATIONS (plus custom ports)
    UDP 5082 SIP COMMUNICATIONS (OUTBOUND PROXY)
    UDP 11780-11800 RTP,RTCP,VOICE
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  11. leejor

    leejor Well-Known Member

    Joined:
    Jan 22, 2008
    Messages:
    10,356
    Likes Received:
    223
    If your modem/router isn't a combo unit, at home, you can also try letting the Yealink pick up a public IP (plug it directly into the modem). Disable STUN, although I've found this usually isn't necessary.

    If that solves the problem, then it's your router (or a phone setting causing grief when used with the router).

    If it doesn't solve the problem, then at least you've eliminated your router as a possible culprit.
     
  12. incey2000

    Joined:
    May 5, 2011
    Messages:
    13
    Likes Received:
    0
    I've opened ports on my router still won't work?

    I've got a combo router/modem so can't get it to get a public IP.

    Getting on my nerves now i've almost given up.
     
  13. davidbenwell

    davidbenwell Active Member

    Joined:
    Apr 27, 2010
    Messages:
    704
    Likes Received:
    0
    ok, last thing you can try is on your home router it should have a DMZ option, enter your IP Phone ip address for the DMZ and apply this and then reboot your router, let us know if this works or not.

    If not, then the only option then if you wanted this sorting, would be to get one of us certified partners to take a look at your configurations and do some in depth testing for you.

    We do offer this service, however there would be a fee payable for this service.

    please see Pay As You Go Support for further information.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  14. leejor

    leejor Well-Known Member

    Joined:
    Jan 22, 2008
    Messages:
    10,356
    Likes Received:
    223
    Have you tried setting up the 3CX softphone on a PC at home and seeing if that works? Or, any other SIP phone?
     
  15. incey2000

    Joined:
    May 5, 2011
    Messages:
    13
    Likes Received:
    0
    I've just tried the 3cx softphone and everything works fine? so it must be a setting on the Yealink T20p Hardphone.

    Any ideas?
     
  16. davidbenwell

    davidbenwell Active Member

    Joined:
    Apr 27, 2010
    Messages:
    704
    Likes Received:
    0
    have you set the outbound proxy on the phone?
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  17. incey2000

    Joined:
    May 5, 2011
    Messages:
    13
    Likes Received:
    0
    No i've not did'nt know i needed to, i thought that was only if i was using the 3cx tunnel?

    What would i set the outbound proxy to?
     
  18. leejor

    leejor Well-Known Member

    Joined:
    Jan 22, 2008
    Messages:
    10,356
    Likes Received:
    223
    You shouldn't need to use it but you can just put in the same IP or URL as the server info.
     
  19. incey2000

    Joined:
    May 5, 2011
    Messages:
    13
    Likes Received:
    0
    Tried setting the outbound server, still won't work?
    This must be a setting on the phone just no idea what setting it is.
     
  20. leejor

    leejor Well-Known Member

    Joined:
    Jan 22, 2008
    Messages:
    10,356
    Likes Received:
    223
    There are really only a few basic settings that need to be changed in a SIP device to place and receive calls. The server, user name, password, then, STUN settings if at a remote location. Many others, can, generally (of course all situations are different) be left at the defaults.

    Since you can register and place calls, we'll assume that the server, user name and password are correct. You can try doing a factory reset and starting again, sometimes that will correct any inadvertent changes you've made that didn't seem important at the time.

    I'm not familiar with the settings on that phone, but, get it to work, first, without STUN, on the 3CX LAN, if you decide to go the factory reset route. Then do a web search on how to implement STUN on that set. Others that have "gone before" may have some tips on what needs to be changed (or not changed) to get it to work.

    You may just find that there was one setting that was incorrect.
     
Thread Status:
Not open for further replies.