Solved callling is ok but silence after the connection

Discussion in '3CX Phone System - General' started by Volkan Celebi, Jan 8, 2018.

Thread Status:
Not open for further replies.
  1. Volkan Celebi

    Joined:
    Nov 20, 2017
    Messages:
    11
    Likes Received:
    0
    Hello,

    one of our extensions seems work but if I call any number (domestic or 0800) it is ringing but I can't hear opposite side. There is no call limitiations of the extension. It is also in ring group. If we get a call it is ringing with the other office extensions but If get the call the counter works but again silence.
     
  2. YiannisH_3CX

    YiannisH_3CX Support Team
    Staff Member 3CX Support

    Joined:
    May 10, 2016
    Messages:
    4,375
    Likes Received:
    278
    Hello @Volkan Celebi

    What version PBX are you running? You can see the exact build number on the Dashboard of the management console next to the licence info. Did you pass the firewall checker? Are the extensions local or remote? Are you using a Voip provider for calls, do you have a gateway, etc?
     
  3. Volkan Celebi

    Joined:
    Nov 20, 2017
    Messages:
    11
    Likes Received:
    0
  4. NickD_3CX

    NickD_3CX Support Team
    Staff Member 3CX Support

    Joined:
    Jun 2, 2014
    Messages:
    1,253
    Likes Received:
    63
    Then other things you can check is that in Settings --> Network you have entered the correct Public IP and that it has not changed from that.
    Also could you please clarify one point, is the problem with the audio one-way (you cant hear the far end) or two-way (no audio in either direction)?
     
  5. Volkan Celebi

    Joined:
    Nov 20, 2017
    Messages:
    11
    Likes Received:
    0
    IP is correct.
    The problem is audio one-way. I can't hear anything from extensions but opposite side can hear me
     
  6. NickD_3CX

    NickD_3CX Support Team
    Staff Member 3CX Support

    Joined:
    Jun 2, 2014
    Messages:
    1,253
    Likes Received:
    63
    If everything has been checked and is correct, as well as the Firewall Checker passing, then the next step is run a packet capture and and check what IP and port 3CX is sending in the SDP section. the if packet are arriving to that port on the server.
     
  7. Volkan Celebi

    Joined:
    Nov 20, 2017
    Messages:
    11
    Likes Received:
    0
    The problem has been resolved from @NickD, . Factory reset and adding to phone to again extension problem solved.
     
  8. NickD_3CX

    NickD_3CX Support Team
    Staff Member 3CX Support

    Joined:
    Jun 2, 2014
    Messages:
    1,253
    Likes Received:
    63
    Just to add a bit more info, the issue turned out to be the communication between the extensions and the 3CX Server, not between 3CX and the provider.

    Specifically, the phone, although being on the same LAN as the 3CX Server had been provisioned as a remote STUN phone.
    This caused the phone to "talk" to the Public IP which resulted in loopback traffic on the Firewall, which was being dropped.
    Re-provisioning the phone as a Local Extensions is what solved it.

    @Volkan Celebi :
    A side note, I looked at the SIP messages coming from the phone as a result of the loopback traffic and have a slight suspicion that SIP ALG might be enabled, as some of the IPs in the SIP headers had been changed. Might not be causing a problem now, but something I would suggest looking into.

    Anyhow, locking post as the issue was confirmed as resolved.
     
Thread Status:
Not open for further replies.