Calls abort after 24 seconds

Discussion in '3CX Phone System - General' started by pjmeulen, Dec 1, 2010.

Thread Status:
Not open for further replies.
  1. pjmeulen

    Joined:
    Jun 27, 2008
    Messages:
    3
    Likes Received:
    0
    We have an Vigor 2820 router and configured it with Qos like descriped in this article:
    http://www.3cx.com/blog/voip-howto/draytek-firewall-voip/

    Dos Defense is not activated.

    Still all voip calls are aborted after 30 seconds.

    I have disabled Stun server because one of my voip providers asked for that.
    Is it therefore that my calls are aborted?

    Where can i find how to make NAT mapping on the Vigor 2820
     
  2. mfm

    mfm Active Member

    Joined:
    Mar 4, 2010
    Messages:
    641
    Likes Received:
    2
    Hi,

    It sounds like 3CX is not receiving the ACK. Your guess would be correct it is NAT issues.

    http://portforward.com/english/routers/port_forwarding/Draytek/Vigor-2800G/3CX.htm

    This is the closest router i could find to yours.

    Best of luck!
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. hornetsoft

    Joined:
    Nov 6, 2009
    Messages:
    10
    Likes Received:
    0
    if your router support sip alg switch it off I have had this problem loads of times and its worked for me on several routers not sure if there are any other problems caused by switching it off
     
  4. hornetsoft

    Joined:
    Nov 6, 2009
    Messages:
    10
    Likes Received:
    0
    Seems that you need to do this via telnet.

    sys sip_alg ?

    Should return the current status.

    usage: sys sip_alg [value]
    0 - disable SIP ALG
    1 - enable SIP ALG
     
Thread Status:
Not open for further replies.