Call's Disconnecting after 20 or 30 seconds

Discussion in 'Windows' started by Samwise, Sep 26, 2010.

Thread Status:
Not open for further replies.
  1. Samwise

    Joined:
    Sep 20, 2010
    Messages:
    4
    Likes Received:
    0
    If you are experincing calls disconnecting after 20 or 30 seconds
    please consider this option

    Possiable Fix set the Router Into Bridge Mode
     
  2. pim1

    Joined:
    Aug 15, 2008
    Messages:
    15
    Likes Received:
    0
    Entering STUN server could help i think.
     
  3. eggysplat

    Joined:
    Oct 12, 2010
    Messages:
    2
    Likes Received:
    0
    Stun server may help, the problem is down to a critical packet not being acknowledged. The service provider will normally try resending the packet 5 - 6 times over a 20 second period, then drop the call.

    If STUN doesn't help, then try checking your router to see if you can disable something called SIP ALG. Failing that, ensure that your Softphone is set to use "Any" outgoing port, and ask your service provider if they accept incoming SIP traffic on any port other than 5060. If they do, use the alternative port number. This is enough to fool your router into thinking the traffic isn't SIP, and stop it from meddling with packets.

    I work for a largeish VoIP provider myself and, this little nugget is a lifesaver! :)
     
  4. RichardCrabb1

    RichardCrabb1 New Member

    Joined:
    Mar 7, 2009
    Messages:
    196
    Likes Received:
    0
    Hi,
    This looks like the classic keep alive problem. Routers lose the port address translation after about 20 seconds to a minute. Ensure that in settings -> general -> global options keep alive is switched on. If you are using external extensions, then ensure that keep alives are enabled on the phone that is the external extension. Also, on settings -> network -> firwall ensure that "allow non sequential ports" is enabled. STUN as mentioned also helps. SIP ALGs on routers nearly always "break" SIP, as the ALG tries to correct SIP packets that the 3CX is also trying to correct. Good idea also to try using another port number for SIP if the provider allows it.

    FInally, if you can, use a static IP address (on the public side) and configure static port mapping on the router. Then ensure you test it with the 3CX firewall tester.
    Kind regards
    Richard Crabb
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Thread Status:
Not open for further replies.