Calls Dropping after 15 Minutes

Discussion in '3CX Phone System - General' started by interactive9, Jul 21, 2017.

Thread Status:
Not open for further replies.
  1. interactive9

    Oct 26, 2015
    Likes Received:
    Over the past week we have started to experience a problem with our external calls dropping after roughly 15 minutes.

    3CX is fully upto date and (apart from maybe an auto update) nothing has changed with our config.

    The SIP provider has reported this;

    "After 15 minutes our network will send a message to your phone system which needs to be replied to in order for the call to stay active. It appears this message is not being received by your phone system. As we receive no reply the call is ended from our side, but still looks active on your phone hence why it seems audio is lost.

    The port that the SIP traffic NATs out of has changed in the 15 mins since the call started, so the original port has closed. It's possible the 3CX must be refreshing registration with a new UDP stream each time.

    Alternately, the reason we are sending re-invite messages is because of the below message from the 3CX. This header could be removed.

    Session-Expires: 1800;refresher=uac"

    Is this more likely to point to a firewall issue? Or has something changed in one of the latest 3CX updates?

    Wer're using a mixture of Yealink handsets.

    Thanks in advance.

  2. YiannisH_3CX

    YiannisH_3CX Support Team
    Staff Member 3CX Support

    May 10, 2016
    Likes Received:
    Hello @interactive9

    What firmware are your phones running? If you are running firmware ending in .60 try upgrading them to .61 and let us know if the issue persists. Also make sure that the firewall checker has passed to avoid any firewall issues.
Thread Status:
Not open for further replies.