Calls taking 9 seconds to connect

Discussion in '3CX Phone System - General' started by Pete@nC, Jul 20, 2017.

Thread Status:
Not open for further replies.
  1. Pete@nC

    Joined:
    Jul 20, 2017
    Messages:
    1
    Likes Received:
    0
    Hello 3CX community,

    I recently decided to move our 3CX installation from a local server to the cloud. I have setup 3CX V15 on a Digitalocean VPS and everything has gone smoothly. I am using a 3CX FQDN and certificate.

    However, the only problem that has occurred is call connection time. When someone calls in, the phone rings instantly but on answering it takes exactly 9 seconds before the caller can be heard. After this 9 seconds everything is fine again. I know the problem isn't with the SIP trunk since the digital receptionist answers immediately.

    In the Activity log, this entry is created after the 9 seconds and the call is connected.
    [CM503003]: Call(C:18): Call to <sip:000@ncoders.3cx.co.uk:5060> has failed; Cause: 487 Request Terminated/INVITE from 127.0.0.1:5488

    Any ideas on how to go about solving this issue?
     
  2. accentlogic

    accentlogic New Member

    Joined:
    Nov 14, 2013
    Messages:
    174
    Likes Received:
    72
    We have seen an audio connection delay if there was not an inbound rule for a specific DID. The default rule for the trunk should route the call normally, but we noticed the exact same issue as you (but only 3 seconds) until we added in Inbound Rule for that DID.
     
  3. GiannosC_3CX

    GiannosC_3CX Guest

    Hi all,

    Please check your inbox, I have send a P.M.
     
  4. accentlogic

    accentlogic New Member

    Joined:
    Nov 14, 2013
    Messages:
    174
    Likes Received:
    72
    Thanks for the follow-up Giannos. For what it's worth, I did try to replicate this on another system, and did not notice the delay when there was no inbound rule for that specific DID. If I see this again I will get back to you. Hopefully Pete will follow up with you.
     
  5. GiannosC_3CX

    GiannosC_3CX Guest

    @accesstech,

    Thank you for your update, please feel free to contact us if you need any further assistance.
     
  6. Brett Coleman

    Joined:
    Jun 20, 2017
    Messages:
    27
    Likes Received:
    4
    Our system has this problem intermittently. Call usually connect after about 6 seconds.

    We are hosted on GCE and are using SBC to connect.

    Was there a quick and easy fix?
     
Thread Status:
Not open for further replies.