Calls via PSTN only connect to first extension

Discussion in '3CX Phone System - General' started by bobcat33071, Feb 1, 2010.

Thread Status:
Not open for further replies.
  1. bobcat33071

    Joined:
    Feb 1, 2010
    Messages:
    1
    Likes Received:
    0
    Hello World,

    I have a Patton 4960 connected to a Dialogic card in a Vocera server. The 3CX software has a PSTN line created using the Patton 4960. The PSTN status is Registered (idle) and the button is green. A also have 5 Hill-Rom RAS extensions created which are 5001 thru 5005. Their status is also Registered (idle) and the button is green. When I use a Vocera phone and call any of the 5 extensions, extension 5001 always answers. The actual RAS devices (5001 thru 5005) call each other successfully with the status changing to Connected for both extensions. Only when the call is originated from outside (Vocera) and comes across the PSTN does it ALWAYS connect to 5001, regardless of what extension is called. Here is the twist - I have 3CX version 5.0.3790.0 loaded on a different server and it works great. I tell the Vocera phone to call extension 5004 and the 3CX status shows the PSTN line connected to extension 5004. The server that has the problem is running 3CX version 6.1.1787.0 and all Vocera calls end up at extension 5001. I visually compared both 3CX configurations and they look good. I'm running out of hair on my head so any help would be greatly appreciated.

    Thanks,
    bobcat33071
     
  2. leejor

    leejor Well-Known Member

    Joined:
    Jan 22, 2008
    Messages:
    10,366
    Likes Received:
    227
    What is the incoming rule for the PSTN trunk? Does it point to a ring group (hunting or ring all) that all five extensions are in? Are you basing PSTN trunk to extension routing on incoming Caller ID?
     
  3. nb

    nb Support Team
    Staff Member 3CX Support

    Joined:
    Jun 7, 2007
    Messages:
    2,097
    Likes Received:
    142
    Version 6 of 3CX is too old. You are 2 complete versions backwards.
    Try version 8 and check how this goes.

    Make sure that the Patton is not configured to hunt.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Thread Status:
Not open for further replies.