Can not make/receive calls

Discussion in '3CX Phone System - General' started by spareine, Dec 27, 2008.

Thread Status:
Not open for further replies.
  1. spareine

    Joined:
    Dec 27, 2008
    Messages:
    3
    Likes Received:
    0
    Hello all,

    Your help would me most welcome. I am new to this and trying to set the 3CX system up with a Grandstream GXW4104 gateway to make/receive calls on the normal PSTN phone lines (The Netherlands, KPN). The gateway port is registered (green in status) and an extension (10) as well (3CX client). There is an outbound rule to direct calls starting with 9 to this gateway. All other settings are factory default.

    Somehow both incoming and outgoing calls are directed to extension 10, see below the logs. I have been looking but can not find the place where to change this or something related to the out-of-office matter. Also the client is 'available' and not 'busy'. Hope someone can help me out, thank you very much!

    Making outgoing call to number 91234567890:
    23:05:50.843 [CM503008]: Call(31): Call is terminated
    23:05:50.828 [CM503008]: Call(31): Call is terminated
    23:05:31.796 [CM503007]: Call(31): Device joined: sip:10@192.168.1.104:5060
    23:05:31.781 [CM503007]: Call(31): Device joined: sip:10000@127.0.0.1:5070;rinstance=dfad432673cb905b
    23:05:31.765 [CM505001]: Ext.10: Device info: Device Not Identified: User Agent not matched; Capabilities:[reinvite, replaces, able-no-sdp, recvonly] UserAgent: [Grandstream GXW4104 (HW 1.1, Ch:1) 1.0.1.8] Transport: [sip:192.168.1.100:5060]
    23:05:31.765 [CM503002]: Call(31): Alerting sip:10@192.168.1.104:5060
    23:05:30.734 [CM503004]: Call(31): Calling: Ext:Ext.10@[Dev:sip:10@192.168.1.104:5060]
    23:05:30.734 [CM503010]: Making route(s) to <sip:10@192.168.1.100:5060>
    23:05:30.734 [CM505002]: Gateway:[Grandstream GXW4104] Device info: Device Not Identified: User Agent not matched; Capabilities:[reinvite, replaces, able-no-sdp, recvonly] UserAgent: [3CX Phone 7.0.4184.0] Transport: [sip:192.168.1.100:5060]
    23:05:30.718 [CM503001]: Call(31): Incoming call from 10000@(Ln.10000@Grandstream GXW4104) to <sip:10@192.168.1.100:5060>
    23:05:30.687 [CM503012]: Inbound out-of-office hours rule for 10000 forwards to DN:10

    Trying to receive incoming call:
    23:09:33.593 [CM503008]: Call(32): Call is terminated
    23:09:33.593 [CM503015]: Call(32): Attempt to reach <sip:10@192.168.1.100> failed. Reason: Busy
    23:09:33.578 [CM503015]: Call(32): Attempt to reach <sip:10@192.168.1.100> failed. Reason: Busy
    23:09:33.578 [CM503014]: Call(32): No known route to target: <sip:10@192.168.1.100>
    23:09:33.578 [CM503010]: Making route(s) to <sip:10@192.168.1.100>
    23:09:33.578 [CM505001]: Ext.10: Device info: Device Not Identified: User Agent not matched; Capabilities:[reinvite, replaces, able-no-sdp, recvonly] UserAgent: [Grandstream GXW4104 (HW 1.1, Ch:4) 1.0.1.8] Transport: [sip:192.168.1.100:5060]
    23:09:33.562 [CM503001]: Call(32): Incoming call from Ext.10 to <sip:10@192.168.1.100>
     
  2. Discovery Technology

    Joined:
    Apr 19, 2008
    Messages:
    278
    Likes Received:
    0
    Try checking the ports underneath the gateway itself - there should be some inbound dialling rules for the number or indial range there.

    ie: PSTN Devices --> Gateway --> 10000, 10001 etc
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. spareine

    Joined:
    Dec 27, 2008
    Messages:
    3
    Likes Received:
    0
    Thanks for your help. It says under 'Office Hours' connect to extension 10. That should be fine for incoming calls? But why is that extension always busy, even if the client is available?

    Also for the outgoing calls I need to change something so that it is not routed to extension 10 but to the outgoing PSTN line.

    Thanks for any assistance!
     
  4. discovery1

    discovery1 Member

    Joined:
    Aug 4, 2008
    Messages:
    355
    Likes Received:
    0
    Assuming your Grandstream gateway is configured and working correctly, to make an outgoing call you need to have an outbound rule that sends calls to the gateway - which you mention you have.

    Check the properties of the Grandstream extension 10000 - have you enabled the "Allow outbound Calls on this line" option at the bottom of the properties page?
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  5. spareine

    Joined:
    Dec 27, 2008
    Messages:
    3
    Likes Received:
    0
    I've checked all that, all seems fine. It's always routing the calls to sip10 somehow. Very strange, if anyone has further suggestions... tried everything I can think of!

    Thanks.
     
  6. discovery1

    discovery1 Member

    Joined:
    Aug 4, 2008
    Messages:
    355
    Likes Received:
    0
    If it is always routing the calls to ext 10 then there is either a default mapping from the external number directly to ext 10 in the properties of the Grandstream or you have an inbound rule set.

    What version of 3CX are you using?
    Make sure you have the latest version and also that you have set the Grandstream up correctly as per the documentation

    http: //www.3cx.com/voip-gateways/Grandstream-GXW-41044108 NO LONGER AVAILABLE. NEW LINK http://www.3cx.com/voip-gateways/.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  7. amygoda

    amygoda Member

    Joined:
    Sep 18, 2006
    Messages:
    436
    Likes Received:
    0
    Hello,
    I tried Galal's settings and it works fine with me
    check it
    http://www.3cx.com/forums/poor-inbound-call-quality-newbie-7645.html?highlight=4104
     
Thread Status:
Not open for further replies.