Can not register phone

Discussion in '3CX Phone System - General' started by Cairnsb, Dec 27, 2013.

Thread Status:
Not open for further replies.
  1. Cairnsb

    Joined:
    Dec 27, 2013
    Messages:
    2
    Likes Received:
    0
    Hoping someone has run into this...

    I have 3CX v12, and Cisco SPA504G phones.

    I can create a new ext, and then perform a factory reset on the phone. The phone will display the right name, number, and evern download and update the firmware.

    However it never registers in the system.

    Using wireshark on the server I can see the SIP traffic and one packet stands out...

    SIP 406 Status: 403 Invalid password provided

    I have tripple checked all the passwords related to the ext, any thoughts?
     
  2. lneblett

    lneblett Well-Known Member

    Joined:
    Sep 7, 2010
    Messages:
    2,083
    Likes Received:
    61
    There may be a little confusion in the description or order of how you indicate things progressing.

    First, you really don't need wireshark just yet. Simply look at the extension status within 3CX and if not green, then the extension will not work. You can then go to the server activity log and/server event log and get the details about the extension and hopefully from these, the reasons behind the malfunction.

    Normally the sequence would be to create the extension within 3CX. You did not indicate if the phone is on the local LAN or remote. You also did not indicate how the phone was provisioned, either manually or by 3CX as a) a result of the Discovery and assign to the extension process or b) you filled out the MAC and pertinent info in the phone provisioning tab and re-provisioned.

    You indicated you did the factory reset and then somehow or another "the phone will display the right name, number.............. It also apparently picked up the correct firmware provisioning path (and even presumably the remote phonebook and even configuration provisioning paths).

    You might look at the security tab and see if the IP was blacklisted and if so, remove. Not knowing if the phone was ever in use before, and assuming it may have been, perhaps the system blacklisted the phone while you were in the midst of the effort. You might also want to go into 3cx and do a copy of the password and then into the phone's interface and paste same just to be sure.
     
  3. Cairnsb

    Joined:
    Dec 27, 2013
    Messages:
    2
    Likes Received:
    0
    Thanks for the response!

    Create the extensions in 3cx and use DHCP opton 66 to register the phones.

    Going back through the logs, I saw:


    28-Dec-2013 17:49:30.050 Endpoint Extn:3964: the request from external source 10.10.0.1:5060 is blocked. Reason: the extension is configured to block external registrations.

    This made no sense as the phone and the server are on the same subset.

    Did a little digging:
    http://www.3cx.com/blog/releases/3cx-phone-system-v10-rc/

    Turns out there is an option in the extension under options->restrictions->disallow use of extension outside of LAN

    Unchecked that box and the phones registered.
     
Thread Status:
Not open for further replies.