Can Only Make Inbound Calls to Ext 100

Discussion in '3CX Phone System - General' started by olivermsubadra, Feb 23, 2016.

Thread Status:
Not open for further replies.
  1. olivermsubadra

    Joined:
    Feb 18, 2016
    Messages:
    33
    Likes Received:
    0
    Hi,

    We have a selection DDIs, all set up with their own inbound rules. The rules stipulate that calling a DDI should forward it to the appropriate extension number. However, when making inbound calls to any of our DDIs, the calls are allways automatically routed to ext 100 and stop there.

    We have one SIP trunk with one port. The port has been configured so that all calls are routed to ext 100 (the operator) during office hours. What I assume should happen is that when one of our DDI numbers is called, the call is routed over to the appropriate extension instead. This doesn't seem to be happening, though.

    I'm hoping this isn't just a feature of the trial version, which is what we're currently using.

    Thanks for your help.
     
  2. daktur

    daktur New Member

    Joined:
    Oct 15, 2015
    Messages:
    226
    Likes Received:
    7
    Hi,

    There seems to be a misconfiguration parameter in the inbound rules are you sure each line incomes with a different DID?

    Try using wildcards to make your dids, it could work. If your did is +18555555555 try *8555555555 and so one, this should work.

    Good luck
     
  3. olivermsubadra

    Joined:
    Feb 18, 2016
    Messages:
    33
    Likes Received:
    0
    Hi daktur. It did work, thank you. Could you explain why?

    I set up the DID numbers in the inbound rules with the same prefix: xxxxxxxx101, xxxxxxxx102, xxxxxxxx103. When I removed the prefix and added the wildcard, everything started working as it should.
     
  4. leejor

    leejor Well-Known Member

    Joined:
    Jan 22, 2008
    Messages:
    10,752
    Likes Received:
    285
    I would think that because there was not an exact match, with your original settings, the call would default to the operator extension. I have to assume that your provider is sending something slightly different (prefix?) than your original DID parameters.
     
  5. olivermsubadra

    Joined:
    Feb 18, 2016
    Messages:
    33
    Likes Received:
    0
    That does make sense. I'm not sure where the mismatch between the dialed number and the original DID number in the rule occurred. Maybe the provider adds a country dialing code somewhere along the way?
     
  6. daktur

    daktur New Member

    Joined:
    Oct 15, 2015
    Messages:
    226
    Likes Received:
    7
    Olivermsubadra,

    That's what Leejor explained, glad to help and hope you enjoy 3cx.

    I usually set all my did with the wildcard instead of country code and works great.

    Good luck.
     
Thread Status:
Not open for further replies.