Can register phones using TCP

Discussion in '3CX Phone System - General' started by johnp@vvmicro.com, Jan 14, 2012.

Thread Status:
Not open for further replies.
  1. johnp@vvmicro.com

    Joined:
    Dec 30, 2011
    Messages:
    4
    Likes Received:
    0
    I'm having an issue where I'm unable to connect the 3CX phone from inside or outside the office using TCP. UDP works just fine, but for some reason TCP stopped working a few days ago. At first I thought it was a firewall issue, but I even tried from a 3CX phone in the office and it still wont register. No firewall or AV software is running on the PBX. The reason I want to use TCP is that's the only way I can get the outside phones to receive incoming calls without using the tunnel. The tunnel is not an option for the iPhone.
     
  2. misstake2012

    Joined:
    May 23, 2011
    Messages:
    40
    Likes Received:
    1
    Hi.
    I'm also use TCP transport on my iPhone 3CX Phone app. In my Wifi network everything is fine. In 3G network it is working bad.
    Maybe you problem in bandwidth of wireless network?
     
  3. danhriscanu

    danhriscanu New Member

    Joined:
    Nov 29, 2011
    Messages:
    232
    Likes Received:
    0
    Maybe you should post more information here in order for us to be able to help you. Like Whireshark capture when its trying to register with the error that it received, Server log status, type of phone used and exact configuration.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  4. johnp@vvmicro.com

    Joined:
    Dec 30, 2011
    Messages:
    4
    Likes Received:
    0
    Well, I waited until the next day and it started working. The only clue that I have is that there was an IP that was trying to connect and was blacklisted. I set the firewall to block this IP and everything was working fine the next day. As far as the issue with remote phones not receiving incoming calls using UDP, this was a problem with my NetGear N300 at home. I found a firmware that allows you to turn off SIP ALG using the web interface. Everything worked correctly after that. It even took care of my problem where calls from the remote site were being disconnected after 32 seconds.
     
Thread Status:
Not open for further replies.