Cannot change default ring tone on SNOM

Discussion in '3CX Phone System - General' started by mnorfolk, Sep 12, 2013.

Thread Status:
Not open for further replies.
  1. mnorfolk

    Joined:
    Sep 12, 2013
    Messages:
    1
    Likes Received:
    0
    A question for anyone who has successfully edited the standard provisioning templates as supplied in v12.
    I understand that support isn't given for editing the provisioning templates, so I wonder if anyone on the forum has managed this.

    I am using SNOM 710 and 720 handsets (and the latest 3CX version) and I would like to make two simple changes to the templates...

    • 1) Change the display to show the extension number and username
      2) Change the default ring tone.

    1) Change the Display - I have managed to do this by editing the variables in the Background Logo section of the template...

    Code:
        <!--########################################################-->
        <!--###                 Background Logo                  ###-->
        <!--########################################################-->
    
    	<user_idle_text idx="1" perm="">%%extension_number%% - %%extension_first_name%%</user_idle_text>
    2) Change the Default Ring Tone - I haven't been able to do this!
    The following code in the template looks as though it would change the ringer tone, so I simply changed the number to Ringer2 or Ringer3 for example, but it doesn't work.

    Code:
    <!--########################################################-->
    <!--###       Distinctive ringing                                                      ###-->
    <!--########################################################-->
    	
    <!--# Internal Calls-->
    <alert_internal_ring_text perm="">internal</alert_internal_ring_text> 
    <alert_internal_ring_sound perm="">Ringer1</alert_internal_ring_sound> 
    This parameter is obviously for the internal ring, but I tried changing it for external as well.

    Has anyone managed to change the ring tone using a template?

    Thanks.
     
  2. sbowers

    Joined:
    Feb 23, 2015
    Messages:
    12
    Likes Received:
    1
    mnorfolk - I am experiencing the same problem. I attempted to change the config file to where there is no default ring tone set but it keeps on leaving it as default. I have also tried the fixes you did with the same outcome. I am still working on this and if I figure it out I will let you know.
     

    Attached Files:

    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. sbowers

    Joined:
    Feb 23, 2015
    Messages:
    12
    Likes Received:
    1
    I figured it out. In the provisioning template do:

    <!--# Internal Calls-->
    <alert_internal_ring_text perm="">internal</alert_internal_ring_text>
    <alert_internal_ring_sound perm="">Custom</alert_internal_ring_sound>

    <!--# Calls from Exernal-->
    <alert_external_ring_text perm="">external</alert_external_ring_text>
    <alert_external_ring_sound perm="">Custom</alert_external_ring_sound>

    This worked right away for me.

    Hope this helps!
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Thread Status:
Not open for further replies.