Cannot get inbound fax working.

Discussion in '3CX Phone System - General' started by cejota3, Jan 8, 2010.

Thread Status:
Not open for further replies.
  1. cejota3

    Joined:
    Oct 18, 2009
    Messages:
    16
    Likes Received:
    0
    Hello Everyone,

    My problem is that I cannot get inbound faxing to work. I've configured the fax server and default fax extension as instructed in the documentation. Inbound fax calls are being connected to the system fax extension, but after just a few seconds, the call is being dropped. The answering side, i.e. the 3CX system, is not giving a fax answering "warble" if you call it directly (I'm not sure if that should even happen with T.38).

    I've tried:
    - Having the inbound trunk be A) a VoIP provider, that assures me they are T.38 compliant and B) a good old fashion POTS line gateway-ed via a Patton FXO gateway.
    - Making sure the 5100 and 10000 TCP and UDP ports are open on my server, as they both seem to play a part in faxing.
    - Followed the instructions on the 3CX FAQ "Receiving faxes from VoIP providers" at http://wiki.3cx.com/documentation/fax-1/receiving-faxes-from-voip-providers
    - Fax directly to "The e-mail address of a (regular) extension" rather than the system's default fax extension.
    - Adding the "SipPort" setting to the 3cxPhoneSystem.ini file, as our Network SIP port is 5070.

    None of these things have helped, and our phone system works just fine otherwise (and has for some time now). We are running the latest version 8.0.9532.468, and our server has a NIC with a static public IP address (i.e. it is not behind a hardware firewall or NAT).

    Here is an example of what is happening:

    16:33:09.670 [CM503008]: Call(727): Call is terminated
    16:33:08.264 [CM503007]: Call(727): Device joined: sip:989@63.224.85.165:5100;user=phone
    16:33:08.249 [CM503007]: Call(727): Device joined: sip:techadm@209.212.88.134:5060
    16:33:08.233 [CM503002]: Call(727): Alerting sip:989@63.224.85.165:5100;user=phone
    16:33:08.108 [CM503025]: Call(727): Calling @[Dev:sip:989@63.224.85.165:5100;user=phone]
    16:33:08.092 [CM503004]: Call(727): Route 1: @[Dev:sip:989@63.224.85.165:5100;user=phone]
    16:33:08.092 [CM503010]: Making route(s) to <sip:989@63.224.85.165:5070;user=fax>
    16:33:08.077 [CM505003]: Provider:[PINS] Device info: Device Not Identified: User Agent not matched; Capabilities:[reinvite, replaces, able-no-sdp, recvonly] UserAgent: [] PBX contact: [sip:techadm@63.224.85.165:5070]
    16:33:08.077 [CM503001]: Call(727): Incoming call from 3036904065@(Ln.10005@PINS) to <sip:989@63.224.85.165:5070;user=fax>
    16:33:07.967 [CM503012]: Inbound out-of-office hours rule (General Adigo Fax ) for 10005 forwards to Fax:989

    You can see that it just seems to route fine, and then a second or two later "Call is terminated".

    This has got to be something simple, right? Any help would be greatly appreciated.

    Thank you!
    C.J.
     
  2. leejor

    leejor Well-Known Member

    Joined:
    Jan 22, 2008
    Messages:
    10,366
    Likes Received:
    227
    The first question I would ask is...are you using the Demo code in conjunction with the free version?
     
  3. cejota3

    Joined:
    Oct 18, 2009
    Messages:
    16
    Likes Received:
    0
    Nope. Fully licensed.
     
  4. Nick Galea

    Nick Galea Site Admin

    Joined:
    Jun 6, 2006
    Messages:
    1,888
    Likes Received:
    190
    The inbound fax works with supported gateways and selected VoIP providers. From the logs it appears you are not using the system fax extension 888 but another extension 989? Please review the FAQ in that regard.

    I also suggest contacting our technical support department If you have a support package. They will definitely be able to get your PATTON device to receive faxes. In regards to the VoIP provider it will depend on the T38 provided by your VoIP provider and their willingness to interoperate.....
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  5. cejota3

    Joined:
    Oct 18, 2009
    Messages:
    16
    Likes Received:
    0
    Yes, I have changed the default Fax Server extension on our 3CX system to 989. That is because I needed to use extension 888 as a "regular" extension. The FAQ does not say it would be problem to make this change. You can see from the below screen shots the configuration of this:

    [​IMG]

    [​IMG]

    Again, calls make it to this extension (989, our fax server extension), but then just drop.

    No, we do not have a support package, but if that is what it takes to get this resolved. I'll consider it. It just seems ... frustrating is the most polite word I can think of right now ... to have to resort to that given I thought this was functionality that was supposed to "just work"? I've reviewed my Patton FXO gateway (a SmartNode 4114), and there doesn't seem to be anything special to have to do with that to get its T.38 pass-through to work. However, I will stress that what I am trying to do is get this to work via my VoIP provider (who again assures me their SIP trunk to us is T.38 enabled and compliant), but I figure if I cannot even get this to work with the Patton, then it must be a 3CX configuration issue and why bother with the further complications of the VoIP provider.

    It is just frustrating that there are is no additional logging or troubleshooting procedures I can follow to try to further this along.

    Let me point out one other thing. Our server has two NIC's. One of is connected to our "inside" network with an IP address of 10.0.0.170, and the other is connected directly to the internet with a static IP address (63.224.85.165). I've tried configuring the "Fax Server Host" setting to both of these IP addresses (with also the corresponding change to the "in_session.cfg" template as per the FAQ), and it still doesn't work. And I've done all of this with the Windows built-in firewall turned-off (let alone that I've opened up all the applicable ports anyway).

    I've spent a lot of time on this, and haven't just willy-nilly made this post. I consider myself pretty sophisticated with all of this stuff, and I'm more than willing to spend more time on it, I just don't know where to go next. Again, is there any way to get more info or logging from somewhere?

    Like I said earlier, if I have to purchase a support package to get this working, then I guess so be it, but that sure seems silly.

    Thanks for your time in reading this and everyone's responses,
    C.J.
     
  6. national1

    Joined:
    Mar 24, 2009
    Messages:
    2
    Likes Received:
    0
    We're having the same problem.
    The machine sending the fax sends a handshake, the 3CX does not reply back.
    My guesses have been that it would be a "PBX delivers Audio", Codec or firewall problem.

    Any help would be appreciated

    PS: Fax machine works well when connected to a PSTN

    Martin
     
  7. carolinainnovative

    Joined:
    May 4, 2009
    Messages:
    369
    Likes Received:
    5
    which voip provider? Many of them will assure you that they are T38 compatible - but I've worked with THREE SEPARATE provideds and could not get inbound or outbound faxing to work with them. I _FINALLY_ have it working through ONE particular company, but they had to make sure that they created my DID (and soon - port my number) through the correct telco provider on THEIR end in order to increase chances of success.

    Also - calling the fax ext directly will yeild different results depending on how you call it. If you call it from the outside world, you should hear fax tones. If you call it from your (non-T38-speaking) sip phone, you'll hear nothing then get disconnected. If you call it from an internal T-38-speaking ATA, you'll hear fax tones...

    Some experiences on my end:

    1) the "how to fax over voip provider" faq is great - except it assumes you're on NAT. If you aren't on NAT - ie you're like me or the OP and have a public ip bound to the nic of your server, the nat portions don't seem to apply. I don't know if going ahead and making the changes to the template files makes any difference, but I don't have the changes in there and it works like a champ.

    2) setup a separate provider in 3cx specifically for fax. This used to be highly recommended for T38 - don't know if it still is or not. Ask your provider for a second set of sip creds. Thats what I did, anyway.

    3) Turn on "supports replace" and "supports reinvite" on the voip provider and turn off PBX delivers audio... though i'm not sure how much the latter matters - I've had it on and off and T38 still works. I think 3cx has set their system up at this point where the fax bypasses that anyway.


    I have two recommendations for you -

    1) use wireshark on your 3cx box to see your system communicating with the voip provider. Look at the sip invites. Make sure they include the T38 headers, etc. I had a problem where my systems never got the T38 re-invite when I was testing. Turns out it was a firewall issue.

    2) if you have an T38-speaking ATA, try to get it working directly with your voip provider (or outbound through your patton smartnode) first before you play with 3cx. That way you can establish beyond a shadow of a doubt that YES, THEY SUPPORT T38 properly (or YES, the patton is configured properly) and it is just something in your 3cx/network/firewall setup. Of course, make sure your ATA is well connected to the internet if you're testing the voip provider or you could inadvertantly introduce your own set of firewall/nat issues there.

    3) once you've established #2 is ok, setup the same ATA as a FAX extension within 3cx. Configure it appropriately. Fax something to 888 and see if it works.

    I have mine faxing internally and externally - using both physical fax machines for outbound and T38FaxVoip's T38 driver for Windows Fax. One of my fax machines is remote from my 3cx box (whole other set of fun issues there).

    I'll be happy to assist you any way I can, or contact support (with contract in hand). They're a great resource.
     
  8. cejota3

    Joined:
    Oct 18, 2009
    Messages:
    16
    Likes Received:
    0
    Hello National1,

    I'm realizing I never followed up to my post. So let me quickly do that now.

    For starters, all of Salter's info and insight is GREAT. It is that kind of information that I think should be more formally presented within the 3CX help and installation, but I digress ...

    This did finally start working for me once I finally did get my provider to really get T.38 turned on so to say. In other words, Salter's first point about them assuring you they are T.38 compatible, or that they have it turned on, but in fact really are not, is very true. In the end, I really didn't have to go through all of the crazy mucking of settings deep within 3CX to get this working. I really wish the 3CX log would tell you something that would clearly say, "No T.38" or something like that.

    I should also point out that I had a need for another fax number where there was no way the provider could give me T.38. So I basically just routed that number to a dedicated extension that connects a good, old-fashion fax machine via a Linksys ASA adapter. Those fax calls are then coming over "regular" G.711u codec, without any other special treatment for fax. That setup works okay. There are definitely times, especially when we are trying to send faxes (basically never when receiveing faxes) where we get errors that I am highly, highly suspicious is because of this other setup that is less than ideal, but we've learned to live with it.

    In short, it really was a big pain getting that inbound faxing working with 3CX, and I really think they need to do a lot more to make the setup, diagnositics, and interopability of it better. Fax over IP, be it with 3CX or otherwise, is not all that it is cracked up to be. There's a lot of black magic to it.

    C.J.
     
  9. carolinainnovative

    Joined:
    May 4, 2009
    Messages:
    369
    Likes Received:
    5
    CJ you are correct - there is a LOT of black magic involved... that is why folks like KerryG of 888voipstore will often - somewhat adamantly - tell you not to bother with T38 faxing and instead use something like FaxxBochs.

    I wish we could blame it on 3cx and say they need to improve their product - but in reality, its T38 in general.

    I'm a personal fan of FaxBack. Theirs uses T38 but also uses a proprietary HTTPS transport - much like FaxxBochs. It is MUCH more reliable than T38 because it isn't subject to the same latency issues as T38... however, both turn faxing into more of a "store and forward" concept than a stream. Then again - if you look at what fax is, Store-and-forward makes more sense anyway... it is just a document, after all. Not all that different from an email...

    Glad you got it working.
     
Thread Status:
Not open for further replies.