Cannot make or receive external calls

Discussion in '3CX Phone System - General' started by muaddib32, Oct 16, 2010.

Thread Status:
Not open for further replies.
  1. muaddib32

    Joined:
    Oct 16, 2010
    Messages:
    68
    Likes Received:
    0
    I have just set up the 3CX phone system for the first time. I have configures two VOIP providers. Both are showing as registered. I have run the firewall test and passed with flying colours. I have applied all the updates. I have created two extensions. I can call internally between the two extensions. However I cannot receive or make external calls. I can with with the same VOIP accounts using other equipment on the same network.

    Any suggestions?
     
  2. leejor

    leejor Well-Known Member

    Joined:
    Jan 22, 2008
    Messages:
    10,375
    Likes Received:
    231
    Yes...have a look at, and if necessary, post, the 3CX logs. They should show why the calls are failing. It may have something to do with the way you have configured your outbound rules.
     
  3. muaddib32

    Joined:
    Oct 16, 2010
    Messages:
    68
    Likes Received:
    0
    Hi Leejor,

    Okay, have fixed outgoing calls. I had limited the call length to only 8 digits. But I can't get incoming calls to work. I have tried no incoming rules just the default rule for the voip provider (forward all calls to extension 100). No good. Gets unconfigured mailbox. Tried all sorts of incoming rules but still no good. This is the log (obviously I have xxx'ed the identifying IP address and phone number):

    17:05:37.097 [CM503020]: Normal call termination. Reason: Disabled by Forwarding Rule
    17:05:37.050 [CM503016]: Call(32): Attempt to reach <sip:EndCall@192.168.64.25:5060;user=endcall> failed. Reason: Busy
    17:05:36.956 [CM503010]: Making route(s) to <sip:EndCall@192.168.64.25:5060;user=endcall>
    17:05:36.611 [CM505003]: Provider:[Engin - AU] Device info: Device Not Identified: User Agent not matched; Capabilities:[reinvite, replaces, able-no-sdp, recvonly] UserAgent: [] PBX contact: [sip:039017xxxx@150.101.163.xxx:5060]
    17:05:35.748 [CM503001]: Call(32): Incoming call from 0418146xxx@(Ln.10000@Engin - AU) to <sip:EndCall@192.168.64.25:5060;user=endcall>
    17:05:34.759 [CM503012]: Inbound ?? rule (unnamed) for 10000 forwards to DN:EndCall
    17:05:28.893 [CM504004]: Registration succeeded for: 10000@Engin - AU
    17:05:27.010 [CM504003]: Sent registration request for 10000@Engin - AU

    The problem seems to me to be the 'Inbound ?? rule (unnamed) for 10000 forwards to DN:EndCall' but I can't work out how to implement an inbound rule that actually redirects to extension 100.

    I imagine its quite simple but I can't work it out from the instructions.

    Regards
    Ben
     
  4. sigma1

    sigma1 Active Member

    Joined:
    Nov 20, 2009
    Messages:
    542
    Likes Received:
    1
    Do you have a phone (soft or hard) registered for extension 100? Does ext. 100 have any FWD rules set?
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  5. muaddib32

    Joined:
    Oct 16, 2010
    Messages:
    68
    Likes Received:
    0
    Yes, two softphones. No forwarding. I can call internally between the two extensions.
     
  6. muaddib32

    Joined:
    Oct 16, 2010
    Messages:
    68
    Likes Received:
    0
    I didn't really answer the question. Two softphones, one on ext 100 the other on ext 101
     
  7. sigma1

    sigma1 Active Member

    Joined:
    Nov 20, 2009
    Messages:
    542
    Likes Received:
    1
    Can you please post a screen shot of both the Edit Voip provider and the edit DID screens? That will help
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  8. muaddib32

    Joined:
    Oct 16, 2010
    Messages:
    68
    Likes Received:
    0
    I haven't added a DID rule as the instructions say it is not necessary. Mind you I have experimented with this but it didnt' work anyway
     

    Attached Files:

    • port.png
      port.png
      File size:
      31.4 KB
      Views:
      1,444
    • voip.png
      voip.png
      File size:
      20.9 KB
      Views:
      1,442
  9. muaddib32

    Joined:
    Oct 16, 2010
    Messages:
    68
    Likes Received:
    0
    Well, it seems there was nothing wrong with my setup. I changed the forwarding to voicemail to see if that made any difference. It worked. And the voicemail was accessible from the extension. So then I changed the forwarding back to the extension and it now works.

    So it seems it was just a glitch with the software.
     
Thread Status:
Not open for further replies.