Dismiss Notice
We would like to remind you that we’re updating our login process for all 3CX forums whereby you will be able to login with the same credentials you use for the Partner or Customer Portal. Click here to read more.

Solved Cannot make outbound calls to other extensions - Yealink T21p E2 & T27G

Discussion in '3CX Phone System - General' started by Owen Last, Nov 13, 2017.

Thread Status:
Not open for further replies.
  1. Owen Last

    Joined:
    Nov 8, 2017
    Messages:
    8
    Likes Received:
    0
    I'm in the process of configuring and testing 3CX for the first time. I've managed to segment the data and phone networks using two network cards (NOT Vlan'd)

    I have the 3CX App on my iPhone, and 3CX client installed on my Desktop PC, and both of them connect to 3CX over the Data network (192.168.16.xxx). Both were seen in "phones" before being provisioned (not sure if that's important but will explain later)

    I've added the 2nd NIC and connected two hard phones (Yealink T21P E2 and a T27G), both of which have IP's in the 172.16.12.xxx range. the phones initially weren't seen under "Phones" in 3CX, I had to manually provision them to each of their respective extensions before they appeared.

    Using the iPhone and Windows apps, I can call the two Yealink phones that are on the 172.16.12.xxx range.
    However, the two Yealink phones can't outbound to eachother, or the iPhone app / windows client sat on the 192.168.16.xxx range.

    the calls don't appear in the call log in 3CX, and the message that displays on the Yealink phones are simply

    "Call Failed!
    (ext)
    Decline"

    if anyone has had this before, or can offer any advice, that'd be much appreciated.
     
  2. leejor

    leejor Well-Known Member

    Joined:
    Jan 22, 2008
    Messages:
    11,113
    Likes Received:
    329
    The fact that the Yealinks are receiving calls would suggest that they are registered correctly. Since 3CX sees no call attempts, makes me suspect an internal dialplan, or other option misconfiguration, on the Yealinks, preventing calls from leaving the sets.
    You don't say if the Yealinks can make outside calls.
     
    #2 leejor, Nov 13, 2017
    Last edited: Nov 13, 2017
  3. DavidWebb

    Joined:
    Jul 22, 2016
    Messages:
    18
    Likes Received:
    1
    I have a simpler network and different models of phones, a T56A, T48G, and a CP860, but all the same symptoms. Did you ever figure out the cause?

    I was testing Debian for a bit, but switched back to a Windows host because I'm no good with Linux (unfortunately). That's when my problems started. I restored a backup, made the IP the same, and everything is working except for the IP phones making any calls, internal or external. The softphones work completely and the IP phones can receive calls.
     
  4. leejor

    leejor Well-Known Member

    Joined:
    Jan 22, 2008
    Messages:
    11,113
    Likes Received:
    329
    Since your softphones are working correctly, it points to a (configuration?) problem with the Yealink sets. If you see no sign of a call attempt, in the 3CX Activity Log, even incorrect digits, then I'd hazard a guess that it's a setting within the sets that is preventing the digits from being sent. Usually this is some sort of internal dial-plan or digit screening, but, there may be another option, perhaps some sort of security feature? Generally, SIP sets will have a "dial" key, or they use #, as an "end of string" character to get around a fixed dial-plan.

    Could it be that the sets are sending their INVITE to the wrong destination or port? Wireshark would provide information on what, if anything, is leaving the sets.

    Were changes made to the PBX configuration after the set configuration files were created?
     
  5. DavidWebb

    Joined:
    Jul 22, 2016
    Messages:
    18
    Likes Received:
    1
    Well I fixed it by making a new backup and re-installing. My last backup included custom template and phone firmwares, because I didn't want to re download them. This one I excluded that. I haven't ever made any custom templates, but I'm guessing that was the issue anyway.
     
  6. apostolis_3CX

    apostolis_3CX Support Team
    Staff Member 3CX Support

    Joined:
    Nov 1, 2017
    Messages:
    149
    Likes Received:
    15
    Glad to hear your issue was resolved.
     
Thread Status:
Not open for further replies.