Solved Cannot make outbound calls.

Discussion in '3CX Phone System - General' started by dz2017, May 17, 2017.

Thread Status:
Not open for further replies.
  1. dz2017

    Joined:
    May 17, 2017
    Messages:
    3
    Likes Received:
    0
    Hello,
    I have gone through google and through the forum here but I am unable to find an solution to our problem.

    No users can make outbound calls. The phone displays 404 not found error on the screen. (Ubiquiti UVP)
    The activity logs on 3CX show 05/17/2017 1:18:47 PM - [Flow] Target endpoint for 214******** can not be built!
    I did a packet capture and the INVITE, 100 Trying and 404 Not Found output is below.

    Does anyone know what i'm doing wrong? Thanks in advance for your help.

    =====================================
    INVITE sip:2145161704@10.180.10.5:transport=udp
    =====================================

    Message Header
    Via: SIP/2.0/UDP 10.180.10.146:5060;rport;branch=z9hG4bKPjOSTs4mkEptnDdLcQm-f-LqbJfAtaBA8x
    Transport: UDP
    Sent-by Address: 10.180.10.146
    Sent-by port: 5060
    RPort: rport
    Branch: z9hG4bKPjOSTs4mkEptnDdLcQm-f-LqbJfAtaBA8x
    Max-Forwards: 70
    From: <sip:813@10.180.10.5>;tag=KPVRqcVdVy482Oj9KORQNCQVHI2lztHZ
    SIP from address: sip:813@10.180.10.5
    SIP from tag: KPVRqcVdVy482Oj9KORQNCQVHI2lztHZ
    To: <sip:2145161704@10.180.10.5>
    SIP to address: sip:2145161704@10.180.10.5
    Contact: <sip:813@10.180.10.146:5060;ob>
    Contact URI: sip:813@10.180.10.146:5060;ob
    Call-ID: WlTzX.5krMD5H12VsZVGyTMymtsjeHDF
    CSeq: 8906 INVITE
    Allow: PRACK, INVITE, ACK, BYE, CANCEL, UPDATE, INFO, SUBSCRIBE, NOTIFY, REFER, MESSAGE, OPTIONS
    Supported: replaces, 100rel, timer, norefersub
    Session-Expires: 1800
    Min-SE: 90
    User-Agent: UniFi VoIP Phone 5.0.13.656
    Proxy-Authorization: Digest username="813", realm="3CXPhoneSystem", nonce="414d535c0f2d250700:7d40c25ead254096aa99b546600487e1", uri="sip:2145161704@10.180.10.5;transport=udp", response="ed7169e75d7d15e914435b3f1bf9020b", algorithm=MD5
    Authentication Scheme: Digest
    Username: "813"
    Realm: "3CXPhoneSystem"
    Nonce Value: "414d535c0f2d250700:7d40c25ead254096aa99b546600487e1"
    Authentication URI: "sip:2145161704@10.180.10.5;transport=udp"
    Digest Authentication Response: "ed7169e75d7d15e914435b3f1bf9020b"
    Algorithm: MD5
    Content-Type: application/sdp
    Content-Length: 322

    ==================================
    100 Trying
    ==================================


    Message Header
    Via: SIP/2.0/UDP 10.180.10.146:5060;rport=5060;branch=z9hG4bKPjOSTs4mkEptnDdLcQm-f-LqbJfAtaBA8x
    Transport: UDP
    Sent-by Address: 10.180.10.146
    Sent-by port: 5060
    RPort: 5060
    Branch: z9hG4bKPjOSTs4mkEptnDdLcQm-f-LqbJfAtaBA8x
    To: <sip:2145161704@10.180.10.5>
    SIP to address: sip:2145161704@10.180.10.5
    From: <sip:813@10.180.10.5>;tag=KPVRqcVdVy482Oj9KORQNCQVHI2lztHZ
    SIP from address: sip:813@10.180.10.5
    SIP from tag: KPVRqcVdVy482Oj9KORQNCQVHI2lztHZ
    Call-ID: WlTzX.5krMD5H12VsZVGyTMymtsjeHDF
    CSeq: 8906 INVITE
    Content-Length: 0


    ==================================
    404 Not Found
    ==================================

    Message Header
    Via: SIP/2.0/UDP 10.180.10.146:5060;rport;branch=z9hG4bKPjOSTs4mkEptnDdLcQm-f-LqbJfAtaBA8x
    Transport: UDP
    Sent-by Address: 10.180.10.146
    Sent-by port: 5060
    RPort: rport
    Branch: z9hG4bKPjOSTs4mkEptnDdLcQm-f-LqbJfAtaBA8x
    Max-Forwards: 70
    From: <sip:813@10.180.10.5>;tag=KPVRqcVdVy482Oj9KORQNCQVHI2lztHZ
    SIP from address: sip:813@10.180.10.5
    SIP from tag: KPVRqcVdVy482Oj9KORQNCQVHI2lztHZ
    To: <sip:2145161704@10.180.10.5>
    SIP to address: sip:2145161704@10.180.10.5
    Contact: <sip:813@10.180.10.146:5060;ob>
    Contact URI: sip:813@10.180.10.146:5060;ob
    Call-ID: WlTzX.5krMD5H12VsZVGyTMymtsjeHDF
    CSeq: 8906 INVITE
    Allow: PRACK, INVITE, ACK, BYE, CANCEL, UPDATE, INFO, SUBSCRIBE, NOTIFY, REFER, MESSAGE, OPTIONS
    Supported: replaces, 100rel, timer, norefersub
    Session-Expires: 1800
    Min-SE: 90
    User-Agent: UniFi VoIP Phone 5.0.13.656
    Proxy-Authorization: Digest username="813", realm="3CXPhoneSystem", nonce="414d535c0f2d250700:7d40c25ead254096aa99b546600487e1", uri="sip:2145161704@10.180.10.5;transport=udp", response="ed7169e75d7d15e914435b3f1bf9020b", algorithm=MD5
    Authentication Scheme: Digest
    Username: "813"
    Realm: "3CXPhoneSystem"
    Nonce Value: "414d535c0f2d250700:7d40c25ead254096aa99b546600487e1"
    Authentication URI: "sip:2145161704@10.180.10.5;transport=udp"
    Digest Authentication Response: "ed7169e75d7d15e914435b3f1bf9020b"
    Algorithm: MD5
    Content-Type: application/sdp
    Content-Length: 322
     
  2. ALANB

    Joined:
    May 15, 2017
    Messages:
    24
    Likes Received:
    2
    Hi dz,

    I am just putting it out there as it is the first thing to check. Have you created an outbound rule?

    Cheers
    Alan
     
  3. dz2017

    Joined:
    May 17, 2017
    Messages:
    3
    Likes Received:
    0
    Thanks for the reply Alan. That's a good question and it was one of the first things I checked and re-checked. I went as far as removing all rules for faxes and left only one single default outbound.
    Rule Name = Default Outbound
    Apply this rule to these calls:
    Calls to number starting with prefix = blank
    Calls from extensions = blank
    Calls to numbers with length of = 10,11
    Calls from groups = not configured
    Make outbound calls on:
    Route, 1 , Flowroute, strip digits 0, prepend = "flowroute prefix + asterisk" (example: 123456*)
     
  4. leejor

    leejor Well-Known Member

    Joined:
    Jan 22, 2008
    Messages:
    10,732
    Likes Received:
    277
    I don't see the call taking any outbound rule in the logs provided.
    Try creating a second rule, just as a test, but be more specific as to the first digit, or areacode.

    Calls to number starting with prefix = 2
    Calls from extensions = blank
    Calls to numbers with length of = 10
    Calls from groups = not configured
    Make outbound calls on:
    Route, 1 , Flowroute, strip digits 0, prepend = 123456*

    Put it ahead of the other rule and try a call to that 214 number, see if that works.

    It is unclear in your log where the 404 message is coming from, is there part of the log that confirms it is coming from your provider? If so, are you sending the correct digits when that prefix is attached?
     
  5. dz2017

    Joined:
    May 17, 2017
    Messages:
    3
    Likes Received:
    0
    leejor,
    Thank you for the suggestions. The 404 was coming directly from the PBX. As it turns out it was my outbound routes. I had to create two separate outbound rules; one specifying a 10 digit length with *1 after the prepend and another specifying an 11 digit length with just numerical prepend.

    Thanks again!
     
Thread Status:
Not open for further replies.