Cannot Make Outbound or Softphone -> Softphone Calls

Discussion in '3CX Phone System - General' started by olivermsubadra, Feb 18, 2016.

Thread Status:
Not open for further replies.
  1. olivermsubadra

    Joined:
    Feb 18, 2016
    Messages:
    33
    Likes Received:
    0
    I'm able to make incoming calls from an 'ordinary' phone to a registered softphone. However, every time I try to make calls between softphones (e.g., ext 101 -> ext 102), or make any outbound calls from a softphone, I'm presented with the 'incoming call rejected' error in the log:

    Code:
     18-Feb-2016 18:48:20.104   [CM502001]: Source info: From: "101"<sip:101@domain.com>;tag=vgfpgybq; To: "[Outbound number or softphone ext]"<sip:[Outbound number or softphone ext]@domain.com>
    18-Feb-2016 18:48:20.104   [CM503013]: Call(C:6): Incoming call rejected, caller is unknown; msg=Invite-IN Recv Req INVITE from 127.0.0.1:20002 tid=e5155d70-982c-4512-9204-3dc5102c4323 Call-ID=gmdnnydgkebnhtrsjtxomgllicaoniaowamdydiqshwnqvhkee:
    INVITE sip:[Outbound number or softphone ext]@domain.com SIP/2.0
    Via: SIP/2.0/UDP 127.0.0.1:20002;branch=z9hG4bKe5155d70-982c-4512-9204-3dc5102c4323;rport=20002
    Max-Forwards: 70
    Contact: <sip:101@127.0.0.1:20002>
    To: [Outbound number or softphone ext]<sip:[Outbound number or softphone ext]@domain.com>
    From: "101"<sip:101@domain.com>;tag=vgfpgybq
    Call-ID: gmdnnydgkebnhtrsjtxomgllicaoniaowamdydiqshwnqvhkee
    CSeq: 2 INVITE
    Content-Type: application/sdp
    Proxy-Authorization: Digest username="101",realm="3CXPhoneSystem",nonce="414d535c0cd6a2f305:c728c93c4d60f5b88ad694e2f70110d0",response="6dbe155a875f833fb15ccdc2e9de74d4",uri="sip:[Outbound number or softphone ext]@domain.com",algorithm=MD5
    User-Agent: Ozeki VoIP SIP SDK v1.2.0
    Content-Length: 364
    I'm not entirely sure what I've missed. With regards to outbound calls, it doesn't look as though the outbound rule below is even being triggered when I call an outbound (0###) number:

    Code:
    Calls to numbers starting with prefix: 0
    Route: sipgate (no stripped digits)
    Any help would be appreciated.

    [Edit: I'm clearly doing something very wrong here. When incoming calls are made, they're always directed to ext 100, the default 'operator'. They never go to the extension that the DID is directed to in the incoming rule. This might be an entirely separate problem, but it might be linked.]
     
  2. leejor

    leejor Well-Known Member

    Joined:
    Jan 22, 2008
    Messages:
    10,781
    Likes Received:
    286
    Did you put the SIP Domain Name "into" the settings in 3CX? If you are using remote extensions that are sending to a Domain Name, and you haven't "told" the PBX that you will be using that, then the calls will be rejected. You should find that replacing the Domain name , in the extension, with the PBXs public IP should work, if that is actually the issue.

    See... http://www.3cx.com/blog/docs/fqdn-ip-phone/
     
  3. olivermsubadra

    Joined:
    Feb 18, 2016
    Messages:
    33
    Likes Received:
    0
    @leejor Thank you. I had the SIP registry name (sipconnect.sipgate.co.uk) in my 'Local SIP Domain' field instead of my PBX's domain name. I didn't realise that the FDQN and the SIP domain had to match up -- I just saw 'SIP' and made the assumption that was what it meant. Outbound/softphone calls now work.
     
Thread Status:
Not open for further replies.