Cannot Park/Pickup Call

Discussion in '3CX Phone System - General' started by SBCTEC, Dec 5, 2009.

Thread Status:
Not open for further replies.
  1. SBCTEC

    Joined:
    Oct 10, 2009
    Messages:
    7
    Likes Received:
    0
    I have looked in the manual and followed all instructions. When I'm on a call, I hit the transfer button and type in *01, and I receive a response that , "Call forbidden by Administrator." I have purchased a license for 3CX and I am not using the free one, as most of the other features that come with the pay for version are working fine. I have Aastra 6753i phones, and attempted to use the park/pickup options on the programmable keys, and I get no response either. I getting frustrated because I know when I figure this out it's going to be blantantly obvious. I don't know what else to try. I can transfer to extensions, but just can't park a call.
     
  2. KerryG

    KerryG Active Member

    Joined:
    Jun 19, 2009
    Messages:
    960
    Likes Received:
    0
    First off, try the 3CX Assistant to make sure parking is actually working properly.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. archie

    archie Well-Known Member
    3CX Support

    Joined:
    Aug 18, 2006
    Messages:
    1,299
    Likes Received:
    0
    I can add only one suggestion: look into Server logs. Sometimes it helps.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  4. SBCTEC

    Joined:
    Oct 10, 2009
    Messages:
    7
    Likes Received:
    0
    I have confirmed the parking and unparking work with the assistant and the 3cxphone. Seems to have something to do with the phone itself. There are programmable keys that allow me to assign one for parking and one for unparking, but I haven't been able to get those to work either. Still at a stand still.
     
  5. KerryG

    KerryG Active Member

    Joined:
    Jun 19, 2009
    Messages:
    960
    Likes Received:
    0
    I am seeing some strange behavior as well. On a Cisco SPA525 phone, if I use the Transfer key and dial *01 I get a Forbidden as well showing here:

    Code:
    12:29:27.737  [CM503003]: Call(95): Call to sip:*01@sip.domain.com:5060 has failed; Cause: 403 Forbidden; from IP:127.0.0.1:40000
    12:29:27.737  [CM505001]: Ext.*0: Device info: Device Identified: [Man: 3CX Ltd.;Mod: Parking orbit;Rev: General] Capabilities:[reinvite, replaces, able-no-sdp, recvonly] UserAgent: [3CX Parking Orbit] PBX contact: [sip:*0@127.0.0.1:5060]
    12:29:27.737  [CM503002]: Call(95): Alerting sip:*0@127.0.0.1:40000;rinstance=8f8bc780fde26f60
    12:29:27.580  [CM503025]: Call(95): Calling Ext:Ext.*0@[Dev:sip:*0@127.0.0.1:40000;rinstance=8f8bc780fde26f60]
    12:29:27.580  [MS210004] C:95.2:Offer provided. Connection(proxy mode): 127.0.0.1:7380(7381)
    12:29:27.549  [CM503004]: Call(95): Route 1: Ext:Ext.*0@[Dev:sip:*0@127.0.0.1:40000;rinstance=8f8bc780fde26f60]
    12:29:27.549  [CM503010]: Making route(s) to <sip:*01@192.168.5.8>
    Notice that the returned error is *01@sip.domain.com - I have no clue where sip.domain.com is coming from.

    However, if I use the D-Pad and go right, and select BlindXfr, and dial *01 as before, the call is parked as shown here:
    Code:
    12:30:38.721  [MS210005] C:97.3:Answer provided. Connection(proxy mode):127.0.0.1:7388(7389)
    12:30:38.721  [MS210001] C:97.2:Answer received. RTP connection[unsecure]: 192.168.5.75:40014(40015)
    12:30:38.721  Remote SDP is set for legC:97.2
    12:30:38.533  [CM503007]: Call(97): Device joined: sip:*0@127.0.0.1:40000;rinstance=8f8bc780fde26f60
    12:30:38.533  [MS210004] C:97.2:Offer provided. Connection(proxy mode): 192.168.5.8:7386(7387)
    12:30:38.518  [MS210000] C:97.3:Offer received. RTP connection: 127.0.0.1:40028(40029)
    12:30:38.518  Remote SDP is set for legC:97.3
    12:30:38.518  [CM505001]: Ext.*0: Device info: Device Identified: [Man: 3CX Ltd.;Mod: Parking orbit;Rev: General] Capabilities:[reinvite, replaces, able-no-sdp, recvonly] UserAgent: [3CX Parking Orbit] PBX contact: [sip:*0@127.0.0.1:5060]
    12:30:38.518  [CM503002]: Call(97): Alerting sip:*0@127.0.0.1:40000;rinstance=8f8bc780fde26f60
    12:30:38.346  [CM503025]: Call(97): Calling Ext:Ext.*0@[Dev:sip:*0@127.0.0.1:40000;rinstance=8f8bc780fde26f60]
    12:30:38.299  [CM503004]: Call(97): Route 1: Ext:Ext.*0@[Dev:sip:*0@127.0.0.1:40000;rinstance=8f8bc780fde26f60]
    12:30:38.299  [CM503010]: Making route(s) to <sip:*01@192.168.5.8>
    12:30:38.283  Refer: from="200"<sip:200@192.168.5.8>;tag=297933d58d6becd0o0; to=<sip:300@192.168.5.8>;tag=2121a357; RefTo=<sip:*01@192.168.5.8>
    I am not sure what the difference is, it should work either way as far as I am concerned.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  6. KerryG

    KerryG Active Member

    Joined:
    Jun 19, 2009
    Messages:
    960
    Likes Received:
    0
    I changed the value of sp domain in the advanced settings and that didn't fix it

    Code:
    12:38:48.424  [CM503016]: Call(99): Attempt to reach <sip:*01@192.168.5.8> failed. Reason: Forbidden
    12:38:48.424  [CM503003]: Call(99): Call to sip:*01@192.168.5.8:5060 has failed; Cause: 403 Forbidden; from IP:127.0.0.1:40000
    12:38:48.408  [CM505001]: Ext.*0: Device info: Device Identified: [Man: 3CX Ltd.;Mod: Parking orbit;Rev: General] Capabilities:[reinvite, replaces, able-no-sdp, recvonly] UserAgent: [3CX Parking Orbit] PBX contact: [sip:*0@127.0.0.1:5060]
    
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  7. leejor

    leejor Well-Known Member

    Joined:
    Jan 22, 2008
    Messages:
    10,767
    Likes Received:
    286
    In the logs I keep seeing "*0" and not *01", is the dialplan in the SPA set to allow * codes with more than 1 digit to be sent out? I might be way off on this....

    Never mind, went back and looked again, more closely, at the last post of the logs, and see the "*01"
     
  8. SBCTEC

    Joined:
    Oct 10, 2009
    Messages:
    7
    Likes Received:
    0
    KerryG,

    The Aastra 6753i has a key for Park and Unpark, but as I said before, they don't function as expected. I took your advice and highlighted the BLF/Txfr and set the value for *00 (for my Park Key) and *01 (for my unpark key). That seemed to do the trick.

    I know this may be asking a lot, but if anyone else reads this article and knows of a way to show the light as red if a call is parked, that would be excellent.
     
  9. KerryG

    KerryG Active Member

    Joined:
    Jun 19, 2009
    Messages:
    960
    Likes Received:
    0
    Currently 3CX does not allow you to subscribe to a parking lot, at least not that I have found.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Thread Status:
Not open for further replies.