Dismiss Notice
We would like to remind you that we’re updating our login process for all 3CX forums whereby you will be able to login with the same credentials you use for the Partner or Customer Portal. Click here to read more.

Cannot pick up

Discussion in 'Windows' started by fraser, May 10, 2010.

Thread Status:
Not open for further replies.
  1. fraser

    Joined:
    May 10, 2010
    Messages:
    2
    Likes Received:
    0
    I have installed and configured the 3CX soft phone and all appears to be working, I can make outbound calls successfully.

    I cannot however pick up incoming calls, the soft phone rings and I click the green answer button but the call keeps ringing, I've tried pressing enter on the keyboard but I just can't answer.

    Any ideas?

    Fraser
     
  2. fraser

    Joined:
    May 10, 2010
    Messages:
    2
    Likes Received:
    0
    The fault seems to be to do with the outgoing proxy when the outgoing proxy is ticked the phone will ring but I cannot answer. I need to keep the outgoing proxy alive otherwise my SIP account closes.
     
  3. gpsjeff717

    Joined:
    Jun 5, 2008
    Messages:
    31
    Likes Received:
    0
    Are you using the 3CXPhone as standalone directly connected with a VoIP service, like I do?

    I use one Voip service that requires "Use Outbound Proxy Server" to be checked and proxy entered.
    And, I use another Voip service that does not use the Proxy Server setting.

    Check your Voip provider support pages and confirm what they recommend for their service. If they don't indicate use outbound proxy, then it shouldn't be required. But, if they do, then it is required setting.

    Make sure your network isn't blocking SIP or RTP ports required by your voip service provider.

    Are you using the 3CX STUN server setting (stun.3cx.com) to help with Nat-Router traversal? If so, you may need to check that port 3478 is also forwarded or triggered to also pass through your firewall...
     
  4. RickMeasham

    Joined:
    May 21, 2010
    Messages:
    1
    Likes Received:
    0
    I'm having exactly the same problem.

    I've set my firewall to forward every port mentioned in the Advanced setup through to my laptop, and have now added the aforementioned port for STUN. But I still get exactly the same behaviour.

    The phone will continue to "ring" after I've clicked to answer and I can't hang up. I have to wait for a timeout.

    Any other ideas? Which ports should I be having the firewall pass through to me? It's fairly rare to need to do anything like that these days, but maybe I'm missing something.
     
  5. gpsjeff717

    Joined:
    Jun 5, 2008
    Messages:
    31
    Likes Received:
    0
    First, double check with your VoIP service provider support pages and confirm your SIP registration required settings, including whether it needs support for outbound proxy server, which SIP ports, and which RTP ports range, as well as codecs supported.
    Make sure you have accounted for these settings in your 3CXPhone Connections Settings as well as the Advanced tab settings.

    I've got my Advanced settings set for SIP port 5060 and RTP port range 16384 - 16482. I have my Router set to "Trigger" on these ports and ranges. I'm set for using PCMU codec.

    Is the 3CXPhone the only SIP device registered to your VoIP account?
    If you have more than one SIP device registered to the same SIP account (or sub-account), it is possible there will exist conflicts between the devices and unpredictable operation may result. I've seen that happen in the past myself.
     
Thread Status:
Not open for further replies.