Cannot register Android app over 3g to public 3cx box

Discussion in 'Android' started by pauladams, Jul 27, 2010.

Thread Status:
Not open for further replies.
  1. pauladams

    Jul 25, 2010
    Likes Received:
    Cross posted in the 3cx forum

    I have the following setup:

    3cx box with a private IP (172.16.x.x).

    A pix firewall with a public static IP (I have the "public ip address" set in global options)

    I have the public IP Natted to the private IP and I am allowing udp 5060 from my host on the internet. If I run ethereal on the 3cx box, I see the request come in, as well as in the 3cx logs.

    I have my droid with the 3cx app installed. When I am on wifi (internal work network) it is able to register perfectly and I can make calls, etc.

    When I am on 3g, using the same credentials, I get Authentication failed. I look in the server logs and I get this:

    13:07:44.464 [CM102001]: Authentication failed for SipReq: REGISTER tid=PjCXpnl1x.6zOXtyFNDGmW7VUQbCY23BnE cseq=REGISTER contact=170@ / 1478 from(wire); Reason: Credentials don't match, check that authorization-ID and password match the ones in extension settings

    The weird thing is that they DO match. I have fiddled with 3cx app for ever now and I still can't get it to work. I am rolling out a solution soon and evaluating 3cx but if I cant get users with public IPs to connect over the internet then this solution is worthless to me.

    Is this a bug, or am I missing something? I have been back and forth through the documentation on this and I can't get past it.

  2. LeonidasG

    LeonidasG Support Team
    Staff Member 3CX Support

    Nov 19, 2008
    Likes Received:
    It would be best if you did a wireshark capture of both scenarios, one with WiFi enabled and one with 3G Enabled and send the captures to

    But before doing that please try using a very weak password in that extension's settings. Try a password like 170 and see what happens.

    Can you also confirm that in your PIX firewall you have SIP Helping services disabled? There's usually a setting somewhere in the router related to SIP that you would need to disable.
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Thread Status:
Not open for further replies.