Cannot register with VOIP provider (broadvoice)

Discussion in '3CX Phone System - General' started by bt_consulting, Jan 17, 2007.

  1. bt_consulting

    Joined:
    Jan 16, 2007
    Messages:
    1
    Likes Received:
    0
    I am attempting to register 3cx with broadvoice, and am unable to do so. I set everything up exactly as the documentation explained. I can connect from the same machine using Xten X-Lite so I know it isn't a firewall / connectivity issue. No software firewall is installed on this machine (windows, norton, etc.)

    Steps i've taken:
    I set up one extension (100)
    I added a voip provider:
    proxy: proxy.nyc.broadvoice.com
    port: 5060
    registrar: sip.broadvoice.com
    port: 5060
    i tried no stunserver and port, and i've tried stunserver.org : 3478. No results.

    LineNumber and password is correct, per the broadvoice portal (Accounts -> My Devices -> Settings).

    I've run ethereal on the box, and changed a 3cx Voip Provider setting to force reregistration, but i don't see any UDP traffic (with the exception of some microsoft networking packets). Also, my perimeter firewall is not showing any UDP traffic in it's logs. The Server Status log shows only the following entry:

    17:52:37.464 LineImpl::update: Line: register line 4047956110

    and nothing else. I'm pasting the complete log entries below.

    Please let me know if i can provide any other information to debug this issue. Based upon the ethereal results, it appears that 3cx is not actually attempting to register with broadvoice.

    Server: windows 2003 & windows xp (tried on multiple machines).

    Thanks.


    14:15:13.589 LineImpl::update: Line: register line 4047956110
    14:14:58.693 ??: SL: connected mobile1:0/PHPExtension_0 at [mobile1]/PHPExtension_0
    14:14:45.293 SessionMgr::thread: ** Entering Main Loop **
    14:14:45.293 SessionMgr::run: ** Start Session Manager **
    14:14:45.293 SessionMgr::run: ** Initialize Status Monitor **
    14:14:45.293 LineImpl::update: Line: register line 4047956110
    14:14:45.072 DBA: ** Database connection Ok **
    14:14:45.062 SessionMgr::run: ** Initialize Lines Manager **
    14:14:45.062 SessionMgr::run: STUN resolved external IP: 216.157.232.26
    14:14:44.911 MediaServerConnected: Media Server is connected
    14:14:44.911 ??: SL: connected mobile1:0/MediaServer at [mobile1]/MediaServer
    14:14:44.791 SessionMgr::run: ** Initialize Client Authentication **
    14:14:44.791 SessionMgr::run: ** Initialize Server Authentication **
    14:14:44.791 SessionMgr::run: ** Initialize DUM **
    14:14:43.716 SessionMgr::run: ** Adding transports **
    14:14:43.716 SessionMgr::run: Version: 2.0.913.0
     
  2. watts

    Joined:
    Jan 15, 2007
    Messages:
    2
    Likes Received:
    0
    Same problem here. I get a Registration Failure error. What is odd is if I connect my IP phone directly to Broadvoice, it works. Same settings on 3cx and it does not connect. Firewall is way open. In fact i took it off to try this out. Any ideas????
     
  3. Nick Galea

    Nick Galea Site Admin

    Joined:
    Jun 6, 2006
    Messages:
    1,720
    Likes Received:
    41
    We have tested it with Broadvoice and we did not have issues. However, since we are releasing a new build next week, with vastly improved VOIP provider capabilities and better troubleshooting, i would ask if you could wait for this version. Right now we are focusing on this new release.
     

Share This Page