Cannot utilize outside auto attendant - can't press 1

Discussion in '3CX Phone System - General' started by SBCTEC, Nov 30, 2009.

Thread Status:
Not open for further replies.
  1. SBCTEC

    Joined:
    Oct 10, 2009
    Messages:
    7
    Likes Received:
    0
    I don't know if I'm explaining this correctly, and I'm sure it's just a setting that has been overlooked, but here is my problem. I have a grandstream gateway with aastra 6753i phones running latest of 3CX. When I call a user that has an auto attendant, I hear the button press on my handset, but their auto attendant doesn't register the tone. Where do I look and what do I have to do to configure the system to properly register these tones? Thank you in advance.
     
  2. leejor

    leejor Well-Known Member

    Joined:
    Jan 22, 2008
    Messages:
    10,375
    Likes Received:
    231
    DTMF tones can be passed on (in VoIP) in a number of ways. There are generally settings in both the sets (ATAs) and the gateways as to how they will be sent. Sometimes it is enough to send the audio tone that you hear when you press the key. Unfortunately, due either to a low level, short duration or distortion due to dropped packets, this doesn't always work. In this case you can (generally) set it so that the ATA will recognise the DTMF tone then generate a SIP message that the gateway will recognise (again with the correct settings) and then re-generate the tone(s). This may require some trial and error to get the settings right. If this is going out over an analogue gateway, as i suspect, you may want to monitor (listen) on the PSTN phone line to see just what you are actually sending out on the phone line, low level or no tone at all?

    Do you have the same sort of problem when calling something else (different phone number) that responds to DTMF?
     
  3. LeonidasG

    LeonidasG Support Team
    Staff Member 3CX Support

    Joined:
    Nov 19, 2008
    Messages:
    1,406
    Likes Received:
    81
    If you have a Grandstream Gateway and a 53I Aastra, you can try going in the Line Settings for the Aastra and changing the DTMF Method to something that will work for you.

    Generally setting the DTMF to: BOTH is ok, but you can try the other settings if you are having trouble.


    If the above doesnt work, check your Gateway Settings for anything that has to do with DTMF Tones.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  4. SBCTEC

    Joined:
    Oct 10, 2009
    Messages:
    7
    Likes Received:
    0
    Thanks for the help. I'm going to attempt all suggestions and I'll post back my results.
     
  5. SBCTEC

    Joined:
    Oct 10, 2009
    Messages:
    7
    Likes Received:
    0
    When I enter the administrative interface of the Aastra 6753i, under Basic Settings -> Preferences there are two options (Suppress DTMF Playback and Display DTMF Digits). DDD displays the number on the phone when I press them, I hear them in the handset, but it doesn't register on the other party's phone system. SDP does nothing. I've found no other option in the phone interface that deals with DTMF. There are a lot of options to configure the Grandstream Gateway GXW4104, but none of them specifically reference DTMF while in a call and I don't want to mess with settings that apparantly work with everything else without knowing exactly what they do. They deal with frequencies and other technicalities that I'm not familar with. I'm open for other suggestions.
     
  6. leejor

    leejor Well-Known Member

    Joined:
    Jan 22, 2008
    Messages:
    10,375
    Likes Received:
    231
    Did you monitor the PSTN line(s) coming from the gateway to see if any DTMF tones are being passed through? It might be that they are being generated but the far end requires a longer duration tone, as someone discovered when using a Panasonic cordless phone a while back. Have you tried placing a call to something else that requires DTMF tones? I'm afraid that I don't use either of the devices you have, so I can't be of any help with device specific settings, but perhaps someone else on the forum does use them.

    Did a quick search...in the 4104 there is a setting called "DTMF Methods", which gives you choices of In Audio, RCF2833 and SIP Info. These are probably the setting to want to look at changing. BUT, before you do, check to see if the DTMF tones are going out as the unit stands.
     
  7. SBCTEC

    Joined:
    Oct 10, 2009
    Messages:
    7
    Likes Received:
    0
    leejor,

    Thanks for a help. In the Channels section of the gateway is an option for DTMF methods. It was initially set to 1: audio. I hooked up a buttset to the line and heard no tones when pressing the buttons. I changed the setting to 2: RFC2833, and heard the tones. There's a slight delay, that could be my loca networking, but the initial problem is solved. Thanks again.
     
  8. leejor

    leejor Well-Known Member

    Joined:
    Jan 22, 2008
    Messages:
    10,375
    Likes Received:
    231
    I'm sure that the delay is just the fact that the gateway has to receive a SIP message each time a key is pressed on the set and then generate the tone, so, of course, it won't be as immediate as a tone being generated directly by the keypad. And that message might be relayed though 3CX.
     
Thread Status:
Not open for further replies.