Can't call just get fast busy

Discussion in '3CX Phone System - General' started by richs, Nov 26, 2012.

Thread Status:
Not open for further replies.
  1. richs

    Joined:
    Nov 26, 2012
    Messages:
    9
    Likes Received:
    0
    I am trying out 3CX with the trial (free) version. I have bought two phones, Polycom 331's and am running 3CX on a small dedicated computer running Windows 7 Pro. I have a fixed IP address from my cable provider and have purchased two SIP trunks from Nextiva. Nextiva informed me that they use port 5062 so I changed the standard 5060 to that everywhere it shows up in the system.

    I have forwarded port 5090 (TCP), ports 5060-5062 (TCP+UDP) and ports 9000-9049 (UDP) to the 3cx server, which has a fixed local IP address of 192.168.1.98.

    I have configured the 331 phones with fixed local IPs of 192.168.1.100 (for extension 100) and 192.168.1.102 (for extension 102). There is no extension 101 (yet).
    I have set up the phones manually via their web interface.

    My problem is that I can receive calls from an outside number just fine, but any attempt to call a number from either extension, whether to an ouside number or the other extension, just results in a fast busy.

    I have configured a single outbound rule as follows:
    Rule Name: Leading 9
    Calls to Numbers starting with (Prefix) : 9
    Calls from extension(s): blank
    Calls to Numbers with a length of: blank
    Calls from extension group: blank
    Route 1: Nextiva Strip Digits: 1 Prepend: blank
    Routes 2 and 3 are blank (that is, set up as block calls).

    LOG RESULTS

    Every so often there is the following entry in the log:

    11:24:32.676 [CM506001]: STUN request to resolve SIP external IP:port mapping is sent to STUN server [ V4 199.192.206.228:3478 UDP target domain=unspecified mFlowKey=0 ] over Transport [ V4 192.168.1.98:5062 UDP target domain=unspecified mFlowKey=0 ]

    Very frequently I get the following log entries:

    11:24:30.155 [CM302001]: Authorization system can not identify source of: SipReq: SUBSCRIBE 100@192.168.1.98 tid=2b3a20c41A6E4EA9 cseq=SUBSCRIBE contact=100@192.168.1.100:5062 / 1 from(wire)
    11:24:25.257 [CM302001]: Authorization system can not identify source of: SipReq: SUBSCRIBE 102@192.168.1.98 tid=43519c00A02D9B51 cseq=SUBSCRIBE contact=102@192.168.1.102:5062 / 1 from(wire)

    When I attempt do dial from extension 100 to extension 102 I get the following log entries:


    11:26:46.097 [CM502001]: Source info: From: "100"<sip:100@192.168.1.98>;tag=A6E5E0A0-D0B11D35<sip:102@192.168.1.98;user=phone>
    11:26:46.097 [CM503013]: Call(30): Incoming call rejected, caller is unknown; msg=SipReq: INVITE 102@192.168.1.98 tid=bbefbdf72337E5B8 cseq=INVITE contact=100@192.168.1.100:5062 / 2 from(wire)
    11:26:45.679 [CM500002]: Unidentified incoming call. Review INVITE and adjust source identification:
    INVITE sip:102@192.168.1.98;user=phone;transport=tcp SIP/2.0
    Via: SIP/2.0/TCP 192.168.1.100:5062;branch=z9hG4bKd492308e590FB47B
    Max-Forwards: 70
    Contact: <sip:100@192.168.1.100:5062;transport=tcp>
    To: <sip:102@192.168.1.98;user=phone>
    From: "100"<sip:100@192.168.1.98>;tag=A6E5E0A0-D0B11D35
    Call-ID: dd8b490c-b4177991-a8d0a59a@192.168.1.100
    CSeq: 1 INVITE
    Accept-Language: en
    Allow: INVITE, ACK, BYE, CANCEL, OPTIONS, INFO, MESSAGE, SUBSCRIBE, NOTIFY, PRACK, UPDATE, REFER
    Supported: 100rel, replaces
    User-Agent: PolycomSoundPointIP-SPIP_331-UA/4.0.3.7562
    Allow-Events: conference, talk, hold
    Content-Length: 0

    When I attempt to dial an outside number such as my cell phone I get the following log entries (last four digits of the number have been changed to 'nnnn'):

    11:28:39.324 [CM502001]: Source info: From: "100"<sip:100@192.168.1.98>;tag=D1FFFFC5-8ED3C05E<sip:91970443nnnn@192.168.1.98;user=phone>
    11:28:39.324 [CM503013]: Call(31): Incoming call rejected, caller is unknown; msg=SipReq: INVITE 91970443nnnn@192.168.1.98 tid=395847f2BCC5962F cseq=INVITE contact=100@192.168.1.100:5062 / 2 from(wire)
    11:28:38.892 [CM500002]: Unidentified incoming call. Review INVITE and adjust source identification:
    INVITE sip:91970443nnnn@192.168.1.98;user=phone;transport=tcp SIP/2.0
    Via: SIP/2.0/TCP 192.168.1.100:5062;branch=z9hG4bK734f0ead9CE0BA66
    Max-Forwards: 70
    Contact: <sip:100@192.168.1.100:5062;transport=tcp>
    To: <sip:91970443nnnn@192.168.1.98;user=phone>
    From: "100"<sip:100@192.168.1.98>;tag=D1FFFFC5-8ED3C05E
    Call-ID: 3e943a33-9a8a2424-3e1cf189@192.168.1.100
    CSeq: 1 INVITE
    Accept-Language: en
    Allow: INVITE, ACK, BYE, CANCEL, OPTIONS, INFO, MESSAGE, SUBSCRIBE, NOTIFY, PRACK, UPDATE, REFER
    Supported: 100rel, replaces
    User-Agent: PolycomSoundPointIP-SPIP_331-UA/4.0.3.7562
    Allow-Events: conference, talk, hold
    Content-Length: 0

    I have searched the forum entries as best I could before posting, but I either found postings that had the same or a similar symptom but a different source problem, or else the suggested solution was one I'd already tried or implemented at first.

    Any help would be greatly appreciated. I've spend quite a few hours on this and am a bit tired of hearing that fast busy!
     
  2. richs

    Joined:
    Nov 26, 2012
    Messages:
    9
    Likes Received:
    0
    I should have also said that the firewall checker says all is OK.
     
  3. leejor

    leejor Well-Known Member

    Joined:
    Jan 22, 2008
    Messages:
    10,752
    Likes Received:
    285
    You only need to change the outgoing port, on the trunk to Nextiva, to 5062. That is the port number that they wish to receive SIP messages. All others can stay at the default (usually 5060)

    This line is the issue. I'm not sure how you have the sets, or 3CX set-up (network/SIP settings), but the INVITE message, that 3CX gets, indicates that is preventing calls from proceeding. I looks like something is not correct.

    .

    3CX is rejecting them.
     
  4. richs

    Joined:
    Nov 26, 2012
    Messages:
    9
    Likes Received:
    0
    Regarding the ports, I changed the entries under VOIP Provider, General Tab, SIP Server Port and Outbound Proxy Port. I also changed the entry under Settings/Network/Ports/SIP Port.

    Because the problem extends even to extension-extension calls, I am virtually certain that the problem is in the Polycom setup, but I cannot see anything that I did which would cause the problem. The phone setup asks for a SIP server address [192.168.1.98] and port [5062], as well as a SIP Outbound Proxy address [192.168.1.98] and port [5062]. It also asks for SIP Line Identification:
    Display Name: [100]
    Address: [100@192.168.1.98]
    Authentication ID: [100]
    Authentication Password: [p/w string - matches that in 3CX]
    Label: [ASCII string with user location]

    I set up the Provisioning Server as follows:
    Server Type {HTTP}
    Server Address: [192.168.1.98:5000/provisioning/]
    Server User: [100]
    Server Password: [p/w string - matches that in 3CX]
    File Transmit Tries: [3]
    Retry Wait : [1]
    Tag SN to UA: [Disable]
    DHCP Menu
    Boot Server: [static]
    Boot Server Option: [160]
    Boot Server Type: [String]
    Option 60 Format: [ASCII String]

    Under the phone's SIP page, I set things up as follows:
    Local SIP Port: [5062]
    Calls per Line Key: [2]
    New SDP TYpe: [Disable]
    Live Communication Server Support: [disable]
    Non Standard Line Seize: [enable]
    Digit Map: [blank]
    Digit Map Timeout [blank]
    Remove End of Dial Marker [enable]
    Digit map Impossible Match [2]

    Outbound Proxy Address: [192.168.1.98]
    Outbound Proxy Port: [5062]
    Transport [TCP preferred]

    Server 1 Address: [192.168.1.98]
    Server 1 Port: [5062]
    Server 1 Transport: [TCP preferred]
    Server 1 Expire(s): [3600]
    Server 1 Register [yes]
    Server 1 Retry Timeout: [0]
    Server 1 Retry Maximum Count: [3]
    Server 1 Line Sieze Timeout: [30]

    FInally, under "Line 1" I set the entries to:
    Identification:
    Display Name: [100]
    Address: [100@192.168.1.98]
    Authentication ID: [100}
    Authentication Password: [p/w string - matches that in 3CX]
    Label: [ASCII string with user location]
    Type: [private]
    Third Party Name: [blank]
    Number of Line Keys: [1]
    Calls per Line: [2]
    Ring Type: [Low Trill]
    Outbound Proxy:
    Address: [192.168.1.98]
    Port: [5062]
    Transport: [TCP preferred]
    Server 1:
    Address: [192.168.1.98]
    Port: [5062]
    Transport: [TCPpreferred]
    Expires: [900]
    Register: [yes]
    Retry Timeout: [0]
    Retry Maximum Count: [3]
    Line Seize Timeout: [30}

    I made no entries under Server 2 or any under Line 2.
    There are entries under "Preferences" (i.e., Time and Date, etc.) but I can't see they would make any difference.

    Any suggestions you can make would be greatly appreciated.
     
  5. richs

    Joined:
    Nov 26, 2012
    Messages:
    9
    Likes Received:
    0
    Dear leejor,

    Based on your suggestion, I changed all of the phone's ports to 5060 and the Network/Ports/SIP port back to 5060 and all is working at last.

    Thank you SO much for your patient reading and help! I'm quite relieved at this point.

    Aloha from Maui, Hawaii

    Rich Scholl
     
  6. leejor

    leejor Well-Known Member

    Joined:
    Jan 22, 2008
    Messages:
    10,752
    Likes Received:
    285
    As I said earlier (based on what you quoted from your provider), you should only have to change the port you are sending to, in the 3CX trunk group. They will send back to what ever port 3CX specifies, normally 5060. It obviously was a setting, but you should be able to use port 5062 on all devices (except shared IP's), and it should all just work.

    Just got back from a few weeks over on Oahu. Will miss the warm weather but not the humidity (at times) , or the Vog.
     
  7. sigma1

    sigma1 Active Member

    Joined:
    Nov 20, 2009
    Messages:
    542
    Likes Received:
    1
    Also turn STUN off if you have a static IP address. Hardcode the public IP in there, it will help you ;-)
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Thread Status:
Not open for further replies.