Dismiss Notice
We would like to remind you that we’re updating our login process for all 3CX forums whereby you will be able to login with the same credentials you use for the Partner or Customer Portal. Click here to read more.

Can't get 3CXPhone 12.5 to register in CTI mode

Discussion in 'Windows' started by --mark--, Jun 19, 2015.

Thread Status:
Not open for further replies.
  1. --mark--

    Joined:
    Jun 3, 2011
    Messages:
    12
    Likes Received:
    0
    Problem:
    The 3CXphone software will not connect with the 3CX server in CTI mode.

    Configuration:
    Setup is vanilla v12.5 with license. System working fine with mixture of Yealink and Cisco handsets using SIP trunks.
    We have recently moved IP address range from 192.x.x.x to 10.x.x.x
    Server/Phones/Client computers all on same 10.x.x.x subnet
    Clients can ping and access shared files on 3CX machine using standard file sharing.
    Firewall is OFF on both server and clients (for testing).
    3CXPhone is 12.5.42341.0, Server is 12.5 with service pack 1.
    Client software has been configured using the Welcome Email file.
    Firewall checker in 3CX passes.
    In Network the internal IP is correctly set to 10.0.0.21, external IP is set to a FQDN that resolves to the correct external IP of our broadband feed.

    The client is trying to connect, if I deliberately make the passwork in 3cxphone wrong, then it errors with "Invalid Password" so must be able to talk to the server.

    In Custom Parameters I note that MYPHONEVERSION is 12.5.41543.0, this is different to the client version. I have tried changing this but as yet have been unable to restart the server services to see if it makes a difference.

    I note in 3CXPhone Clients in the web gui that my desktop phone extension tries to register multiple times. It displays the IP of the client software as 10.0.0.50 sometimes and others uses the External IP of our connection 82.x.y.z, same as configured in Settings>Network for the external public FQDN when resolved.

    After a while, the app throws the "3CX Phone System is unreachable. 3CXPhone will try to reconnect automatically. Please wait." error.

    I've noticed that two users with the older version of the software 12.5.415 *ARE* successfully using the software.

    I'd welcome any suggestions, I am unable to find the log in the client software, can anyone direct me?
     
  2. --mark--

    Joined:
    Jun 3, 2011
    Messages:
    12
    Likes Received:
    0
    I wonder if anyone can advise which ports the client communicates over to help me with troubleshooting?
     
  3. Tamnet83

    Joined:
    Jun 24, 2015
    Messages:
    1
    Likes Received:
    0
    Hi
    i have similar problem. . Did you find out away around it?
     
  4. --mark--

    Joined:
    Jun 3, 2011
    Messages:
    12
    Likes Received:
    0
    Sadly not, I'm somewhat resigned to waiting for v14 to be released to see if that resolves it.
     
  5. complex1

    complex1 Active Member

    Joined:
    Jan 25, 2010
    Messages:
    814
    Likes Received:
    49
    Mark,

    After changing the IP-address to 10.x.x.x and before sending the new welcome mail to the 3CXPhone did you regenerate the extension config files?
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  6. --mark--

    Joined:
    Jun 3, 2011
    Messages:
    12
    Likes Received:
    0
    :D PROBLEM SOLVED :D

    I took a look at the 3CXPhone provisioning file that is sent to the users mailbox to configure the client, the problem is in here.

    Near the end of the file:
    <MyPhoneServerLocalAddr>http://10.0.0.21:5000/MyPhone/MPWebService.asmx</MyPhoneServerLocalAddr>
    <MyPhoneServerPublicAddr>http://3cx.myfirmname.co.uk:5000/MyPhone/MPWebService.asmx</MyPhoneServerPublicAddr>
    <MyPhoneServerLocalSSLAddr>https://myfirmname.local:5001/MyPhone/MPWebService.asmx</MyPhoneServerLocalSSLAddr>
    <MyPhoneServerPublicSSLAddr>https://3cx.myfirmname.co.uk:5001/MyPhone/MPWebService.asmx</MyPhoneServerPublicSSLAddr>

    Note: 'myfirmname' isn't what is really there, it's my company name and matches my domain name etc. 3cx is the hostname of the server. 3cx.myfirmname.co.uk correctly resolves to my outside public IP.

    The bold line is the problem. The file has substituted the local IP with what it thinks is the server local hostname rather than using an IP address. The hostname (myfirmname.local) is actually the network name and not a host. If 3cx.myfirmname.local had been used it probably would have worked. I chose to simply substitute with the correct internal IP per the first line:
    <MyPhoneServerLocalSSLAddr>https://10.0.0.21:5001/MyPhone/MPWebService.asmx</MyPhoneServerLocalSSLAddr>


    Finally using this file to create the account in the 3CXPhone now works perfectly.

    Observations:
    Why does the generated file use an inconsistent way of referring to the internal server?
    Where does it pick up the 'myfirmname.local' reference, I can't find it within 3CX config? It would be great to solve this so I can correct the auto generated configuration files and let users install themselves.
    You can amend the phone server local address within 3CXPhone, you cannot amend the Local SSL address - so no quick fix option.
    I *think* this was a problem introduced by version 12.5 but clearly changing our IP address scheme may also have had some part in this.

    Frank - thanks for replying. I'm not sure how I'd go about regenerating the config files, however for my install the phones are configured manually and use static IPs, we don't have a suitable Option 66 DHCP server here. We primarily have older Cisco SPA handsets, these need the option 66 method, we use a very simple network without MS servers where possible, hard to find others DHCP servers that do it without diving into Linux boxes. More recent Yealink phones do configure nicely without needing this anyway, we are transitioning across.
     
  7. complex1

    complex1 Active Member

    Joined:
    Jan 25, 2010
    Messages:
    814
    Likes Received:
    49
    Hi Mark,

    This is because you have "tell" this 3CX during installation.
    The SSL data is stored in the registry, other data in the 3CX database. That’s why you can change the server local address but can’t change SSL data.
    Every time when you create an extension, 3CX collect this data and put it in the extension config file.

    To change the local and/or external FQDN/IP-addresses you need to do this steps (Win 8.1)
    Regedit – HKLM – Software – Wow6432Node – 3CX – PhoneSystem
    Here you can change the ExternalFqdn and/or InternalFqdn values as you whishes.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  8. Thomas 3CX

    3CX Support

    Joined:
    May 6, 2015
    Messages:
    15
    Likes Received:
    0
    Hello,

    As it was already mentioned, the MyPhoneServerPublicSSLAddr and MyPhoneServerLocalSSLAddr are generated during the installation of the 3CX Phone System (certificate). These entries cannot been changed by just modifying the configuration on the PBX. It can be changed via registry (also mentioned) but it is not recommended. The best way to update those values is to fully backup the PBX excluding the SSL certificate, uninstall the system, reinstall with the correct values and restore the backup.

    Thanks.
     
  9. --mark--

    Joined:
    Jun 3, 2011
    Messages:
    12
    Likes Received:
    0
    Dear Frank and Thomas,

    Thank you both for taking the time to reply and help my understanding. I've made the changes via registry for now, next install (v14) I'll follow instructions from Thomas and get back to standard.
     
  10. pjk

    pjk

    Joined:
    Apr 17, 2015
    Messages:
    9
    Likes Received:
    0
    Just for reference for anyone else with this issue look here in the registry HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\3CX\PhoneSystem
     
  11. craigreilly

    craigreilly Well-Known Member

    Joined:
    Feb 1, 2012
    Messages:
    3,575
    Likes Received:
    304
    pjk, same location as complex gave.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Thread Status:
Not open for further replies.