Solved Can't install Linux version on Linode KVM

Discussion in '3CX Phone System - General' started by minnesota, Jan 5, 2017.

Thread Status:
Not open for further replies.
  1. minnesota

    Joined:
    Nov 24, 2014
    Messages:
    43
    Likes Received:
    1
    Hey everyone,

    I am trying to install 3CX Linux on a Linode VPS using KVM. Everything goes fine until I select "Option 1" to configure it from web browser. You can scroll to the end of my SSH output and see an error exit status 139.

    Any ideas on what this might be? I currently have my 3CX installed at OVH and followed the same direction as that. It works at OVH but not on my Linode KVM. Definitely followed instructions exactly as in the guide. Debian 8 64-bit, etc.

    Any ideas on how to make this work? Thank you all







    Welcome to the 3CX Configuration Tool

    Help https://www.3cx.com


    Press ESC to go back.



    Select how to run the tool:

    (1) Using a Web Browser

    (2) From Command Line

    Enter option: 1


    Starting PbxWebConfigTool...Removed symlink /etc/systemd/system/3CXSystemService01.service.

    Removed symlink /etc/systemd/system/3CXCfgServ01.service.

    Removed symlink /etc/systemd/system/3CXEventNotificationManager.service.

    Removed symlink /etc/systemd/system/3CXMediaServer.service.

    Removed symlink /etc/systemd/system/3CXTunnel01.service.

    Removed symlink /etc/systemd/system/3CXIVR01.service.

    Removed symlink /etc/systemd/system/multi-user.target.wants/3CXSystemService01.service.

    Removed symlink /etc/systemd/system/multi-user.target.wants/3CXCfgServ01.service.

    Removed symlink /etc/systemd/system/multi-user.target.wants/3CXEventNotificationManager.service.

    Removed symlink /etc/systemd/system/multi-user.target.wants/3CXMediaServer.service.

    Removed symlink /etc/systemd/system/multi-user.target.wants/3CXTunnel01.service.

    Removed symlink /etc/systemd/system/multi-user.target.wants/3CXIVR01.service.

    Removed symlink /etc/systemd/system/multi-user.target.wants/3CXPhoneSystemMC01.service.

    Removed symlink /etc/systemd/system/multi-user.target.wants/3CXPhoneSystem01.service.

    Removed symlink /etc/systemd/system/multi-user.target.wants/3CXQueueManager01.service.

    Removed symlink /etc/systemd/system/3CXPhoneSystemMC01.service.

    Removed symlink /etc/systemd/system/3CXPhoneSystem01.service.

    Removed symlink /etc/systemd/system/3CXQueueManager01.service.

    active

    dpkg: error processing package 3cxpbx (--configure):

    subprocess installed post-installation script returned error exit status 139

    Processing triggers for libc-bin (2.19-18+deb8u6) ...

    Processing triggers for systemd (215-17+deb8u5) ...

    Errors were encountered while processing:

    3cxpbx

    E: Sub-process /usr/bin/dpkg returned an error code (1)

    root@debian:~#
     
  2. minnesota

    Joined:
    Nov 24, 2014
    Messages:
    43
    Likes Received:
    1
    Anyone able to help? How do I get this fixed? We really need to get this up and running on Linode as the performance at OVH is horrible for us.

    Thanks
     
  3. YiannisH_3CX

    YiannisH_3CX Support Team
    Staff Member 3CX Support

    Joined:
    May 10, 2016
    Messages:
    4,349
    Likes Received:
    274
    Hello @minnesota

    Please try the following and provide us with a feedback

    dpkg --configure -a
    apt-get remove 3cxpbx --purge
    apt-get update
    apt-get install 3cxpbx
     
  4. minnesota

    Joined:
    Nov 24, 2014
    Messages:
    43
    Likes Received:
    1

    Same results and error code. I've attached text file showing me following those commands and still having issues. Linode uses KVM so it should work properly, right?
     

    Attached Files:

  5. minnesota

    Joined:
    Nov 24, 2014
    Messages:
    43
    Likes Received:
    1
    I have attached screenshot of some options for this VPS. VM Mode is recommended to be in Paravirtualization mode instead of Full-Virtualization. Would I need to change this for 3CX to FULL?

    Also, is the latest 64-bit kernel the correct one to be on? It is the default for the Debian 8 version I selected.
     

    Attached Files:

  6. YiannisH_3CX

    YiannisH_3CX Support Team
    Staff Member 3CX Support

    Joined:
    May 10, 2016
    Messages:
    4,349
    Likes Received:
    274
  7. choicetg

    Joined:
    Apr 28, 2016
    Messages:
    1
    Likes Received:
    0
    Was this resolved? I am getting the same error trying to install on a Linode VPS running Debian 8.
     
  8. YiannisH_3CX

    YiannisH_3CX Support Team
    Staff Member 3CX Support

    Joined:
    May 10, 2016
    Messages:
    4,349
    Likes Received:
    274
  9. minnesota

    Joined:
    Nov 24, 2014
    Messages:
    43
    Likes Received:
    1
    https://www.linode.com/docs/tools-r...s/run-a-distribution-supplied-kernel-with-kvm

    Correct. We did get it working by following the directions at the link here. Works great now. Hope 3CX applies this link to their knowledge base somewhere as well for other Linode customers. OVH did not work well for us at all being in Canada.
     
  10. chocoloco

    Joined:
    Jul 15, 2017
    Messages:
    1
    Likes Received:
    0
    It appears the similar issue can be found on 15.5. Is there anyway to resolve this as the above suggestion does not work.
     
Thread Status:
Not open for further replies.