Dismiss Notice
We would like to remind you that we’re updating our login process for all 3CX forums whereby you will be able to login with the same credentials you use for the Partner or Customer Portal. Click here to read more.

Can't Install on XOOM

Discussion in 'Android' started by KerryG, Apr 20, 2011.

Thread Status:
Not open for further replies.
  1. KerryG

    KerryG Active Member

    Joined:
    Jun 19, 2009
    Messages:
    960
    Likes Received:
    0
    The app wont even show in the market for the Motorola XOOM. Would love to test it but its not there to install.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  2. leejor

    leejor Well-Known Member

    Joined:
    Jan 22, 2008
    Messages:
    11,073
    Likes Received:
    323
    I've discovered that, that usually means it isn't compatible with the Android version you are running. There is obviously a data transfer that lets the Market know what device and version you are running. Although, there are certain apps that I know arecompatible (at least with the the version), and they still don't show up. Frustrating. I've had to Root, then use the terminal app to move the files from one to the other via the sdcard.
     
  3. KerryG

    KerryG Active Member

    Joined:
    Jun 19, 2009
    Messages:
    960
    Likes Received:
    0
    Correct, the XOOM is running Honeycomb. If there is a link to the APK I can try to install it.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  4. leejor

    leejor Well-Known Member

    Joined:
    Jan 22, 2008
    Messages:
    11,073
    Likes Received:
    323
    Has it been confirmed, that the new release, it is supported on Android 2.3?
     
  5. KerryG

    KerryG Active Member

    Joined:
    Jun 19, 2009
    Messages:
    960
    Likes Received:
    0
    It doesn't appear in the market so I have no way to test it.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  6. Vali_3CX

    Vali_3CX Well-Known Member
    Staff Member 3CX Support

    Joined:
    Dec 12, 2008
    Messages:
    1,526
    Likes Received:
    71
    Hi Kerry

    I cannot attach it here, I don't know why, so please send me by PM an eMail address and I will send it to you to try.
    Regards
    vali

    P.S it has been tested on:
    - HTC Desire: Android 2.2, build 2.29.405.5
    - HTC Wildfire : Android 2.2, build 2.22.405.1
    - Samsung GT-I9000: Android 2.2 build Froyo.XXJPO
    - Sony Ericsson Xperia U20i: Android 2.1 build 2.1.1.A.0.6
    - Samsung GT-I5800: Android 2.1 build Eclair.XWJG8
    - Sony Ericsson Xperia X10i: Android 2.0, build 2.0.2.A.0.24

    Known issues:
    - GT-I5800: switching Speaker/Earpiece is disabled during call
    - GT-I5900: volume adjustment by device's volume button has no effect
    - cannot register on a provider which requires an Auth ID different than User.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  7. rancho

    Joined:
    Jun 14, 2011
    Messages:
    25
    Likes Received:
    2
    Bit of an old thread but in http://www.3cx.com/forums/3cxphone-for-android-un-supported-devices-20713.html#p104255 there is a quoted statement stating that the Motorola Xoom Android 3.1 is supported. In fact, the Xoom Android Honeycomb 3.1 is listed as being supported at AppBrain. If all this is true, why do I get an error when I try to install it.

    3CXPhone shows up in the market as Version 1.2.11 released June 15, 2011. It will not show up on a search but will show when linking to the app from AppBrain.

    When I try to install I get an error that says "Purchase cancelled, 3CXPhone for Android (VoIP); Your device is not compatible with this item."

    Come on 3CX, fix this.
    :evil:
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  8. Vali_3CX

    Vali_3CX Well-Known Member
    Staff Member 3CX Support

    Joined:
    Dec 12, 2008
    Messages:
    1,526
    Likes Received:
    71
    Rancho, please check your PM.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  9. KerryG

    KerryG Active Member

    Joined:
    Jun 19, 2009
    Messages:
    960
    Likes Received:
    0
    I have it installed and working on my Xoom Wifi
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  10. rancho

    Joined:
    Jun 14, 2011
    Messages:
    25
    Likes Received:
    2
    Where did you get the install file? The one I got from the market does not install and gives an error saying my device is not compatible.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  11. StefanW

    StefanW Head of Customer Support and Training
    Staff Member 3CX Support

    Joined:
    Jun 2, 2009
    Messages:
    1,222
    Likes Received:
    93
    guys check androidpid.com or slideme.org there you will find them as well publicly
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  12. Vali_3CX

    Vali_3CX Well-Known Member
    Staff Member 3CX Support

    Joined:
    Dec 12, 2008
    Messages:
    1,526
    Likes Received:
    71
    For everybody interested, there is an updated - but not released on Android Market - version, numbered 1.2.11.43

    http://www.3cx.com/downloads/3CXPhone.apk

    Compared to the released (1.2.11.41) this version provide following significant fixes:
    - displaying of remote caller id on incoming calls
    - proper handling of non-standard server port on INVITE
    - recording of both audio streams
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  13. rancho

    Joined:
    Jun 14, 2011
    Messages:
    25
    Likes Received:
    2
    This one installed on my Xoom without a problem. Works great on my LAN. Just wish it could use the 3CX tunnel like 3CXPhone does. That would allow me to use it on my smart phone through 4G while out and about. My PBX is on a public facing IP but it seems without 3CX tunnel, remote use is not possible.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  14. rancho

    Joined:
    Jun 14, 2011
    Messages:
    25
    Likes Received:
    2
    Well, as I was viewing a video at the VoIPStore I noticed a setting for extensions that I had not considered. So in the PBX settings for the extension assigned to my Android phone, in the 'Other' tab, under the 'Extension options', I unchecked 'Disallow use of extension outside the LAN', and sved the change. Lo and behold, my Android 3CX registered. So I tested it and it worked. :) Something I am noticing, however, with the output audio set to 'Earpiece' and the volume cranked all the way up, the audio is barely audible. I guess I'll post this issue to another topic. :cry:
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Thread Status:
Not open for further replies.