Can't receive incoming calls

Discussion in '3CX Phone System - General' started by abinns, Apr 10, 2007.

Thread Status:
Not open for further replies.
  1. abinns

    Joined:
    Apr 10, 2007
    Messages:
    3
    Likes Received:
    0
    I have 6 PSTN lines coming into a Grandstream GXW-4108. I can call out on the lines, transfer, conference, etc. Whenever I call any of the phone numbers, I get this debug info:

    Endpoint::findSource Can not find source by following specs: From: 'unknown'; To: '10000'; Rline: '10000'; Contact: '10000'

    I've tried forwarding all numbers to extension 100, I've also tried having them forward to a ring group with extension 150 (which encompasses 8 extensions). None of this has helped (and I doubted that it would have!). I've read one post that explains a little about it (http://www.3cx.com/forums/viewtopic.php?t=1035), but I still couldn't quite understand it.

    I have set up and registered all 6 lines with internal extensions of 10000-10005.

    What am I ding wrong? Thanks!
     
  2. Costas3CX

    Costas3CX New Member

    Joined:
    Jan 23, 2007
    Messages:
    217
    Likes Received:
    0
    Check the advanced configuration for the grandstream from the management console. Go to "Lines/Manage/click on the name of your gateway not the number/Show advanced options. Make sure that "Line-ID location in 'user' part of:" is in "To" field instead of "from".

    And "Line-ID matching:" is in external

    let me know if this solved the problem. Remember what the initial conf was in case this doesn't work to return to default state.
     
  3. abinns

    Joined:
    Apr 10, 2007
    Messages:
    3
    Likes Received:
    0
    Didn't seem to work

    Hi, that didn't seem to do the trick. I still come up with the same error msg in the Server Status screen.

    -Andrew
     
  4. archie

    archie Well-Known Member
    3CX Support

    Joined:
    Aug 18, 2006
    Messages:
    1,309
    Likes Received:
    0
    Re: Didn't seem to work

    Sorry, Line-ID matching should be 'Internal number'
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Thread Status:
Not open for further replies.