Can't receive incomming calls to 3CX

Discussion in '3CX Phone System - General' started by henlon, Jan 4, 2007.

  1. henlon

    Joined:
    Jan 3, 2007
    Messages:
    8
    Likes Received:
    0
    I'm connected to the swedish VOIP privider Cellip AB. I use their services with both standalone IP phones and software phones like X-lte and there are no problems.
    I use a Linksys RT31P2 router/firewall.
    When I connect the 3CX PBX to my provider it get registred and I can see the name of the PBX and ip address.
    When I try to call one of the two installed numbers the 3CX doesen't answer.
    I can make outbound calls even if it take some time for the call to establish.
    When I contacted my VOIP provider they told me to set the function "send internal ip always".
    I can't find such parameter.

    How do I proceed?
     
  2. henlon

    Joined:
    Jan 3, 2007
    Messages:
    8
    Likes Received:
    0
    Can someone help me with this issue?
     
  3. Watashi_FR

    Joined:
    Dec 5, 2006
    Messages:
    63
    Likes Received:
    0
    Assuming that your 3CX is on the LAN-side of your router, have you set NAT to the 3CX appropriately? If outbound works but inbound doesn't, that's the first place to check.
     
  4. henlon

    Joined:
    Jan 3, 2007
    Messages:
    8
    Likes Received:
    0
    Yes it's on the LAN side of the router.
    Why does the incoming calls reach their targets if I use a standalone softphone like X-lite.

    I have two sip-phones connected on the LAN thru the same router/firewall and they works fine.

    When I read the logfile of 3CX it's empty.

    One mysterious thing is that it takes so long time for the outbound calls to reach there receivers.

    This problem doesent appear in the standalone phone's

    What about the "Send internal IP always"?
     
  5. Watashi_FR

    Joined:
    Dec 5, 2006
    Messages:
    63
    Likes Received:
    0
    Your softphones, when connected directly to your VoIP provider, connect to a server across the router. This means that they use client NAT (outgoing) to reach the SIP server on the internet, who is then aware of their existance and knows how to reach them. When you run 3CX, it will register to your VoIP provider as an endpoint, indicating that it is listening for incoming calls. Incoming calls are then routed to your external IP address, which should be listening on port 3478 (the SIP port) and should have several ports available (depending on the number of incoming lines your VoIP provider supplies) for the actual calls. If you do not configure your router to forward (using inbound NAT) incoming requests on port 3478 to your 3CX server, no incoming call will ever ring. The 3CX server logs remain empty because the server never receives the calls.

    About the "send internal IP" option, I can't say, this may be provider specific.
     
  6. henlon

    Joined:
    Jan 3, 2007
    Messages:
    8
    Likes Received:
    0
    Thank's for your advice.

    I'll try to do the arrangement's in my router.
     

Share This Page