Can't Register from Outside Local Network

Discussion in 'Android' started by Nanogeek, Jan 28, 2016.

Thread Status:
Not open for further replies.
  1. Nanogeek

    Joined:
    Jan 28, 2016
    Messages:
    8
    Likes Received:
    0
    Hello All,

    Been trying to fix this problem for the better part of the day. Setting up everything else was easy.

    My android phone will register and be ready to use when I'm on Wi-Fi (The Local Network).

    However, when I disable WiFi, it says "Disconnected - Registering". After Sometime it times out.

    I've setup the following port fowarding (Note: I'm using port 5080 for SIP rather than 5060)

    TCP & UDP: 5080
    UDP: 9000-9255
    UDP: 5090
    TCP: 5000 (Abyss Port, IIS is used for Remote login)
    TCP: 5001 (Abyss Port)
    TCP: 5228-5230 (PUSH Setup)

    The firewall and DNS checkers both report that everything is good.

    I've activated PUSH and setup the appropriate Google information. I've set my otuside hosted DNS to: pbx.XXXX.com and added an (A) name in my local DNS for: pbx.XXXX.local

    I'm at a lose and I'm sure it's probably something I'm overlooking. I've even disabled the firewall on the router and the server for testing, and it still has the issue.

    Any help would be greatly appreciated.
     
  2. leejor

    leejor Well-Known Member

    Joined:
    Jan 22, 2008
    Messages:
    10,586
    Likes Received:
    252
    Possibly, one of two things...

    In the extension settings (in the PBX), the option to allow outside registrations, is not set correctly.

    The Domain Name you are using in the registration, has not been entered in the PBX, this will cause rejection.


    The 3CX server logs should be able to confirm why you are unable to register.
     
  3. Nanogeek

    Joined:
    Jan 28, 2016
    Messages:
    8
    Likes Received:
    0
    I searched through Extensions and could not find a checkbox for allowing or dis-allowing registration. FWIW, I'm using the provisioning file that gets automatically sent into the e-mail.

    As far as domain name. Under Network>FQDN. My FQDN is pbx.XXX.com , which would be correct (assuming this is the outside DNS record that is setup).

    Could there be a problem that internal DNS uses .local vs. external using .com (Our domain is YYYY.local, where as our external is XXXX.com)

    Thank you for your help!
     

    Attached Files:

  4. Nanogeek

    Joined:
    Jan 28, 2016
    Messages:
    8
    Likes Received:
    0
    ~~~~FIXED~~~~~

    It was a problem with 3CX Tunnel. I turned it off on the phone (and in the settings) and it works now.

    This is a Mobile only extension, so I assume Tunnel causes it to mess up since it doesn't have anything to tunnel to.

    Happy that I finally got it. Such a simple setting, causing all sorts of problems, lol
     
  5. NickD_3CX

    NickD_3CX Support Team
    Staff Member 3CX Support

    Joined:
    Jun 2, 2014
    Messages:
    1,283
    Likes Received:
    68
    The reason why it doesn't work with the Tunnel enabled is because it happens that port 5080 is used internally by the Tunnel service (5090 external listening port, 5080 internal listening port). If you change the SIP Port to anything else that is not used by the system like e.g. port 5079, 6080, etc, you should be able to connect remotely via Tunnel.
     
Thread Status:
Not open for further replies.