Dismiss Notice
We would like to remind you that we’re updating our login process for all 3CX forums whereby you will be able to login with the same credentials you use for the Partner or Customer Portal. Click here to read more.

Change number the softphone dials for VM

Discussion in 'Windows' started by filemakers, May 21, 2011.

Thread Status:
Not open for further replies.
  1. filemakers

    Joined:
    May 20, 2011
    Messages:
    4
    Likes Received:
    0
    I was prompted to enter the mailbox number for voicemail on the 3cx softphone client, I stupidly entered the phone numer of the extension, and now I am unable to change it to the correct VM extension number, I have tried editing the line PBXVoicemail=101 in the local 3CXVoipPhone.ini on my pc, to the correct VM number, however everytime I restart the client it resets back to the 101 that I put in originally.

    The Server has been changed to a number away from 999 as I am in the uk, however this doesnt seem to carry down.

    I am guessing it has stored it on the server somewhere, but I have no idea where to start looking, I am a newbee to 3cx and voip systems in general, however a IT technician, I am guessing there is some kind of provisioning file per extension stored? Can anyone tell me how to correct my faux pas.

    Thanks in advance.
     
  2. filemakers

    Joined:
    May 20, 2011
    Messages:
    4
    Likes Received:
    0
    Ok... Sorry, I have managed to work out how to do it, the fix was as follows, close the softphone, edit the file, change the line entry listed previously and then save it, then make the file read only, reopen the client and then make the file not read only again, after reopening the phone again after the file was writable has seemed to update the softphone permanently.
     
  3. Vali_3CX

    Vali_3CX Well-Known Member
    Staff Member 3CX Support

    Joined:
    Dec 12, 2008
    Messages:
    1,526
    Likes Received:
    71
    Hi
    Looks far too complicated. Open account's Advanced Settings dialog, then try to change there "PBX voicemail" parameter and see if is working.
    Regards
    vali
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Thread Status:
Not open for further replies.