Dismiss Notice
We would like to remind you that we’re updating our login process for all 3CX forums whereby you will be able to login with the same credentials you use for the Partner or Customer Portal. Click here to read more.

Changes to inbound rule not taking effect

Discussion in '3CX Phone System - General' started by jbg77, Jun 27, 2009.

Thread Status:
Not open for further replies.
  1. jbg77

    Joined:
    Jun 27, 2009
    Messages:
    2
    Likes Received:
    0
    Hello,
    I have a strange problem. Changes to my only inbound rule are not taking effect, even though they appear changed and look correct in the GUI. No matter how I change the inbound rule, it still follows the original rule I created, which was to forward to extension 102. I'm running 3cx free edition version 7.1.7139.0 and have a very simple setup:
    callcentric sip trunk used for outbound and providing my only DID
    1 extension uses a Linksys SPA921 phone
    2 extensions use xlite softphones
    The log shows an inbound rule being followed that no longer exists, at least according to the web interface. Anyone have any ideas? Thanks.

    01:19:38.968 [CM503024]: Call(3): Calling Ext:Ext.102@[Dev:sip:102@75.150.76.132:5060]

    01:19:38.968 [MS210002] C:3.2:Offer provided. Connection(transcoding mode): 75.150.76.129:7004(7005)

    01:19:38.953 [CM503004]: Call(3): Route 1: Ext:Ext.102@[Dev:sip:102@75.150.76.132:5060]

    01:19:38.953 [CM503010]: Making route(s) to <sip:102@75.150.76.129:5060>

    01:19:38.953 [MS210000] C:3.1:Offer received. RTP connection: 204.11.192.36:52750(52751)

    01:19:38.953 Remote SDP is set for legC:3.1

    01:19:38.953 [CM505003]: Provider:[CallCentric] Device info: Device Not Identified: User Agent not matched; Capabilities: [reinvite, replaces, able-no-sdp, recvonly] UserAgent: [] Transport: [sip:75.150.76.129:5060]

    01:19:38.921 [CM503001]: Call(3): Incoming call from 15087405663@(Ln.10003@CallCentric) to <sip:102@75.150.76.129:5060>

    01:19:38.921 [CM503012]: Inbound out-of-office hours rule (unnamed) for 10003 forwards to DN:102
    01:19:38.921 Looking for inbound target: called=15087390820; caller=15087405663

    01:19:38.875 [CM500002]: Info on incoming INVITE: INVITE sip:17772062540@75.150.76.129:5060;rinstance=fb1b771f9ab4aa9b SIP/2.0 Via: SIP/2.0/UDP 204.11.192.36:5060;branch=z9hG4bK-490d1054c2d18b2912a8df201c519639 Max-Forwards: 15 Contact: <sip:715af1128200720c9792b42a2111f74e@204.11.192.36:5060;transport=udp> To: <sip:15087390820@ss.callcentric.com> From: <sip:15087405663@66.193.176.35>;tag=3455068771-706789 Call-ID: 24857229-3455068771-706761@msw1.telengy.net CSeq: 1 INVITE Supported: timer Content-Length: 0
     
  2. bluetel2

    bluetel2 Member

    Joined:
    Oct 16, 2008
    Messages:
    377
    Likes Received:
    8

    hello. how many have you incomming interface ? for exempe patton 4638 have 4 inbound interface, such you must parameter the 4 inbound line with your rules.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. jbg77

    Joined:
    Jun 27, 2009
    Messages:
    2
    Likes Received:
    0
    Thanks, but I figured it out. I needed to prepend my DID with a 1 in the rule definition.
     
Thread Status:
Not open for further replies.