Dismiss Notice
We would like to remind you that we’re updating our login process for all 3CX forums whereby you will be able to login with the same credentials you use for the Partner or Customer Portal. Click here to read more.

CID not being passed on to parallel ringing mobile

Discussion in '3CX Phone System - General' started by teichhei, Oct 5, 2012.

Thread Status:
Not open for further replies.
  1. teichhei

    Joined:
    Oct 11, 2009
    Messages:
    29
    Likes Received:
    1
    Hi,

    I set the field from:display number to be the originator CID and with the new verbose log (great feature, thanks for that) I can see that the CID that came in through the pstn gateway is passed on to the outbound invite, forwarding to the mobile.
    Unfortunately it contains a leading 0, because that's what you need everywhere else in the pbx. I played around in the "manipulate CID" settings but all I could get was a 49097... instead of a 4997...
    Ist there a way to manipulate outbound CIDs on a trunk to simply remove the leading 0 or replace it with a constant? I only found a way to set a prefix, but not to replace a digit. Sipgate wants the format without leading 0 and doesn't accept anything else.
    I know it will cause trouble for incoming international calls but those would just come through as the DID anyway.
    If there is a way to make 004997... to be 4997... and 097... to 97... it would fix the problem and allow me to send correct extension DIDs to other providers than Sipgate. I thought that "reformat CID" in the trunk settings would do that, but I can't figure out how.

    br

    Heinz
     
  2. mixig

    mixig Active Member

    Joined:
    Dec 13, 2011
    Messages:
    530
    Likes Received:
    12
    Hi,

    try with this (attach), maybe will help
     
  3. teichhei

    Joined:
    Oct 11, 2009
    Messages:
    29
    Likes Received:
    1
    Hi, I tried a lot with those settings, with no real logic results.
    I set up all fields in both involved trunks according to the location. The result on the inbound trunk (as described in the 3CX blog to get a correct format internally) is:

    Specified international prefix (0) doesn't match given number '097...'
    Check your reformat inbound caller ID rule for Lc:10023(@T-Com BRI[<sip:10023@192.168.10.235:5060>

    International prefix is by the way 00, not 0
    And the outbound leg does this:

    Route to L:97.8[Line:10013>>0172...] sends Invite-OUT Send Req INVITE from 0.0.0.0:0 tid=882e072bcd2e422b Call-ID=NTIwMzg3NmQ1YjBlZWZjM2U4NjQ0NWMzZWVjMmI2ZmM.:
    INVITE sip:0172...@sipgate.de:5060 SIP/2.0
    Via: SIP/2.0/ ;branch=z9hG4bK-d8754z-882e072bcd2e422b-1---d8754z-;rport
    Max-Forwards: 70
    Contact: <sip:11...@xxx.xx.xxx.xxx:5060>
    To: <sip:0172...@sipgate.de:5060>
    From: "00097..."<sip:11...@sipgate.de:5060>;tag=395e1e16
    Call-ID: NTIwMzg3NmQ1YjBlZWZjM2U4NjQ0NWMzZWVjMmI2ZmM.
    CSeq: 1 INVITE
    Allow: INVITE, ACK, CANCEL, OPTIONS, BYE, REGISTER, SUBSCRIBE, NOTIFY, REFER, INFO, MESSAGE
    Content-Type: application/sdp
    Supported: replaces
    Content-Length: 258


    Bottom line is that 3CX doesn't take the zero off the inbound CID and happy adds heaps of zeros to the outbound number. Only keeping the boxes ticked at the outbound options doesn't change the number at all.
    Is that feature supposed to work? I found some comments saying that it is not working and would hopefully be changed in V10.
    It would be easier to apply just a set of rules for inbound and outbound CIDs, like the outbound route rules are made up.
    Maybe I'm just dumb. I just can't believe that there is nobody else with a similar problem using ring groups that forward to mobiles.
    Provided that the provider allows changing the CID.
     
Thread Status:
Not open for further replies.