Dismiss Notice
We would like to remind you that we’re updating our login process for all 3CX forums whereby you will be able to login with the same credentials you use for the Partner or Customer Portal. Click here to read more.

CID transfer problem (PSTN>SPA3102>3CX) (SOLVED)

Discussion in '3CX Phone System - General' started by Halea, Jan 5, 2008.

Thread Status:
Not open for further replies.
  1. Halea

    Halea New Member

    Joined:
    Jan 5, 2008
    Messages:
    151
    Likes Received:
    0
    My PSTN supplier is actually OptimumVoice. When I connect a phone to it I get to see caller's name and phone number. So, OV seems to be OK.
    My SPA3102 is setup with "PSTN to VOIP" enabled and configured with defaults (which seems to indicate that CID transfer from PSTN to VOIP is turned on). When I receive a PSTN call my VOIP phone connected through 3CX shows "SPA-3102" and "10001" as caller's name and number, which I believe are the info that I entered in SPA3102 in the "VOIP Line Registration" settings.
    Other than the CID issue, everything else works fine. Can call in and out with top quality sound.
    I am trying to properly configure so that I get to see the PSTN caller's real name and phone number. Any help will be appreciated.
     
  2. Halea

    Halea New Member

    Joined:
    Jan 5, 2008
    Messages:
    151
    Likes Received:
    0
    Re: CID transfer problem (PSTN>SPA3102>3CX)

    After firmware upgrade to 5.1.7 and lots of playing around with settings, I am still at the same point. CID from PSTN is caught by SPA3102 (since it can actually show it at the end of the communication on the infor page), it never gets transfered to 3CX. :cry:
    Any help will be appreciated.
    Halea
     
  3. miraportuga

    miraportuga Member

    Joined:
    Aug 7, 2007
    Messages:
    297
    Likes Received:
    0
    Re: CID transfer problem (PSTN>SPA3102>3CX)

    Make sure that on the PSTN Line tab you have PSTN CID to Voip CID enabled....

    Cheers
     
  4. Halea

    Halea New Member

    Joined:
    Jan 5, 2008
    Messages:
    151
    Likes Received:
    0
    Finally I solved the CID problem. I setup SPA-3102 with a 5 second delay in picking up the PSTN line when a call comes in. It did the trick. Inserting a delay in 3CX didn't help. :roll:
    Halea
     
Thread Status:
Not open for further replies.