Dismiss Notice
We would like to remind you that we’re updating our login process for all 3CX forums whereby you will be able to login with the same credentials you use for the Partner or Customer Portal. Click here to read more.

Cisco 2620XM Gateway

Discussion in '3CX Phone System - General' started by home, Aug 9, 2009.

Thread Status:
Not open for further replies.
  1. home

    Joined:
    Feb 25, 2009
    Messages:
    31
    Likes Received:
    0
    Hi
    I am looking for a little help or suggestions,

    1/ Can anyone please tell me what is required from a device in order for it to register within 3CX ( other than username password etc ) as I am using a Cisco 2620XM, which if told it needs to register shows red and fails to work, but if told registration not required appears green and functions.

    2/ I have a
    Cisco 2620XM (MPC860P) processor (revision 4.1) with 98304K/32768K bytes of memo
    ry.
    Processor board ID FCZ092773CG
    M860 processor: part number 5, mask 2
    1 FastEthernet interface
    1 ATM interface
    2 Voice FXO interfaces
    2 Voice FXS interfaces
    32K bytes of NVRAM.
    32768K bytes of processor board System flash (Read/Write)

    Configuration register is 0x2102

    I can make a call over PSTN okay, but an incoming call is answered and imediately ( 1ring) then dialtone for 10 secs then engaged tone and finally hangs up.
    Copy of log entry


    10:07:06.377 [CM503008]: Call(7): Call is terminated
    10:06:21.814 Session 515 of leg C:7.1 is confirmed
    10:06:21.533 [CM503007]: Call(7): Device joined: sip:*******@sip2.plus.net:5060
    10:06:21.517 [CM503007]: Call(7): Device joined: sip:11@192.168.69.202:5060;transport=udp
    10:06:21.517 [MS210001] C:7.2:Answer received. RTP connection[unsecure]: 194.165.60.134:13254(13255)
    10:06:21.502 Remote SDP is set for legC:7.2
    10:06:19.002 [MS210005] C:7.1:Answer provided. Connection(proxy mode):192.168.69.1:7018(7019)
    10:06:19.002 [MS210001] C:7.2:Answer received. RTP connection[unsecure]: 194.165.60.134:13254(13255)
    10:06:19.002 Remote SDP is set for legC:7.2
    10:06:18.986 [CM505003]: Provider:[Plus Net] Device info: Device Not Identified: User Agent not matched; Capabilities:[reinvite, replaces, able-no-sdp, recvonly] UserAgent: [] PBX contact: [sip:*******@80.229.218.96:5060]
    10:06:18.986 [CM503002]: Call(7): Alerting sip:*******@sip2.plus.net:5060
    10:06:17.127 [CM503025]: Call(7): Calling VoIPline:01553******@(Ln.10001@Plus Net)@[Dev:sip:*******@sip2.plus.net:5060]
    10:06:17.127 [MS210004] C:7.2:Offer provided. Connection(proxy mode): 80.229.218.96:9006(9007)
    10:06:17.095 [CM503004]: Call(7): Route 1: VoIPline:01553******@(Ln.10001@Plus Net)@[Dev:sip:*******@sip2.plus.net:5060]
    10:06:17.080 [CM503010]: Making route(s) to <sip:01553******@192.168.69.1>
    10:06:17.080 [MS210000] C:7.1:Offer received. RTP connection: 192.168.69.202:32184(32185)
    10:06:17.080 Remote SDP is set for legC:7.1
    10:06:17.080 [CM505001]: Ext.11: Device info: Device Not Identified: User Agent not matched; Capabilities:[reinvite, replaces, unable-no-sdp, no-recvonly] UserAgent: [Cisco-CP7940G/8.0] PBX contact: [sip:11@192.168.69.1:5060;transport=udp]
    10:06:17.064 [CM503001]: Call(7): Incoming call from Ext.11 to <sip:01553******@192.168.69.1>
    10:06:17.064 [CM500002]: Info on incoming INVITE:
    INVITE sip:01553******@192.168.69.1 SIP/2.0
    Via: SIP/2.0/UDP 192.168.69.202:5060;branch=z9hG4bK44095750
    Max-Forwards: 70
    Contact: <sip:11@192.168.69.202:5060;transport=udp>
    To: <sip:01553******@192.168.69.1>
    From: "11"<sip:11@192.168.69.1>;tag=0015629f94bc16234d8d445b-5149d6b4
    Call-ID: 0015629f-94bc0031-0e1a5ee0-09101e19@192.168.69.202
    CSeq: 102 INVITE
    Expires: 180
    Accept: application/sdp
    Allow: ACK, BYE, CANCEL, INVITE, NOTIFY, OPTIONS, REFER, REGISTER, UPDATE
    Date: Sun, 09 Aug 2009 09:08:37 GMT
    Proxy-Authorization: Digest username="11",realm="3CXPhoneSystem",uri="sip:01553******@192.168.69.1",response="1be03608fe7bb106a82b74e77c0f92a5",nonce="414d535c008f228890:940d563e763b0e296002824309316bd1",algorithm=MD5
    Supported: replaces, join, norefersub
    User-Agent: Cisco-CP7940G/8.0
    Content-Length: 0

    Any help would be good

    Thanks in advance
     
  2. home

    Joined:
    Feb 25, 2009
    Messages:
    31
    Likes Received:
    0
    All done, Cisco 2620XM, now acting as a PSTN gateway for 3CX, a few nights of wireshark, cisco books and internet, but its done.
     
  3. ciscotech2007

    Joined:
    Jan 27, 2009
    Messages:
    94
    Likes Received:
    0
    Home,

    please post your cisco config for all to learn... some people are interested in using cisco routers as gateways with 3cx. I presume your using a 2620 with E1 and FXO VIC... please include your hardware models that your using as well...thanks!
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  4. home

    Joined:
    Feb 25, 2009
    Messages:
    31
    Likes Received:
    0
    Hi Ciscotech,
    Will post config later this evening, hardware as previous post.

    Home
     
  5. home

    Joined:
    Feb 25, 2009
    Messages:
    31
    Likes Received:
    0
    Hi
    Config for router, this config allows a pstn call to come in via a FXO port and be handle by 3CX, and also to make a pstn call. I have also plugged a pstn handset into a FXS port and can make a call from this ( not through 3CX ) although having a small problem of hiss.
    If anybody uses this and improves it all ideas gratefully received, in 3CX gateway does not require registration, as it appears cisco sends a wilcard .*@ , I have yet to figure a work around.

    VoIP#sh conf
    Using 9806 out of 29688 bytes
    !
    ! Last configuration change at 20:36:29 London Wed Aug 12 2009 by theshire
    ! NVRAM config last updated at 20:36:40 London Wed Aug 12 2009 by theshire
    !
    version 12.4
    no service pad
    service tcp-keepalives-in
    service tcp-keepalives-out
    service timestamps debug datetime msec localtime show-timezone
    service timestamps log datetime msec localtime show-timezone
    service password-encryption
    service sequence-numbers
    !
    hostname VoIP
    !
    boot-start-marker
    boot-end-marker
    !
    security authentication failure rate 3 log
    security passwords min-length 6
    logging buffered 4096 debugging
    enable secret 5 $1$hq/5$Hj4UWad0apDcV9iJ6g57K1
    !
    aaa new-model
    !
    !
    aaa authentication login local_authen local
    aaa authorization exec local_author local
    !
    aaa session-id common
    memory-size iomem 25
    clock timezone London 0
    clock summer-time London date Mar 30 2003 1:00 Oct 26 2003 2:00
    no network-clock-participate slot 1
    no network-clock-participate wic 0
    no ip source-route
    ip cef
    !
    !
    !
    !
    no ip bootp server
    ip domain name **************
    ip name-server 208.67.222.222
    ip name-server 208.67.220.220
    !
    !
    !
    voice service pots
    !
    voice service voip
    allow-connections h323 to h323
    allow-connections h323 to sip
    allow-connections sip to h323
    allow-connections sip to sip
    sip
    !
    !
    !
    voice class codec 1
    codec preference 1 g729r8 bytes 40
    codec preference 2 g711ulaw
    codec preference 3 g723r63 bytes 96
    codec preference 4 g726r16 bytes 80
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    crypto pki trustpoint TP-self-signed-1766898624
    enrollment selfsigned
    subject-name cn=IOS-Self-Signed-Certificate-1766898624
    revocation-check none
    rsakeypair TP-self-signed-1766898624
    !
    !
    crypto pki certificate chain TP-self-signed-1766898624
    certificate self-signed 01 nvram:IOS-Self-Sig#3434.cer
    username ******** privilege 15 password 7 011B0906590212
    !
    !
    ip tcp synwait-time 10
    !
    !
    !
    interface Null0
    no ip unreachables
    !
    interface ATM0/0
    no ip address
    no ip redirects
    no ip unreachables
    no ip proxy-arp
    ip route-cache flow
    no atm ilmi-keepalive
    dsl operating-mode auto
    !
    interface ATM0/0.1 point-to-point
    description PlusNet
    no ip redirects
    no ip unreachables
    no ip proxy-arp
    pvc 0/38
    encapsulation aal5mux ppp dialer
    dialer pool-member 1
    !
    !
    interface FastEthernet0/0
    description LAN$ETH-LAN$$FW_INSIDE$
    ip address 192.168.69.2 255.255.255.0
    no ip redirects
    no ip unreachables
    no ip proxy-arp
    ip nbar protocol-discovery
    ip flow ingress
    ip flow egress
    ip nat inside
    ip route-cache flow
    duplex auto
    speed auto
    no mop enabled
    !
    interface Dialer0
    description $FW_OUTSIDE$
    ip address ************** 255.255.255.0
    no ip redirects
    no ip unreachables
    no ip proxy-arp
    ip nbar protocol-discovery
    ip flow ingress
    ip flow egress
    ip nat outside
    encapsulation ppp
    ip route-cache flow
    dialer pool 1
    dialer-group 1
    ppp authentication chap pap callin
    ppp chap hostname ***********@plusdsl.net
    ppp chap password 7 020105550F070327
    ppp pap sent-username ********************* password 7 020105550F070327
    ppp multilink
    !
    ip forward-protocol nd
    ip route 0.0.0.0 0.0.0.0 Dialer0
    ip flow-top-talkers
    top 25
    sort-by bytes
    cache-timeout 200
    !
    ip http server
    ip http access-class 2
    ip http authentication local
    ip http secure-server
    ip nat inside source list 1 interface Dialer0 overload
    ip nat inside source static udp 192.168.69.1 9049 interface Dialer0 9049
    ip nat inside source static udp 192.168.69.1 9048 interface Dialer0 9048
    ip nat inside source static udp 192.168.69.1 9047 interface Dialer0 9047
    ip nat inside source static udp 192.168.69.1 9046 interface Dialer0 9046
    ip nat inside source static udp 192.168.69.1 9045 interface Dialer0 9045
    ip nat inside source static udp 192.168.69.1 9044 interface Dialer0 9044
    ip nat inside source static udp 192.168.69.1 9043 interface Dialer0 9043
    ip nat inside source static udp 192.168.69.1 9042 interface Dialer0 9042
    ip nat inside source static udp 192.168.69.1 9041 interface Dialer0 9041
    ip nat inside source static udp 192.168.69.1 9040 interface Dialer0 9040
    ip nat inside source static udp 192.168.69.1 9039 interface Dialer0 9039
    ip nat inside source static udp 192.168.69.1 9038 interface Dialer0 9038
    ip nat inside source static udp 192.168.69.1 9037 interface Dialer0 9037
    ip nat inside source static udp 192.168.69.1 9036 interface Dialer0 9036
    ip nat inside source static udp 192.168.69.1 9035 interface Dialer0 9035
    ip nat inside source static udp 192.168.69.1 9034 interface Dialer0 9034
    ip nat inside source static udp 192.168.69.1 9033 interface Dialer0 9033
    ip nat inside source static udp 192.168.69.1 9032 interface Dialer0 9032
    ip nat inside source static udp 192.168.69.1 9031 interface Dialer0 9031
    ip nat inside source static udp 192.168.69.1 9030 interface Dialer0 9030
    ip nat inside source static udp 192.168.69.1 9029 interface Dialer0 9029
    ip nat inside source static udp 192.168.69.1 9028 interface Dialer0 9028
    ip nat inside source static udp 192.168.69.1 9027 interface Dialer0 9027
    ip nat inside source static udp 192.168.69.1 9026 interface Dialer0 9026
    ip nat inside source static udp 192.168.69.1 9025 interface Dialer0 9025
    ip nat inside source static udp 192.168.69.1 9024 interface Dialer0 9024
    ip nat inside source static udp 192.168.69.1 9023 interface Dialer0 9023
    ip nat inside source static udp 192.168.69.1 9022 interface Dialer0 9022
    ip nat inside source static udp 192.168.69.1 9021 interface Dialer0 9021
    ip nat inside source static udp 192.168.69.1 9020 interface Dialer0 9020
    ip nat inside source static udp 192.168.69.1 9019 interface Dialer0 9019
    ip nat inside source static udp 192.168.69.1 9018 interface Dialer0 9018
    ip nat inside source static udp 192.168.69.1 9017 interface Dialer0 9017
    ip nat inside source static udp 192.168.69.1 9016 interface Dialer0 9016
    ip nat inside source static udp 192.168.69.1 9015 interface Dialer0 9015
    ip nat inside source static udp 192.168.69.1 9014 interface Dialer0 9014
    ip nat inside source static udp 192.168.69.1 9013 interface Dialer0 9013
    ip nat inside source static udp 192.168.69.1 9012 interface Dialer0 9012
    ip nat inside source static udp 192.168.69.1 9011 interface Dialer0 9011
    ip nat inside source static udp 192.168.69.1 9010 interface Dialer0 9010
    ip nat inside source static udp 192.168.69.1 9009 interface Dialer0 9009
    ip nat inside source static udp 192.168.69.1 9008 interface Dialer0 9008
    ip nat inside source static udp 192.168.69.1 9007 interface Dialer0 9007
    ip nat inside source static udp 192.168.69.1 9006 interface Dialer0 9006
    ip nat inside source static udp 192.168.69.1 9005 interface Dialer0 9005
    ip nat inside source static udp 192.168.69.1 9004 interface Dialer0 9004
    ip nat inside source static udp 192.168.69.1 9003 interface Dialer0 9003
    ip nat inside source static udp 192.168.69.1 9002 interface Dialer0 9002
    ip nat inside source static udp 192.168.69.1 9001 interface Dialer0 9001
    ip nat inside source static udp 192.168.69.1 9000 interface Dialer0 9000
    ip nat inside source static udp 192.168.69.1 5090 interface Dialer0 5090
    ip nat inside source static tcp 192.168.69.1 5090 interface Dialer0 5090
    ip nat inside source static udp 192.168.69.1 5082 interface Dialer0 5082
    ip nat inside source static udp 192.168.69.1 5066 interface Dialer0 5066
    ip nat inside source static udp 192.168.69.1 5065 interface Dialer0 5065
    ip nat inside source static udp 192.168.69.1 5064 interface Dialer0 5064
    ip nat inside source static udp 192.168.69.1 5063 interface Dialer0 5063
    ip nat inside source static udp 192.168.69.1 5062 interface Dialer0 5062
    ip nat inside source static udp 192.168.69.1 5061 interface Dialer0 5061
    ip nat inside source static udp 192.168.69.1 5060 interface Dialer0 5060
    ip nat inside source static tcp 192.168.69.1 443 interface Dialer0 443
    ip nat inside source static tcp 192.168.69.1 80 interface Dialer0 80
    ip nat inside source static tcp 192.168.69.1 25 interface Dialer0 25
    ip nat inside source static udp 192.168.69.2 123 interface Dialer0 123
    !
    logging trap debugging
    logging 192.168.69.1
    access-list 1 remark INSIDE_IF=FastEthernet0/0
    access-list 1 remark SDM_ACL Category=2
    access-list 1 permit 192.168.69.0 0.0.0.255
    access-list 2 remark HTTP Access-class list
    access-list 2 remark SDM_ACL Category=1
    access-list 2 permit 192.168.69.0 0.0.0.255
    access-list 2 deny any
    access-list 100 remark VTY Access-class list
    access-list 100 remark SDM_ACL Category=1
    access-list 100 permit ip 192.168.69.0 0.0.0.255 any
    access-list 100 deny ip any any
    dialer-list 1 protocol ip permit
    no cdp run
    !
    !
    control-plane
    !
    !
    !
    voice-port 1/0/0
    supervisory disconnect anytone
    output attenuation 0
    no comfort-noise
    cptone GB
    timing hookflash-out 50
    connection plar opx 10003
    impedance complex3
    description 3CX
    threshold noise -90
    station-id name 3CXPhoneSystem
    station-id number 01553773084
    !
    voice-port 1/0/1
    impedance complex3
    !
    voice-port 1/1/0
    disconnect-ack
    input gain 4
    output attenuation 4
    no comfort-noise
    cptone GB
    threshold noise -90
    caller-id enable
    !
    voice-port 1/1/1
    !
    !
    !
    !
    !
    dial-peer voice 10003 voip
    description 10003
    preference 1
    destination-pattern .T
    voice-class codec 1
    session protocol sipv2
    session target ipv4:192.168.69.1
    dtmf-relay rtp-nte
    no vad
    !
    dial-peer voice 10000 pots
    preference 1
    destination-pattern .T
    port 1/0/0
    !
    sip-ua
    authentication username 10003 password 091D1E594956
    retry invite 3
    retry response 3
    retry bye 3
    retry cancel 3
    timers expires 300000
    sip-server ipv4:192.168.69.1:5060
    !
    banner login ^CAccess is strictly forbidden, so please go away !^C
    !
    line con 0
    login authentication local_authen
    transport output telnet
    line aux 0
    login authentication local_authen
    transport output telnet
    line vty 0 4
    access-class 100 in
    authorization exec local_author
    login authentication local_authen
    transport input telnet ssh
    !
    scheduler allocate 4000 1000
    !
    end

    Hope this helps someone.

    Home
     
Thread Status:
Not open for further replies.